Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

H520 or just me

Joined
Jan 30, 2019
Messages
1
Reaction score
0
Age
41
Hello all,

I recently took out my H520, its been nearly 12 months.

I connected as normal, selecting the 'up' button on the controller. The h520 went up hovering at around 7ft, no control of the h520 at all. This isn't how I remembered it, I pressed land and got down safely. I'm feeling really rusty, I'm sure from hover I just took control and off I would go.

Have I missed something, really lacking confidence now. Any advise would be appreciated.

Thanks
Ted
 
Joined
Feb 5, 2021
Messages
114
Reaction score
64
Age
59
Location
Northern Italy, near Verona
Hi. After long time of no use, it's highly recommended to wait at lest 15 minutes before taking off, in order to give the GPS enough time to refresh satellites almanac.
You have to leave the drone powered on in open space, and I will say the controller too.
After a long time as you describe, it is also recommended to make new calibrations and check hw monitor on the controller for proper functioning of all sticks, buttons and switches.
Connect to GUI to check that all sensors are in proper working state.
In any case, NEVER take off immediately, always wait the acquiring of a sufficient number of satellites both on bird and controller, and check the altitude on ground is truthful.
May be other users who have this model can give you more advice, I fly an H480 but I think it's not so different from H520.
 
Joined
Sep 7, 2020
Messages
15
Reaction score
2
Age
64
This is the log of my last flight with H520 during a photogrammetric mission (1-4-2021) after a firmware update...
the same evening the touch display on st16s get broken.
Now I waiting the repair center sent it back and I'll try again when the uas is back..
 

Attachments

  • 2021-04-01_23-55-55.jpg
    2021-04-01_23-55-55.jpg
    361.6 KB · Views: 18
  • 166197456_508684526967273_4859889848178083104_n.jpg
    166197456_508684526967273_4859889848178083104_n.jpg
    756.4 KB · Views: 17
  • 167079172_157816526221421_6284684165447423744_n.jpg
    167079172_157816526221421_6284684165447423744_n.jpg
    2.1 MB · Views: 15

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
2,617
Reaction score
1,961
Location
North Carolina Piedmont, USA
Hello all,

I recently took out my H520, its been nearly 12 months.

I connected as normal, selecting the 'up' button on the controller. The h520 went up hovering at around 7ft, no control of the h520 at all. This isn't how I remembered it, I pressed land and got down safely. I'm feeling really rusty, I'm sure from hover I just took control and off I would go.

Have I missed something, really lacking confidence now. Any advise would be appreciated.

Thanks
Ted
It sounds like you need to check RC Monitor. When you said "no control of the h520 at all", did you mean your tried all the controls and nothing responded? Or did you mean you tried J1 and got zero response?
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
2,617
Reaction score
1,961
Location
North Carolina Piedmont, USA
This is the log of my last flight with H520 during a photogrammetric mission (1-4-2021) after a firmware update...
the same evening the touch display on st16s get broken.
Now I waiting the repair center sent it back and I'll try again when the uas is back..

David,
Di you post this in the wrong thread? I can move it to you original thread if that is where you wanted it to go.
 

New Threads

Members online

Forum statistics

Threads
19,576
Messages
227,087
Members
23,257
Latest member
Kick