Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

How to install new firmware on ST16E

Joined
Mar 5, 2024
Messages
14
Reaction score
2
Age
25
I have a H520E drone, but unfortunately there is no Yuneec firmware on ST16.
How to install new firmware on ST16 E and where to download it from?
 
I have a H520E drone, but unfortunately there is no Yuneec firmware on ST16.
How to install new firmware on ST16 E and where to download it from?
This link seems to have the H520E firmware:

It's not clear if you are only missing the Flight control APK, or if the other stuff related to an H520E is missing. If you could clarify what is missing, it would be easier for someone to help.
Does the controller boot up at all? If so, what screen does it come to?
 
Thank you for your reply and the link to download the files.
Only the pure android itself starts up without any other files (looks like Yuneec files cleared) just no others as if they were deleted and therefore I can't connect to the drone because there is no Yuneec startup screen.
 
How did the files come to be missing? That might give a clue about which files are still present.

It is not clear what you mean by "pure android" screen when the controller starts. Please indicate if one of these is what you see. Please provide a screenshot if none of these are correct:
1.jpg 2.jpg 3.jpg 4.jpg

It would be best to wait for @Enrico Jorysch, @joe@vertigodrones , or some of the other members familiar with ST16E prior to loading the files. There is a good bit of Forum history on H520E updates in general that make it seem like problems can occur if you are not familiar with the H520E system and how the updates work.

Also, I notice the file versions in the link provided above may not be as up to date as the versions available through the ST16E OTA update system. I do not have an actual ST16E and can't check all versions. However, the items the system would allow me to check are higher than the corresponding versions on the website linked above. An experienced H520E user might tell you to just use the OTA update (once you get the basic APK loaded.
Versions.jpg
 
Last edited:
Unfortunately this is the 1 screen (no screen 2 to 4), so as I wrote only android and no Yuneec files. I bought it as "damaged" so since I can't get into the drone I don't know what software version is here. What I really mean is to install what is on your screen 5, that is for further update. Everything should be OK with the drone, it starts up normally (even the LED in the OFDM module is on solid light) but unfortunately I can't be sure because I can't connect to it.
 
If the green screen (picture "1") is working:
You may only need to install the DataPilot2.
Do a fresh format of an SD card using FAT32 format. (other formats don't work)
Download the DataPilot.APK (v2.1.22) from the link in post #2. (You can update the APK later if needed.)
The APK will download as a zip file. Extract the zip file to the FAT32 formatted SD card.
Put the Card in the ST16E
Tap the Icon at the bottom of the green screen (picture "1")
Tap the file manager on picture "2".
Navigate to the SD Card
Tap the APK on the SD card.
You may have to follow a prompt to settings/security and check the "Unknown sources" box to "Allow installation of apps from unknown sources". If so, check the box, then use the return arrow to get back to the file manager screen and tap the APK again.
Follow the prompts to install the APK.
With the APK installed, you can check firmware versions and update as normal.
(This is very brief guidance. Please let us know if you need more details.)

IF the green screen (picture "1") is NOT working:
Please describe what happens. More advanced members may be able to suggest a way.
 
Last edited:
  • Like
Reactions: Steve Carr
Thank you for the detailed instructions so far it is half done: In my case when I put the card in the station it did not work I had to connect the station via the computer and after a few tries it went.
Unfortunately but it doesn't turn on like other drones to the screen only green first and I have to go through yuneec 2.0 further but still it doesn't connect to the drone only there is a map and it doesn't detect any networks (even home networks) and there is no camera and no drone. Most probably the OFDM module is faulty because it blinks and in another working one I saw that there is a continuous light.
I am sending some pics and videos to show the software deficiencies (no DataPilot, there is only DataPilot 2.0) and no UpdatePilot.
Please let me know how to install the missing files and what I can do about connecting the drone to the station.
 

Attachments

  • 20240327_113007 (Medium).jpg
    20240327_113007 (Medium).jpg
    69.7 KB · Views: 7
  • 20240327_114643 (Medium).jpg
    20240327_114643 (Medium).jpg
    132.4 KB · Views: 7
  • 20240327_115803 (Medium).jpg
    20240327_115803 (Medium).jpg
    108.4 KB · Views: 6
  • 20240327_125031 (Medium).jpg
    20240327_125031 (Medium).jpg
    101.1 KB · Views: 5
  • 20240327_130217 (Medium).jpg
    20240327_130217 (Medium).jpg
    81.5 KB · Views: 5
  • 20240327_130328 (Medium).jpg
    20240327_130328 (Medium).jpg
    72.3 KB · Views: 6
  • 20240327_131114 (Medium).jpg
    20240327_131114 (Medium).jpg
    182.1 KB · Views: 5
  • 20240327_131131 (Medium).jpg
    20240327_131131 (Medium).jpg
    157.3 KB · Views: 5
  • 20240327_131211 (Medium).jpg
    20240327_131211 (Medium).jpg
    132.7 KB · Views: 6
Thank you for the detailed instructions so far it is half done: In my case when I put the card in the station it did not work I had to connect the station via the computer and after a few tries it went.
SD cards have to be 32GB or less for the ST16e controller and formatted as FAT32.

This goes for all STxx series controllers to my knowledge.
 
  • Like
Reactions: WTFDproject
Thank you for the detailed instructions so far it is half done: In my case when I put the card in the station it did not work I had to connect the station via the computer and after a few tries it went.
Unfortunately but it doesn't turn on like other drones to the screen only green first and I have to go through yuneec 2.0 further but still it doesn't connect to the drone only there is a map and it doesn't detect any networks (even home networks) and there is no camera and no drone. Most probably the OFDM module is faulty because it blinks and in another working one I saw that there is a continuous light.
I am sending some pics and videos to show the software deficiencies (no DataPilot, there is only DataPilot 2.0) and no UpdatePilot.
Please let me know how to install the missing files and what I can do about connecting the drone to the station.
"Please let me know how to install the missing files"
It is very important you DO NOT install Update Pilot APK. That one is only for the original H520 and may cause damage if run on your H520e system.
DataPilot and Update Pilot are both for H520 ST16S. These files have no place on your H520e ST16e.
(I do not have an H520e ST16e. The screenshots I uploaded are from an ST16S, with part of the ST16e firmware loaded to provide you with pictures.)
It is interesting to note you mentioned you had bought this controller already damaged. There is some history of H520e controllers being damaged by attempts to run UpdatePilot. Some experienced members may be able to comment if your symptoms suggest this may have happened.

"Unfortunately but it doesn't turn on like other drones to the screen only green first and I have to go through yuneec 2.0"
This is the easy part of the problem. You can set the "Home" screen to DataPilot2,0 as shown in this image:
Set Home.jpg

"still it doesn't connect to the drone only there is a map and it doesn't detect any networks (even home networks)"
Please check the status of the WiFi button in settings. If the button is off, try to turn it on. If it will not turn on or if it turns back off immediately, it implies a bad WiFi Module in the controller. If the button is already on, it implies there is some other issue.
These comments may not be valid. One of your pictures shows you connected to "Lenovo_EXT", which seems to be a Wi-Fi source.
WiFi.jpg

"and there is no camera and no drone."
This may resolve after you get Wi-Fi to work. It will probably require re-binding. Have you performed "OFDM Module Re-bind" on page 12 of the attached manual?

"Most probably the OFDM module is faulty because it blinks and in another working one I saw that there is a continuous light."
Here, we must rely on members with knowledge of the H520e.

"and what I can do about connecting the drone to the station."
This will require resolving the Wi-Fi issue and possibly better binding guidance from members familiar with H520e.
 

Attachments

  • H520E-_-H520E-RTK_USER-MANUAL_V1.0_20201022 (1).pdf
    4.2 MB · Views: 12
Last edited:
and it doesn't detect any networks (even home networks) and there is no camera and no drone.
Please clarify where you are looking for a list of networks. On the camera bind screen? On the Settings/WiFi page? On the Main page "Video/Telemetry RSSI Status"? Note a "Lenovo_EXT" is showing as connected on the picture of the "Video/Telemetry RSSI Status" posted above.
If the "Lenovo_EXT" is listed on the Settings/WiFi list, it must be disconnected or selected to "forget" before the camera can connect.
 
Please clarify where you are looking for a list of networks. On the camera bind screen? On the Settings/WiFi page? On the Main page "Video/Telemetry RSSI Status"? Note a "Lenovo_EXT" is showing as connected on the picture of the "Video/Telemetry RSSI Status" posted above.
If the "Lenovo_EXT" is listed on the Settings/WiFi list, it must be disconnected or selected to "forget" before the camera can connect.
"Lenovo_EXT" is my network, which is used for software updates. I'm getting down to business and will let you know in a bit how it goes.
 
  • Like
Reactions: WTFDproject
"Please let me know how to install the missing files"
It is very important you DO NOT install Update Pilot APK. That one is only for the original H520 and may cause damage if run on your H520e system.
DataPilot and Update Pilot are both for H520 ST16S. These files have no place on your H520e ST16e.
(I do not have an H520e ST16e. The screenshots I uploaded are from an ST16S, with part of the ST16e firmware loaded to provide you with pictures.)
It is interesting to note you mentioned you had bought this controller already damaged. There is some history of H520e controllers being damaged by attempts to run UpdatePilot. Some experienced members may be able to comment if your symptoms suggest this may have happened.

"Unfortunately but it doesn't turn on like other drones to the screen only green first and I have to go through yuneec 2.0"
This is the easy part of the problem. You can set the "Home" screen to DataPilot2,0 as shown in this image:
View attachment 30389

"still it doesn't connect to the drone only there is a map and it doesn't detect any networks (even home networks)"
Please check the status of the WiFi button in settings. If the button is off, try to turn it on. If it will not turn on or if it turns back off immediately, it implies a bad WiFi Module in the controller. If the button is already on, it implies there is some other issue.
These comments may not be valid. One of your pictures shows you connected to "Lenovo_EXT", which seems to be a Wi-Fi source.
View attachment 30390

"and there is no camera and no drone."
This may resolve after you get Wi-Fi to work. It will probably require re-binding. Have you performed "OFDM Module Re-bind" on page 12 of the attached manual?

"Most probably the OFDM module is faulty because it blinks and in another working one I saw that there is a continuous light."
Here, we must rely on members with knowledge of the H520e.

"and what I can do about connecting the drone to the station."
This will require resolving the Wi-Fi issue and possibly better binding guidance from members familiar with H520e.
1. and it is already as it was, i.e. I select Pilot Data 2.0 but after restarting ST16 it is the same how do I remember this setting?
2. when switching on the ST16 a message about a new application appears and when I agree to the installation after a while I have info about an already installed version how do I disable this?
3. unfortunately but despite disabling the "Lenovo" network the attempt to connect the drone to ST16 still without success.
I will have the OFDM board on Friday and then I will see what happens with the connection. I'll try to install the rest of the files in the morning, just where do I get them from if I downloaded them from the official site but they're not the right ones anyway?
 
Thank you but this I know, the card is 16GB and was formatted in FAT :)
The max size partition in FAT is 4GB so that may be why you are having issues with the SD card in your ST16e. Try formatting it in FAT32.
 
1. and it is already as it was, i.e. I select Pilot Data 2.0 but after restarting ST16 it is the same how do I remember this setting?
2. when switching on the ST16 a message about a new application appears and when I agree to the installation after a while I have info about an already installed version how do I disable this?
3. unfortunately but despite disabling the "Lenovo" network the attempt to connect the drone to ST16 still without success.
I will have the OFDM board on Friday and then I will see what happens with the connection. I'll try to install the rest of the files in the morning, just where do I get them from if I downloaded them from the official site but they're not the right ones anyway?
"when switching on the ST16 a message about a new application appears and when I agree to the installation after a while I have info about an already installed version"
What is the new application it is trying to install?

"I'll try to install the rest of the files in the morning, just where do I get them from.."
I'm not sure what other files you need. It is important NOT to load any APPs other than DataPilot2.0. The other update files, if needed should be loaded using the OTA update feature built into DataPilot2.0 on the "versions" page.

"I select Pilot Data 2.0 but after restarting ST16 it is the same how do I remember this setting?:
I have seen conflicts where an APP would stay as the default, no matter what was done. The only way to stop it was to uninstall the offending APP. That is not an option here.

Have you tried to bind your other ST16e to this H520e?
Have you tried to bind this ST16e to the other H520e?

There are so many strange anomalies in the controller behavior, it may be a good idea to do a factory reset and start over. The ONLY APK you need is the Datapilot APK for DataPilot2.0. If you did not keep a copy, you can download it again from the link in Post #2 above.
After the reset, check your date/time and language settings. Install the DataPilot APP as you did before if the SD card still does not work. After the DataPilot App is installed, choose the "Home" setting again and set it to DataPilot2.0. It may help. It may not.
 
When DataPilot is manually installed how will be marked as a launcher?
As I said before, a factory reset will close a lot of questions.
 
  • Like
Reactions: WTFDproject
When DataPilot is manually installed how will be marked as a launcher?
As I said before, a factory reset will close a lot of questions.
Whatever it was called, however it was installed, the flight control screen has always been the first launch by default in earlier forms of the APP since ST10. If not, the Settings/Home selector in later versions should also set it.
But the Home selector can be overridden by the start-up defaults of other APPS, or to the PAD screen if no APPS are set to start or if the Launcer is otherwise not functioning correctly.
Not really sure how the start-up APP might otherwise be coordinated. Possibly by clearing "APP Defaults" and/or "APP Data" for those APPS that have it. The easiest way is simply not installing ANY APP not native to and required by the controller you are working with.

The factory reset did not appear to be an option when you first suggested it. It is not clear what got the controller moving off the PAD screen, but it works now, and settings, including factory reset, are accessible. Reset may well be the best way to get a defined starting point. It would be good to first know if there is a hardware malfunction, but that may not be possible.
 
Last edited:
@polskipilot , you mentioned earlier that you are not seeing GPS. It is normal to see no Drone GPS when not bound.
Are you also showing no Controller GPS when you select the controller icon to display the Controller Status box?
Controller GPS.jpg
 
Last edited:
Unfortunately, as it is already Christmas so I will only deal with this drone afterwards and will let you know the results and also ask about my colleague's problem, with the H520.
Merry and happy Christmas and we will hear from you.
 

New Posts

Members online

Forum statistics

Threads
21,032
Messages
242,640
Members
27,638
Latest member
wkeithcallahan