Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Limp Gimbal , typhoon H camera

Joined
Jan 9, 2024
Messages
1
Reaction score
0
Age
49
How you all doing. I bought a Typhoon H second hand and was told that it has been flown a few times only and a guy panic. landing it without the landing gear down and bumped the camera it twitches. And looks like it has some life in it when we power it up. But when you try to do anything with it. It is just a limp camera point straight down any suggestions. Right deals, the camera looks intact. Everything books in order to
 
How you all doing. I bought a Typhoon H second hand and was told that it has been flown a few times only and a guy panic. landing it without the landing gear down and bumped the camera it twitches. And looks like it has some life in it when we power it up. But when you try to do anything with it. It is just a limp camera point straight down any suggestions. Right deals, the camera looks intact. Everything books in order to
Please confirm your camera is a CGo3+. There should be a label on both side hubs.

The video part of the camera and the gimbal part share a power supply. Knowing if the LED is lit on the front, the color of the LED and whether it is sending a picture to the controller might help understand the source of the problem.

Are there any "beep" sounds when you power the camera up? If so, the beeps will be in a pattern of 1 to 4 "long" beeps followed by 1 to 4 "short" beeps". There should also be a "screeching" sound to announce the start of the beep sequence, but the screech does not always sound. The beep codes are listed on this drawing:
Beep Codes.jpg

You mentioned "limp camera point straight down". Is it truly limp, or does there appear to some amount of spring force pushing the camera down?
 

New Posts

Members online

Forum statistics

Threads
21,032
Messages
242,640
Members
27,638
Latest member
wkeithcallahan