Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

No Cgo3+ or WIFI connection on ST16

Joined
May 20, 2016
Messages
8
Reaction score
1
Location
London
HI all, Im having the the exact same problem as a few others it seems (but have not seen a solution online).

The WIFI button on my ST16 will no longer switch on, it remains greyed out (in PAD function too) and it will no longer bind with the Cgo3+

(The H itself is bound with the ST16 with no problems)

I can connect to and view the camera on my Android app, so I know the camera by itself is working fine)

Anyone have a solution please?
 

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
6,949
Reaction score
3,352
Location
Bessemer, MI
HI all, Im having the the exact same problem as a few others it seems (but have not seen a solution online).

The WIFI button on my ST16 will no longer switch on, it remains greyed out (in PAD function too) and it will no longer bind with the Cgo3+

(The H itself is bound with the ST16 with no problems)

I can connect to and view the camera on my Android app, so I know the camera by itself is working fine)

Anyone have a solution please?
Try opening the PAD, go to Settings and make sure the Wifi is turned on. Tap the (More...) button and make sure Airplane mode is not checked. Go back and tap on Wifi and you should see a list of any wifi signals close by including the CGO3. If you don't see any signals you will have to call Yuneec. Post back here what you find.
 
  • Like
Reactions: abinder
Joined
May 20, 2016
Messages
8
Reaction score
1
Location
London
Thanks Steve, but the problem was not resolvable, so Yuneec replaced the ST16 yesterday, so in that way my problem is now resolved ☺
 
  • Like
Reactions: abinder
Joined
Dec 8, 2016
Messages
14
Reaction score
3
I have the same problem with my ST16+, Wi-Fi grayed out. Re-installed the latest firmware, reset to factory, nothing helped. Guess I'll have to contact Yuneec.
 

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
6,949
Reaction score
3,352
Location
Bessemer, MI
I have the same problem with my ST16+, Wi-Fi grayed out. Re-installed the latest firmware, reset to factory, nothing helped. Guess I'll have to contact Yuneec.
Hope you post what you find after talking to Yuneec. This seems rare but obviously does happen.
 

New Threads

Members online

Forum statistics

Threads
17,106
Messages
199,880
Members
19,799
Latest member
CHARLESANTOINE