Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Primary gyro not found

SKD

Joined
Feb 23, 2020
Messages
2
Reaction score
0
Age
55
Receiving error messages “primary gyro not found “ when turning on H520. Any advice as to how to fix this? Thanks
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
5,909
Reaction score
3,388
Location
Genesee, MI USA
You are the second person having this trouble in the past week. Did you just recently do any updates to your H520?

If so, were they done through UpdatePilot?
 
Last edited:

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
2,504
Reaction score
1,869
Location
North Carolina Piedmont, USA
Please ignore this post if you did NOT encounter the problem as a result of an update!
But assuming you got bit by the update bug that seems to be going around, there may be a way to remedy the issue using SD cards to manually redo the update.
Can I guarantee the SD cards will fix the problem? No. I can't.
Can I guarantee the SD cards will not make the problem worse? No. I can't.
If you can deal with the uncertainty, I will ask a couple questions about your equipment, then mix up a "cocktail" of files to match your kit. I'll send the files along with instructions for how to use them.
Doesn't this just overwhelm you with hope and confidence? Yeah, I know. Sending for warranty work might sound real good right now.
 
Joined
Oct 24, 2020
Messages
29
Reaction score
4
Age
50
I did the process with the SD card. thanks WTFDproject
the process worked on the other hand I still had this message ( primary gyroscope not found ) and my camera was doing what I wanted, I went out to receive GPS and I calibrated the gyroscope , I didn’t like the message ( yes finally!!! ) I calibrated the compass at the same time then the accelerometer which failed it (I start again tomorrow), I have several new alarms ( yaw, GPS and my camera E90 which turns on itself quite quickly obliged to turn off the drone to stop it , I return to as soon as possible .
 
Joined
Oct 24, 2020
Messages
29
Reaction score
4
Age
50
the message ( primary gyroscope not found ) is no longer displayed after searching for a GPS signal and calibrated the gyroscope
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
5,909
Reaction score
3,388
Location
Genesee, MI USA
is this the h520e version that's throwing the gyroscope not found?
Both have been the original H520 Terrence and filip’s was updated using UpdatePilot. Most likely so was SKD’s.
 

SKD

Joined
Feb 23, 2020
Messages
2
Reaction score
0
Age
55
Yes it was after having trouble with the update. Had to download firmware on sd card and then update via controller. After that update I had the primary gyro not found error. Since then I was successful in rebooting it via the sensor setting. Thanks for your response!
 

New Threads

Forum statistics

Threads
19,307
Messages
224,287
Members
22,745
Latest member
Santacroce893