Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Propellers flew off

Joined
Aug 8, 2016
Messages
2
Reaction score
0
Age
58
Greetings , after tightening props well , set it all up and gave it throttle and rear 2 props flew off , any chance they are wired backwards .
Thanks Dan M:(
 
Joined
May 24, 2016
Messages
281
Reaction score
76
I had one prop do that when I first got my H just as I started the motors, I think this was due to being in a rush to get in the air in this occasion I did not double check each prop was securely fastened, I've now got in the habit of holding each motor in turn and try and the same time, twist each prop clockwise & anti clockwise to check they are securely locked in place, not had one fly off since hope this helps you out.


Sorry ignore what I said I mistook you was referring to the Typhoon H props flying off, but as I have the Q500 4k also it maybe you did not tighten the two props quite enough down onto the rubber o ring.
 
Last edited:
  • Like
Reactions: jayday
Joined
Aug 8, 2016
Messages
2
Reaction score
0
Age
58
I had one prop do that when I first got my H just as I started the motors, I think this was due to being in a rush to get in the air in this occasion I did not double check each prop was securely fastened, I've now got in the habit of holding each motor in turn and try and the same time, twist each prop clockwise & anti clockwise to check they are securely locked in place, not had one fly off since hope this helps you out.


Sorry ignore what I said I mistook you was referring to the Typhoon H props flying off, but as I have the Q500 4k also it maybe you did not tighten the two props quite enough down onto the rubber o ring.
Actually I carefully checked a and b and tightened them all fairly tight any tighter and I would fear a break .
Thanks for the reply
 

New Threads

Forum statistics

Threads
16,814
Messages
196,237
Members
19,509
Latest member
Bud Nubby