Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Q500 Problem with Start-Up

Joined
Oct 19, 2021
Messages
2
Reaction score
0
Age
52
I received this drone from a friend or really a customer of mine who didn't want to deal with the drone anymore. I can tell you that he crashed it pretty hard. Let me tell you in line items what I know or what My problems are and maybe you can give me some good advice. If there was a way for me to clear everything and start over like it was new in the box that would be great.
1. The Drone is flashing Red Light and beeping at the same time.
2. There is a wire at the battery opening that has a female connection on it, right where the connector for the USB is when you would hook it up to your computer.
3. I don't know if the controller is connecting to the Drone or not
4. I erased the controller because I wasn't getting anywhere and I finally got it to take the ST+ Firmware update but it still has the same Build number so Im not sure what it is doing. I'm trying to get the camera back on the controller but now the controller is asking for the camera Login & Password info and I am lost.
5. I hooked it to the GUI and it says that the Accelerometer Bias when I is out of range on Sensor Information

Is there a way to just take this thing back to day one and start over???
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,010
Reaction score
2,324
Location
North Carolina Piedmont, USA
I received this drone from a friend or really a customer of mine who didn't want to deal with the drone anymore. I can tell you that he crashed it pretty hard. Let me tell you in line items what I know or what My problems are and maybe you can give me some good advice. If there was a way for me to clear everything and start over like it was new in the box that would be great.
1. The Drone is flashing Red Light and beeping at the same time.
2. There is a wire at the battery opening that has a female connection on it, right where the connector for the USB is when you would hook it up to your computer.
3. I don't know if the controller is connecting to the Drone or not
4. I erased the controller because I wasn't getting anywhere and I finally got it to take the ST+ Firmware update but it still has the same Build number so Im not sure what it is doing. I'm trying to get the camera back on the controller but now the controller is asking for the camera Login & Password info and I am lost.
5. I hooked it to the GUI and it says that the Accelerometer Bias when I is out of range on Sensor Information

Is there a way to just take this thing back to day one and start over???
Johnny,
A refresh is not likely to resolve the issues. We do need a couple of clarifications to start centering on the problem. Please understand following a crash/rebuild, there may be more than one issue left unresolved.
1. "The Drone is flashing Red Light and beeping at the same time."
Is this the single LED under the battery door, or is it the LEDs under the two rear motors?
2. "There is a wire at the battery opening that has a female connection on it, right where the connector for the USB is when you would hook it up to your computer."
How many wires/pins are on the connector? What color are the wires? That will help us focus on whether the loose connector is related to the GPS, the compass, the reciever or an ESC.
3. "now the controller is asking for the camera Login & Password info and I am lost."
The password is: 1234567890. If you need more details on binding you can refer to Attachment 33 (Q500 Binding Verification) of the PDF document attached to "Way To Fix Drones project"

Please give us an overview of what was damaged. Did the repair include removing/replacing the top shell?
 
Last edited:
  • Like
Reactions: DoomMeister

New Threads

Members online

Forum statistics

Threads
20,058
Messages
231,991
Members
24,421
Latest member
chrisgreenslade