Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

URGENT!! CGO 3 Gimbal Not Working

Joined
Jul 27, 2021
Messages
4
Reaction score
0
Age
28
Location
Karachi Paklistan
Hello Friends.


Having a problem with my CGo3 gimbal camera working fine recording tx wifi ok
But gimbal is not
No lights on gimbal board No sound/beeps no movement etc.

i have found a picture on this YuneecPilots forum in which a friend of us diagnosed a problem with an IC

CGo3 GB Top.jpg

But i cannot find this IC on internet because this given name number on IC can not be found any where

Can any 1 tell me its name/number

thanks.
Friends
 
Joined
Mar 4, 2019
Messages
296
Reaction score
127
Age
53
Hello Friends.


Having a problem with my CGo3 gimbal camera working fine recording tx wifi ok
But gimbal is not
No lights on gimbal board No sound/beeps no movement etc.

i have found a picture on this YuneecPilots forum in which a friend of us diagnosed a problem with an IC

View attachment 26171

But i cannot find this IC on internet because this given name number on IC can not be found any where

Can any 1 tell me its name/number

thanks.
Friends
I too had issues trying to find a chip for these boards. I can tell you the older GoPro (gb203 I think) gimbals have the exact same board in them and if you can get your hands on one you would have the part you need. I have several lying around I will see if any of them have a number on it.
Did you check the contacts on the gimbal and drone? These contacts tend to stick at times.
 
Joined
Jul 27, 2021
Messages
4
Reaction score
0
Age
28
Location
Karachi Paklistan
I too had issues trying to find a chip for these boards. I can tell you the older GoPro (gb203 I think) gimbals have the exact same board in them and if you can get your hands on one you would have the part you need. I have several lying around I will see if any of them have a number on it.
Did you check the contacts on the gimbal and drone? These contacts tend to stick at times.
yes everything is great except gimbal you know..
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,718
Reaction score
3,874
Location
Genesee, MI USA
yes everything is great except gimbal you know..
Did you check the PWM transistor on the Q500 Main board as shown in Attachment 55 of the WTFDproject document?
 
Joined
Jul 27, 2021
Messages
4
Reaction score
0
Age
28
Location
Karachi Paklistan
Did you check the PWM transistor on the Q500 Main board as shown in Attachment 55 of the WTFDproject document?
I think it is fine actually don't have much time to supply power to PCB because the both IC's in red circle are getting really hot any suggestions why they are getting so hot??

cgo3-gb-top-jpg.26171
 

New Threads

Members online

No members online now.

Forum statistics

Threads
19,960
Messages
230,915
Members
24,233
Latest member
brad_squared