Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

?
  1. I have installed the 11/16/2016 firmware.

    125 vote(s)
    74.9%
  2. I used the auto update using the ST16 menu.

    53 vote(s)
    31.7%
  3. I have flown following the update and everything seems to work as expected.

    82 vote(s)
    49.1%
  4. After updating I have a new problem.

    43 vote(s)
    25.7%
  5. The landing seems to have improved with this update.

    21 vote(s)
    12.6%
  6. I like the new accelerometer calibration.

    21 vote(s)
    12.6%
  7. I have tried the new muti ST16 connection to the camera.

    9 vote(s)
    5.4%
  8. I don't plan to install this update.

    11 vote(s)
    6.6%
  9. It bricked my H

    17 vote(s)
    10.2%
Multiple votes are allowed.
  1. Steve Carr

    Steve Carr Moderator
    Staff Member

    Joined:
    Dec 15, 2015
    Messages:
    1,472
    Likes Received:
    616
    Location:
    Bessemer, MI
    Latest firmware is V3.01 and V3.01.b27
     
  2. Germán

    Joined:
    Nov 16, 2016
    Messages:
    7
    Likes Received:
    2
    It solved my problem of gps acquiring signal in south America.

    Enviado desde mi SM-J700M mediante Tapatalk
     
    zandoli likes this.
  3. Rayray

    Rayray Moderator
    Staff Member

    Joined:
    Jun 3, 2016
    Messages:
    1,809
    Likes Received:
    617
    Location:
    Pine Forests of Deep East Texas
    I updated two TH's with this new firmware today, using only the micro-card method. All went smoothly, as usual you have to rebind after the ST16 update and before the Craft update. New model is necessary in some cases.

    As per the instructions, I did an Accelerometer calibration after each craft upgrade. I then flew each craft some 10 minutes in Angle mode, this went smoothly. I'll continue to test the new upgrade over the next couple of days, looking closely at GPS, Accelerometer, and compass co-ordination.

    Update- 11-17-16 Flew both craft more this morning, GPS acquisition and stability seems improved, Movement above ground at landing smoother, less twitchy. Since I'm flying at my usual "airport", I did not re-cal the compass or gimbal, Compass is fine on both craft.
     
    #3 Rayray, Nov 16, 2016
    Last edited: Nov 17, 2016
    donmcw likes this.
  4. Tuna

    Joined:
    Jun 9, 2016
    Messages:
    935
    Likes Received:
    816
    Location:
    UK
    By all accounts this is a 'bug fix' release after the last big firmware upgrade. Yuneec are happy that this improves the flight characteristics and addresses a number of other small gotchas.

    I've not flown long on it, but it seems good. Switched between panorama and video and back again, took pictures in some challenging conditions (high contrast, early morning sunrise) and got some lovely results:

    Waterbeach River View

    Very satisfied!
     
  5. mikkis123

    Joined:
    Sep 10, 2016
    Messages:
    5
    Likes Received:
    2
    Updated today, cleared flight mode data, calibrated all, tested, all ok.
     
  6. QuadBart

    Joined:
    Jan 19, 2016
    Messages:
    385
    Likes Received:
    124
    Location:
    USA
    Massive FAIL for me using the auto-update. During the update the lights went out on the H, the only light was on the CGO... waited, waited, waited, waited... Let it sit for a half hour, nothing.... Power cycled the ST-16, nothing.... Attempted to power cycle the H, nothing...

    The only light on is the camera light and the main power switch otherwise no main status light or lights on the arms....

    I've done every firmware upgrade with ZERO issues prior to this.. Looks like my H is bricked.....

    How about adding a new option; "My H is Bricked".... :(
     
    #6 QuadBart, Nov 17, 2016
    Last edited: Nov 17, 2016
  7. Tuna

    Joined:
    Jun 9, 2016
    Messages:
    935
    Likes Received:
    816
    Location:
    UK
    That can be rescued with the Windows GUI. Get a copy of the 1.28 (?) FC software and install it directly on the H to get it to recover. You can download the file from the firmware archive (check the post on this forum). Then with the H unplugged and with no battery, start the windows GUI. Start the firmware updater in the GUI and load the FC software you downloaded. Then, plug the H into the PC and it will install the firmware. Once it's done, unplug everything, put in the battery and your H should start up again.
     
    mcbutler and yuneec53 like this.
  8. QuadBart

    Joined:
    Jan 19, 2016
    Messages:
    385
    Likes Received:
    124
    Location:
    USA
    Thanks! Does the work with Apple Computers? I don't own a Windows computer...

     
  9. gwhuntoon

    Joined:
    Aug 19, 2016
    Messages:
    315
    Likes Received:
    111
    Unfortunately no, unless you use a virtual machine like VMWare Fusion or VirtualBox, but you would still need a Windows License. FYI - I've had minimal success using Wine Bottler. Given the sensitive nature of your issue I wouldn't mess around with a VM on a Mac. Just see if you know someone with a Windows machine which they may let you borrow for an hour.
     
  10. seabee

    Joined:
    Apr 27, 2016
    Messages:
    57
    Likes Received:
    21
    The GUI works fine on my Mac Book Air in the Bootcamp partition using Windows 7.
     
  11. BobW55

    BobW55 Moderator
    Staff Member

    Joined:
    May 10, 2016
    Messages:
    1,193
    Likes Received:
    481
    Location:
    Melvin Michigan, In the thumb
    @QuadBart
    Just for you, added my H is bricked.
     
    SnowRaven, Jester and Steve Carr like this.
  12. jj1517

    Joined:
    Nov 3, 2016
    Messages:
    2
    Likes Received:
    2
    My updates went very smoothly today. Re-calibrated as necessary and had a short flight between the sleet showers. It seemed to fly OK and was stable although I lost the camera connection at 200 feet. This loss of connection was very prevalent since the last update and I had hoped it would now be behind me!
     
  13. dxer

    Joined:
    May 12, 2016
    Messages:
    219
    Likes Received:
    18
    It is premature to say that everything is good, but after updates and calibrations I made one flight and everything went well. Only thing is that I lost video feed when legs went up.
    Just to say that there was and H was very stable.
    Anyway I will not vote on anything up there just yet as I need to made several more flights to be sure that maybe toilet bowl and drifting is gone.
     
    Unlocktender likes this.
  14. JCFlippen

    Joined:
    May 11, 2016
    Messages:
    510
    Likes Received:
    183
    Location:
    Cardiff-Wales UK
    I am going down the card route for both updates. Should it be ST16 update first? Will ST16 then talk to the H?
     
  15. dxer

    Joined:
    May 12, 2016
    Messages:
    219
    Likes Received:
    18
    First ST16, just like video says.
     
  16. Jimmylee

    Joined:
    Apr 24, 2016
    Messages:
    485
    Likes Received:
    201
    Did the update today without any issues.

    Did all the calibrations and went for a flight.

    Immediately got compass errors AGAIN that were fixed with the last firmware.
    With no input on the sticks was getting motor surging and twitching and the H was bouncing all over the place.
    Was able to get it landed and will try the calibrations over again.

    So sad because it was flying great on the last firmware, it just had a little drifting but nothing serious.
     
  17. yerrickl

    Joined:
    Oct 27, 2016
    Messages:
    93
    Likes Received:
    12
    Location:
    Dallas, Texas
    Good so far. The update was too easy this time. Just used the ground station for everything


    Sent from my iPhone using Tapatalk
     
    Ward Paterson likes this.
  18. JCFlippen

    Joined:
    May 11, 2016
    Messages:
    510
    Likes Received:
    183
    Location:
    Cardiff-Wales UK
    Just upgraded with cards and all went smoothly according to ST16 dialogue box, will hopefully test with H in the morning if rain desists.
     
  19. QuadBart

    Joined:
    Jan 19, 2016
    Messages:
    385
    Likes Received:
    124
    Location:
    USA
    UPDATE!

    Typhoon H is "unbricked"! Thanks to all that helped! Had to dust off and power up my old Windows box "hoping" it would still work. After some updates to it, I was able to load the GUI and load the FC V1.28 version. The H booted up on it!

    Rather than jump to the 3.01 Version I started with the 3.0 version. Every upgrade took! I did all the calibrations and am now waiting for some nice weather as we currently have snow and blowing snow.

    Apparently before the loss of connection the camera did update. I did have to rebind but I notice I had to follow a specific sequence other than the standard rebind sequence to get my camera bound. The normal "bind" sequence did not have the camera show up even hitting the "refresh". I had to go back and select the "model" then on the bind screen I had to select my CGO model, only then did it show up when I did refresh.

    Hopefully when I fly it, everything will be fine!
     
    THoff, Ward Paterson, Tuna and 2 others like this.
  20. Ward Paterson

    Joined:
    Jul 23, 2016
    Messages:
    30
    Likes Received:
    3
    Updated no problems via the ST16

    Just need a compass calibration and ready to go

    One thing I did notice is my Roll stick was doing strange things in the hardware monitor. No matter what I do in calibrations I cant get it centred. I kept playing with it - as if to wear it in - and its behaving a bit better. For a while there it wasn't even giving me access to the full stick movement. I am thinking this was causing the drifting issues to the left for me as at the beginning of a flight it would be fine and towards the end it would be drifting - which seems the roll axis was sticking. Hopefully ok now or I will have to have the ST16 serviced...
     
    yerrickl likes this.