Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Any Firmware Issues

Joined
Nov 28, 2019
Messages
192
Reaction score
99
Age
45
Location
Austin, Texas
Is anyone having any problems with this firmware combo on the H520? Mostly in Survey Mode... I have noticed a few things lately that I have reported, but was curious if anyone else had any feedback?

1578340540614.png
 
Joined
Nov 28, 2019
Messages
192
Reaction score
99
Age
45
Location
Austin, Texas
Survey Pattern has an occasional DataPilot crash. It reboots and properly connects, but the pattern has to regen and the icons for the original photos were lost. On a couple of occasions the screen froze and I had to initiate a restart of the app.

Multi-battery no longer auto-RTL.

Multi-battery takes pictures from launch of second battery to the restart waypoint. This existed in beta, but was fixed in the next version so it appears to have come back.

Multi-battery tries to fly directly to the 2nd start point from the ground.

All if these are an inconsistent condition and have not happened in Corridor or Structure modes. This is the first time I have really tried to run released software so I am interested to see what the real world experiences are.
 
Joined
Oct 9, 2017
Messages
13
Reaction score
2
Age
47
Location
Colorado, USA
Survey Pattern has an occasional DataPilot crash. It reboots and properly connects, but the pattern has to regen and the icons for the original photos were lost. On a couple of occasions the screen froze and I had to initiate a restart of the app.

Multi-battery no longer auto-RTL.

Multi-battery takes pictures from launch of second battery to the restart waypoint. This existed in beta, but was fixed in the next version so it appears to have come back.

Multi-battery tries to fly directly to the 2nd start point from the ground.

All if these are an inconsistent condition and have not happened in Corridor or Structure modes. This is the first time I have really tried to run released software so I am interested to see what the real world experiences are.
I've had data pilot crash when doing a survey (almost lost my 520), but I didnt loose any pictures and battery swap went off with out a hitch... Swap portion of the mission also had datapilot crash and reboot
 
Joined
Oct 9, 2017
Messages
13
Reaction score
2
Age
47
Location
Colorado, USA
Survey Pattern has an occasional DataPilot crash. It reboots and properly connects, but the pattern has to regen and the icons for the original photos were lost. On a couple of occasions the screen froze and I had to initiate a restart of the app.

Multi-battery no longer auto-RTL.

Multi-battery takes pictures from launch of second battery to the restart waypoint. This existed in beta, but was fixed in the next version so it appears to have come back.

Multi-battery tries to fly directly to the 2nd start point from the ground.

All if these are an inconsistent condition and have not happened in Corridor or Structure modes. This is the first time I have really tried to run released software so I am interested to see what the real world experiences are.
Let yuneec know... I told them a few months ago
 
Joined
Nov 28, 2019
Messages
192
Reaction score
99
Age
45
Location
Austin, Texas
When my DataPilot crashes it is a fast cycle and comes back on connected within about 30 seconds and the aircraft continues on its merry way so as long as I am in VLOS I'm not really worried about losing it. I didn't actually lose any pictures, just the markers had disappeared for the images that had already been taken. Battery swaps have completed successfully, but have had those odd occurrences a few times. I fly quite allot so it may be more dramatic to me. Yuneec already knows about all of these issues as I report back to them weekly, but I was more curious as to the public's perception. Since I have started using the H520 as our standard mapping platform I have learned to really enjoy its operation and its presence in the sky, but I am continuing with my testing channel in hopes to not only resolve these minor issues, but to get a few features added as well.
 

Paw

Joined
Jul 11, 2018
Messages
113
Reaction score
25
Location
Poland
Survey Pattern has an occasional DataPilot crash. It reboots and properly connects, but the pattern has to regen and the icons for the original photos were lost. On a couple of occasions the screen froze and I had to initiate a restart of the app.

Multi-battery no longer auto-RTL.

Multi-battery takes pictures from launch of second battery to the restart waypoint. This existed in beta, but was fixed in the next version so it appears to have come back.

Multi-battery tries to fly directly to the 2nd start point from the ground.

All if these are an inconsistent condition and have not happened in Corridor or Structure modes. This is the first time I have really tried to run released software so I am interested to see what the real world experiences are.
Sounds like my own experience with datapilot crashes, screen froze and lost of connection.
 
  • Like
Reactions: chascoadmin
Joined
Nov 28, 2019
Messages
192
Reaction score
99
Age
45
Location
Austin, Texas
We are going to have some conversations in the background and this will be one of the first things I approach. I was assuming I was just having problems with my overall configuration, but the last public release and beta software are exhibiting some of the same issues.
 
Joined
Nov 18, 2019
Messages
7
Reaction score
0
Age
34
Sounds like my own experience with datapilot crashes, screen froze and lost of connection.
I've had the same issue, it freezes when it gets high in the picture count I've noticed but it does continue on its path.
 
Joined
Nov 28, 2019
Messages
192
Reaction score
99
Age
45
Location
Austin, Texas
I've had the same issue, it freezes when it gets high in the picture count I've noticed but it does continue on its path.
I'm not sure if this is a clear sign, but mine seems to have happened several times at or around 40% battery. Exception yesterday. I ran a 1600 photo 4 battery mission and it crashed about 2 minutes into the first battery and the 3rd after the battery swap.
 
Joined
Sep 5, 2018
Messages
36
Reaction score
15
Age
68
Location
Matthews, North Carolina
I'm not as experienced as most on this forum as I have only been using my H520 for 2 months and only for survey missions. I've had DataPilot freeze up about 3 out of 4 flights in survey mode on the most current firmware. Like you, the survey completed fine, I just restarted DataPilot without difficulty. I downgraded my firmware to the following:
AutoPilot: 1.8.0-1.6.5 (3/11/19)
DataPilot: 1.5.10.14 (3/11/19)
E90: 1.0.56 A (3/11/19)
E90 Gimbal: 2.40.3 (current)
I had a couple of DataPilot freezes since doing that, but they are rare instead of common. I am sure there are some lost functions such as digital zoom, but there have been no flight issues. I haven't run a survey yet that has required more than one battery, so I'm not sure about that functionality. I have only one ST16s, so in order to try some other options, I loaded the DataPilot and did the controller firmware upgrade on an extra ST16 that I have. It appears to function normally in all respects, except the freezes are even less common (only once since starting to use the ST16). The ST16 has the three external antennas mod that I did some time back. I suspect that the E90 firmware could be brought current without having a negative effect, and it might help me regain zoom for example. I am continuing to test options to see how to get the H520 more reliable. Too much rain today to fly.
Thanks,
Stephen
 
Joined
Nov 28, 2019
Messages
192
Reaction score
99
Age
45
Location
Austin, Texas
10-4.

1.6.18 is the latest official release and am testing other. I am interested in the source as that does not show up on any of the official channels. UK?
 
Joined
Feb 22, 2019
Messages
31
Reaction score
5
Age
58
I’ve had the exact issue with the new firmware making the data pilot software freeze in mid mission. It is very scary.
I switched to using the Pix4Dcapture for the H520 and the problem stopped. But I prefer the data pilot because I can set up the missions on the desktop computer
I was thinking of going backwards with the firmware as others have but haven’t had time to go through all the steps. If someone were to post the exact steps to do that (I’m not a real experienced android person ) that would be great
 
Joined
Nov 28, 2019
Messages
192
Reaction score
99
Age
45
Location
Austin, Texas
I’ve had the exact issue with the new firmware making the data pilot software freeze in mid mission. It is very scary.
I switched to using the Pix4Dcapture for the H520 and the problem stopped. But I prefer the data pilot because I can set up the missions on the desktop computer
I was thinking of going backwards with the firmware as others have but haven’t had time to go through all the steps. If someone were to post the exact steps to do that (I’m not a real experienced android person ) that would be great
Let's start with using this repository. Thank you for the maintainer. I also plan to mirror this as it is obviously super valuable in situations like this. Especially if this is what you do for a living.


The next step is to identify which versions go together. I am trying to work with the flight team to make this a little easier, at least for the last two versions. This is troublesome because UpdatePilot will not overwrite AutoPilot if it is a newer version so AP needs to be rolled back via mSD card.
 

New Threads

Forum statistics

Threads
17,719
Messages
207,965
Members
20,503
Latest member
FLY ENTERPRISE