Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Blue rapid flashing light and continuous beeps!

Joined
Oct 21, 2016
Messages
3
Reaction score
0
Age
48
Hi guys I'm a newbie here to the forum but heres my story!

I own the H pro with realsense, after doing the latest update i started to get issues with the camera! On start up after the H initialises the camera slowly lops to 1 side. I switch it on and off and sometimes it rectifies itself. Thats the 1st problem i have....

Today i decided to go fly, on start up all was good until i lifted of the ground....The H decided to clime on its own with hardly any control on throttle rudder aileron elevator! i managed to get it down and decided to go home, i inspected all and couldn't find anything out the ordinary. I decided to reset the st16 and re-install both updates again, both succesful. Still did the same after i booted it back up. I went into the secret menu and decided to do a calibration! i noticed that all switches and the dial went from a fail to a green pass! the control sticks didn't move at all and remained 'fail'....now I'm getting a continuos beep and a rapid flashing blue light! both the H and st16 are showing as being bind.

Any ideas please
 
R

Rayray

Guest
Sorry to hear this. I think your best bet is to call Yuneec support and let them walk you though the process of getting it going.
 
  • Like
Reactions: ant barton
Joined
May 7, 2016
Messages
1,140
Reaction score
358
Age
72
Location
Gurdon, Ar
Yuneec CS is your best bet. If they can't walk you through it then they will give you a RM A to send it back.
 
  • Like
Reactions: ant barton
Joined
May 7, 2016
Messages
1,140
Reaction score
358
Age
72
Location
Gurdon, Ar
I really don't suggest a reset unless their technicians walk you through it sorry are you located in the US EU or UK?
 
Joined
May 7, 2016
Messages
1,140
Reaction score
358
Age
72
Location
Gurdon, Ar
From what I understand the UK has an excellent technical staff you might want to talk to them.
 

JB1

Joined
Apr 16, 2016
Messages
80
Reaction score
21
Age
57
Hi Ant, I had a similar problem and I dropped my H off at Yuneec USA. The tech told me that the problem is in one of the joysticks which is why you have control issues. He said that quite a few H's have this issue and that you have to go into the hardware section and check that they are both at the center position, if not you have to re-calibrate/zero the stick that's out of sync.
 

New Threads

Members online

Forum statistics

Threads
17,133
Messages
200,269
Members
19,815
Latest member
CRS