Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

c23 camera has stopped working

Joined
Feb 3, 2021
Messages
6
Reaction score
1
Age
42
so the gimbal works except wifi connection and image itself of course ...
no LED on the front either,
movement works as it should.
I'm a bit stuck here ;-)
 

Ty Pilot

One Hexy Pilot
Premium Pilot
Joined
Feb 24, 2017
Messages
2,899
Reaction score
2,986
Location
Central Florida
Website
copperdawg.com
If it was working the last time you used it and nothing has happened since then (like a crash or hard lading -etc) then it could be as simple as the contacts may need just a little cleaning. Try removing the gimble and reinstalling a time or two and see if it boots up normal.
 
Joined
Feb 3, 2021
Messages
6
Reaction score
1
Age
42
hello there
we have already cleaned it, also checked the contacts inside, everything still ok ...
no crash or otherwise crazy things done with it.
we also have a wifi module swap but also without success ...
 
  • Like
Reactions: Miller Kent

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
2,848
Reaction score
2,194
Location
North Carolina Piedmont, USA
There is also a very small LED on the back of the vertical arm. That one is the gimbal board indicator. Please check if the small LED lights, the color it displays, and any blinking patterns it displays.

Are there any beep codes sounding?

Have you recently performed either Compass or Accelerometer calibrations with the camera mounted but not secured by the gimbal lock?
 
Joined
Feb 3, 2021
Messages
6
Reaction score
1
Age
42
It just starts with the normal beeps,
light on the back is ok.
LED on the front of the camera does not light up...
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
2,848
Reaction score
2,194
Location
North Carolina Piedmont, USA
Again:
Have you recently performed either Compass or Accelerometer calibrations with the camera mounted but not secured by the gimbal lock?

This is an important question. The C23 is vulnerable to ribbon damage from unrestricted gimbal movements. Calibrations are a common source, as is transporting the camera without the gimbal lock, hard landings and crashes. And some fail with no apparent reason. Your symptoms suggest a possible damaged or degraded main ribbon. There are other possibilities, but discussing the ribbon is usually a good place to start.
 
Joined
Feb 3, 2021
Messages
6
Reaction score
1
Age
42
no calibration performed stopped working during a flight ...
I'm going to take a look at the ribbon and measure for current ...
thanks in advance for the tips
 

New Threads

Members online

Forum statistics

Threads
19,908
Messages
230,129
Members
24,073
Latest member
Ball fondlers