Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

CGO3+ Gimbal fails after updating firmware to the latest, please help!

Joined
Nov 21, 2022
Messages
11
Reaction score
1
Age
37
Hi typhoon h fans,

I have updated the firmware to the latest (Gimbal version 1.25). After restarting the drone, the gimbal stopped working.
The camera worked just fine, there are video feed on the ST-16 monitor. but the gimbal has no movement, just hang there from turning on to turning off.

Beep situation: once the drone is turned on, there are three fast beeps from cgo3+, and a pause like 3 sec, and then a melody of three beeps like "1-2-3".
The blinking like: first white steady light, and then read steady light plus yellow blinking light. After that, it's yellow blinking light all the time.

Please help!
 
Joined
Nov 21, 2022
Messages
11
Reaction score
1
Age
37
Thanks for the reply @Steve Carr. The file name is "TyphoonH_Ver3.04_A.bin".
BTW, I used a 2GB very small sd card according to the instruction. I don't know if this is the cause.
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
7,632
Reaction score
4,469
Location
Genesee, MI USA
What instructions were you following @Lionheart ?

What version were the camera, gimbal, and autopilot at before updating?

What version is displayed for the camera, gimbal, and autopilot since updating?
 
  • Love
Reactions: WTFDproject

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,424
Reaction score
2,702
Location
North Carolina Piedmont, USA
I have updated the firmware to the latest (Gimbal version 1.25). After restarting the drone, the gimbal stopped working. ...........Please help!

What version were the camera, gimbal, and autopilot at before updating?
Unfortunately, there are two "latest versions" of the gimbal firmware. And the two versions are not compatible.
Almost all CGo3+ cameras use the Ver 1.25 you loaded. But some few were built with a C23 type IMU and require version 1.27 gimbal firmware. If you can confidently answer the version question asked by @DoomMeister, it would help a lot.
If you are not sure which was the original version, it may be worth it to remove the nose piece or the front camera shell to check which IMU type is installed above the lens. (Sorry about the damaged cameras in the image. It was all I had available.)
CGo3+ IMUs.jpg

If the camera has the Black / Box type IMU and you installed Version 1.25 gimbal firmware, I'm pretty sure it's going to be a problem.
 
  • Like
Reactions: Steve Carr
Joined
Nov 21, 2022
Messages
11
Reaction score
1
Age
37
@WTFDproject @DoomMeister thanks for replying. The thing I regretted most now is that I didn't record the original version. Seems like I have to open the camera housing and check the IMU.

I wonder if mine is black/box IMU and I flashed a V1.25 on it, is there any chance I could make it right? (like re-flash it to 1.27)?

FYI, the instruction I fellow is Jeff's one 5 yr ago:
 
Joined
Nov 21, 2022
Messages
11
Reaction score
1
Age
37
Hi @WTFDproject , just as you suspected, it uses black/box IMU (red circle in pic 1) and requires version 1.27. I wonder if you have those firmware files and instruction of how to update it to 1.27? Many thanks!

Also, I'm not quite sure what are those two red/black lines (green circles in pic 2)? Are those mics? I don't know where to place them when I put the housing back, so I just left them there.
 

Attachments

  • p1.jpg
    p1.jpg
    1.6 MB · Views: 11
  • p2.jpg
    5.2 MB · Views: 9

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,424
Reaction score
2,702
Location
North Carolina Piedmont, USA
It's been awhile, and I seem to remember it was a lot harder to fix than it is to break. I will have to try some things before I feel confident enough to speak.
Maybe @h-elsner or someone else may already know the answers?
I don't currently have a functioning CGo3+ with the Black/box IMU. I do think I have enough parts to assemble the important bits. Then I will "break it" in a way to make it as much like yours as possible. That will allow me to experiment with reloading the firmware.

I will try to get something together today or this evening.
 
  • Like
Reactions: Lionheart
Joined
Sep 28, 2020
Messages
1,127
Reaction score
396
Age
54
Location
Kozloduy, Bulgaria
Misunderstanding going from my opinion. The broken camera is with 1.25 FW, probably loaded correctly. If the difference in the HW is only the IMU, so we probably add a white one.
 
Joined
Nov 21, 2022
Messages
11
Reaction score
1
Age
37
Misunderstanding going from my opinion. The broken camera is with 1.25 FW, probably loaded correctly. If the difference in the HW is only the IMU, so we probably add a white one.
HI Vaklin, the firmware works for the camera, only the gimbal stopped working.
 
Joined
Sep 28, 2020
Messages
1,127
Reaction score
396
Age
54
Location
Kozloduy, Bulgaria
HI Vaklin, the firmware works for the camera, only the gimbal stopped working.
The camera and the gimbal FW are different as they are different devices. You have updated the gimbal with an unsuitable version. Now you have two solutions. To flash the gimbal with the right FW or to try to prepare the hardware under the present firmware. Here we can think to sniff the camera to gimbal communication with the idea to understand the flashing process of the gimbal...
 
Joined
Nov 21, 2022
Messages
11
Reaction score
1
Age
37
The camera and the gimbal FW are different as they are different devices. You have updated the gimbal with an unsuitable version. Now you have two solutions. To flash the gimbal with the right FW or to try to prepare the hardware under the present firmware. Here we can think to sniff the camera to gimbal communication with the idea to understand the flashing process of the gimbal...
Right now I believe the easier way is to flash the right FW. Unfortunately I cannot find any firmware that have V1.27 in it.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,424
Reaction score
2,702
Location
North Carolina Piedmont, USA
All I can offer is a little progress report. I now have a functioning black/box IMU CGo3+ to work with. And had some limited success in duplicating the failure. Installing version 1.25 did kill the gimbal, but it did not produce any beep codes. I also did not find a way to restore version 1.27 using only software available to the general public.
You mentioned not finding a copy of the 1.27 firmware. It is available on John Mitchells Yuneec Skins website, but the firmware itself will not load by itself. I believe it has to be part of an upgrade package that has the needed bootloader software built in. Since there were no later versions made available after the initial version 1.27, there is no upgrade package. I spent a lot of time trying to replace the version 1.25 firmware in the latest upgrade package with the 1.27 firmware. It looks real good but so far doesn't work at all. Will work more on it.
You may wind up sending the camera for repair anyway. I know John Mitchell's shop can do the work. Some other shops, such as Vertigo Drones may also have everything that is needed.
John can be contacted at:
 
Joined
Sep 28, 2020
Messages
1,127
Reaction score
396
Age
54
Location
Kozloduy, Bulgaria
Reasonable is to try with a "white" IMU on a downgraded gimbal. Doesn't matter it will be not calibrated. If the gimbal starts at least, the calibration is the second stage, which should be possible with less or more effort from the community.

Try this possibility, please. I understand the exact gimbal can not be cured by the owner with this method, but this is a very possible way to repair it for cents, not for $$$.
 
Joined
Nov 21, 2022
Messages
11
Reaction score
1
Age
37
Reasonable is to try with a "white" IMU on a downgraded gimbal. Doesn't matter it will be not calibrated. If the gimbal starts at least, the calibration is the second stage, which should be possible with less or more effort from the community.

Try this possibility, please. I understand the exact gimbal can not be cured by the owner with this method, but this is a very possible way to repair it for cents, not for $$$.
Hi Vaklin,
Two question: 1. where can I get the white IMU;2. is the IMU plug & play, or I need follow some instructions to replace the old one with new? Thanks!
 

New Threads

Members online

Forum statistics

Threads
20,612
Messages
237,860
Members
26,055
Latest member
Erciyes