Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

CGO3+ Gimbal fails after updating firmware to the latest, please help!

Joined
Nov 21, 2022
Messages
11
Reaction score
1
Age
37
All I can offer is a little progress report. I now have a functioning black/box IMU CGo3+ to work with. And had some limited success in duplicating the failure. Installing version 1.25 did kill the gimbal, but it did not produce any beep codes. I also did not find a way to restore version 1.27 using only software available to the general public.
You mentioned not finding a copy of the 1.27 firmware. It is available on John Mitchells Yuneec Skins website, but the firmware itself will not load by itself. I believe it has to be part of an upgrade package that has the needed bootloader software built in. Since there were no later versions made available after the initial version 1.27, there is no upgrade package. I spent a lot of time trying to replace the version 1.25 firmware in the latest upgrade package with the 1.27 firmware. It looks real good but so far doesn't work at all. Will work more on it.
You may wind up sending the camera for repair anyway. I know John Mitchell's shop can do the work. Some other shops, such as Vertigo Drones may also have everything that is needed.
John can be contacted at:
Many thanks @WTFDproject, seems like Mitchell's might be the ultimate solution. But before doing that, I may still wanna try something else. My idea is to change version to a higher number, like V1.28 or something, so it will force the hardware to take the firmware. I don't know if it makes sense to you?
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,424
Reaction score
2,702
Location
North Carolina Piedmont, USA
Many thanks @WTFDproject, seems like Mitchell's might be the ultimate solution. But before doing that, I may still wanna try something else. My idea is to change version to a higher number, like V1.28 or something, so it will force the hardware to take the firmware. I don't know if it makes sense to you?
It might. There was some earlier firmware that could be fooled by that trick. It would be interesting to see if it will work.
 
Joined
Sep 28, 2020
Messages
1,127
Reaction score
396
Age
54
Location
Kozloduy, Bulgaria
1. From any broken CGO3+. They're a lot.
2. No or yes. As I can see, the connector is different, but probably the connector on the round board is the same. @WTFDproject can say if is it replaceable.

He can try to swap them too.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,424
Reaction score
2,702
Location
North Carolina Piedmont, USA
1. From any broken CGO3+. They're a lot.
2. No or yes. As I can see, the connector is different, but probably the connector on the round board is the same. @WTFDproject can say if is it replaceable.

He can try to swap them too.
The connector is the same on the round board end. The flat / white IMU will probably have the wires and connector already attached if it comes from a salvaged camera.
I have doubts the flat/white IMU will even initialize since we are talking about a board that has never had an IMU temp cal. I may be able to try that later this evening. (Note I am currently still trying to restore the firmware for the existing black /box IMU. I don't want to follow two lines of thought on the same project at the same time. I have enough trouble trying to follow one.)
 
  • Like
Reactions: Steve Carr
Joined
Nov 21, 2022
Messages
11
Reaction score
1
Age
37
It might. There was some earlier firmware that could be fooled by that trick. It would be interesting to see if it will work.
It worth to have a try. In case I don't mess up with the version again, @WTFDproject, could you share the correct udpate package and V1.27 firmware here? Thanks!
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,424
Reaction score
2,702
Location
North Carolina Piedmont, USA
It worth to have a try. In case I don't mess up with the version again, @WTFDproject, could you share the correct udpate package and V1.27 firmware here? Thanks!
There is no update package that contains this version of the gimbal firmware. The firmware version used with the box type IMU was apparently never updated, which leaves us in a bad situation when it gets overridden.
See PM.
 
  • Like
Reactions: Steve Carr

New Threads

Members online

Forum statistics

Threads
20,612
Messages
237,860
Members
26,055
Latest member
Erciyes