Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

H520 - Controller not connecting to vehicle

Joined
Feb 1, 2021
Messages
5
Reaction score
0
Age
46
Hi,

I flew my H520 last Friday without any issues.

I tried to connect to the vehicle (with a laptop) this evening to download the logs and noticed would not connect. I tried to power down the vehicle by pressing the power button but got no response. Powers up fine with the power button.

I tried to connect with the controller but can only connect to the E50 camera. I can see video but cannot control the camera. No vehicle battery display.

I notice that the a couple of the dampers had split and leaked on to the vehicle. Perhaps this has caused damage to the board?

Any advice ?

Thanks,

Jez
 
Joined
Jun 6, 2018
Messages
311
Reaction score
168
Age
22
Location
Hamburg, Germany
I notice that the a couple of the dampers had split and leaked on to the vehicle. Perhaps this has caused damage to the board?
Don't worry they are filled with silicon oil which has a very low electrical conductivity. I'm positive you could even submerge the drone in this oil without noticing any effects.

Have you tried setting up a new model on you remote? Sometimes there is something strange going on and this might fix the issue.
 
Joined
Oct 17, 2019
Messages
53
Reaction score
28
Age
58
Don't worry they are filled with silicon oil which has a very low electrical conductivity. I'm positive you could even submerge the drone in this oil without noticing any effects.

Have you tried setting up a new model on you remote? Sometimes there is something strange going on and this might fix the issue.
It's a H520.
So start up the controller, start up the H520,
Keep it upside down till the LEDs are blinking yellow.
Put it straight up on the table and it will bind it self.
The LEDs go automatically in normal mode.
 
Last edited by a moderator:
  • Like
Reactions: DoomMeister
Joined
Feb 1, 2021
Messages
5
Reaction score
0
Age
46
Thanks for your replies,

Yuneec got in touch and sent me an older version of autopilot to re-flash the H520 - which worked.
 
Joined
Oct 17, 2019
Messages
53
Reaction score
28
Age
58
Thanks for your replies,

Yuneec got in touch and sent me an older version of autopilot to re-flash the H520 - which worked.
Can you please make a film how to re-flash the controler?
So all the members can see how it works.
And the software please.
 
Joined
Feb 1, 2021
Messages
5
Reaction score
0
Age
46
As requested - I have zipped the file.

from Yuneec:

All you need to do is place the file into a formatted sd card in fat32 and place this into the camera.
When you switch the drone on everything should act as normal but after a few minutes hopefully you’ll see all the lights go out on the arms and then flash back on with a tone from the drone giving you an indication the reflash is complete.
If this is the case hopefully reconnect the drone to the ST16S again and perform the OTA updates to reinstall the newer auto pilot.
 

Attachments

  • autopilot.zip
    1,022.8 KB · Views: 3
Joined
Feb 1, 2021
Messages
5
Reaction score
0
Age
46
Can you please make a film how to re-flash the controler?
So all the members can see how it works.
And the software please.
The file re-flashes the drone, not the controller.
I'd have to wipe the drone again to do that unfortunately and I have a heavy workload due to being without a drone for a few days. I will do so as soon as I have the time.
 

New Threads

Members online

Forum statistics

Threads
19,664
Messages
227,962
Members
23,476
Latest member
Paul V