Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Hello from Sausalito, CA

Joined
Feb 26, 2023
Messages
43
Reaction score
14
Age
76
Hello from Sausalito, California, just over the Golden Gate Bridge from San Francisco.
I own a Typhoon Q500 4k and have some problems with it after not using it for 3+ years.
I'm so glad I found this forum and I'm hoping to find some answers or members in the Bay Area that can give me some advice.
I'm leaning toward selling mine since I don't use it enough, but I want it to be in perfect working order before I do that.
It worked fine the last time I used t, but now after recharging the batteries the camera seems to work fine, but the rotors don't turn when I press the start button.
 
  • Like
Reactions: GFields
Hello from Sausalito, California, just over the Golden Gate Bridge from San Francisco.
I own a Typhoon Q500 4k and have some problems with it after not using it for 3+ years.
I'm so glad I found this forum and I'm hoping to find some answers or members in the Bay Area that can give me some advice.
I'm leaning toward selling mine since I don't use it enough, but I want it to be in perfect working order before I do that.
It worked fine the last time I used t, but now after recharging the batteries the camera seems to work fine, but the rotors don't turn when I press the start button.
Welcome to the Forum. I think you will enjoy your membership. You will find members happy to provide assistance for any issues you may have, and those that may need information you can bring. A lot of good information is already stored in existing threads.

Couple easy things:
1.) The search Icon is your friend. It's the magnifying glass near the upper right of the screen when you scroll all the way up. It can find many answers you will never find by yourself.

2.) Be aware that you won't always get a quick response. There are times when many other members are on-line, and sometimes only a few. A response may not show up until the right person sees it.

3.) Be aware the forum is Global. If you are exchanging with a member on the other side of the world, response can get delayed and out of sequence due to a difference in local time.

4.) Although the Forum is global, the language is English. It is customary to translate other languages to English. Many members also include the original language post to help alleviate translation errors.

5.) Review the forum rules (on the bottom right). There are not too many, but it is important they are followed to keep the Forum a useful and happy place for everyone.
 
Power on the ST10+ and check the response of all the controls in the Hardware Monitor.

Connect the Q500 to your PC with a data capable USB cable and run the GUI. It will tell you if there are any systems not functioning in the aircraft, and you can test the motors.
 
Hello from Sausalito, California, just over the Golden Gate Bridge from San Francisco.
I own a Typhoon Q500 4k and have some problems with it after not using it for 3+ years.
I'm so glad I found this forum and I'm hoping to find some answers or members in the Bay Area that can give me some advice.
I'm leaning toward selling mine since I don't use it enough, but I want it to be in perfect working order before I do that.
It worked fine the last time I used t, but now after recharging the batteries the camera seems to work fine, but the rotors don't turn when I press the start button.
Very warm welcome to the Yuneec forum
 
  • Like
Reactions: GFields
Welcome to the Forum. I think you will enjoy your membership. You will find members happy to provide assistance for any issues you may have, and those that may need information you can bring. A lot of good information is already stored in existing threads.

Couple easy things:
1.) The search Icon is your friend. It's the magnifying glass near the upper right of the screen when you scroll all the way up. It can find many answers you will never find by yourself.

2.) Be aware that you won't always get a quick response. There are times when many other members are on-line, and sometimes only a few. A response may not show up until the right person sees it.

3.) Be aware the forum is Global. If you are exchanging with a member on the other side of the world, response can get delayed and out of sequence due to a difference in local time.

4.) Although the Forum is global, the language is English. It is customary to translate other languages to English. Many members also include the original language post to help alleviate translation errors.

5.) Review the forum rules (on the bottom right). There are not too many, but it is important they are followed to keep the Forum a useful and happy place for everyone.
Thank you. I've watched some of your videos and they are very well made!
 
Power on the ST10+ and check the response of all the controls in the Hardware Monitor.

Connect the Q500 to your PC with a data capable USB cable and run the GUI. It will tell you if there are any systems not functioning in the aircraft, and you can test the motors.
Is it possible to do step one only?
I'm afraid I will mess something up if I attempt step 2 and I don't have any 12 year olds near me to do it.
Thanks
 
Is it possible to do step one only?
I'm afraid I will mess something up if I attempt step 2 and I don't have any 12 year olds near me to do it.
Thanks
Is it possible to do step one only?
I'm afraid I will mess something up if I attempt step 2 and I don't have any 12 year olds near me to do it.
Thanks
Does this tell you anything?
Thanks
 

Attachments

  • NIK_4913 Q500 Hardware Monitor.jpg
    NIK_4913 Q500 Hardware Monitor.jpg
    4.5 MB · Views: 12
Does this tell you anything?
Thanks
Those values very good. Maybe stir the left stick around a little while to clear J2, but there is nothing there that would inhibit start.

If you are hesitant to try the GUI, it may be a good idea to talk about things like binding and flight mode switch.
1.) I'm not immediately concerned about the flight mode switch, since your picture of the hardware monitor shows it in the correct position, but please ensure it is NOT in the bottom position when trying to start motors.
2.) What color and pattern do you see on the rear LED? This will help us determine if the craft is bound and has acquired GPS.

And I would have to agree with @DoomMeister about the GUI. If you can get it hooked up, it can sure clear a lot of possibilities.

Some documents you might find useful are attached below.
 

Attachments

  • Q500 4K Cheat Sheet.pdf
    466.9 KB · Views: 7
  • q500_4k_user_manual.pdf
    4.1 MB · Views: 5
welcome to the forum. You already heard from the best minds of yuneec drones but I can't imagine why you would live in such an unattractive place. Lolol.
 
Greetings from Birmingham Alabama USA, welcome to the forum! We look forward to hearing from you!
 
Those values very good. Maybe stir the left stick around a little while to clear J2, but there is nothing there that would inhibit start.

If you are hesitant to try the GUI, it may be a good idea to talk about things like binding and flight mode switch.
1.) I'm not immediately concerned about the flight mode switch, since your picture of the hardware monitor shows it in the correct position, but please ensure it is NOT in the bottom position when trying to start motors.
2.) What color and pattern do you see on the rear LED? This will help us determine if the craft is bound and has acquired GPS.

And I would have to agree with @DoomMeister about the GUI. If you can get it hooked up, it can sure clear a lot of possibilities.

Some documents you might find useful are attached below.
Hi-
I'm going to attempt to try the GUI today.
I am able to bind. Yellow/Orange flahes on the rear LED before I do it.
In Angle Mode the LED flashes Purple 3 times, then a quick pause and 3 times again.
In Smart Mode it does the same, but it's Green.
One thing it is now doing, that I don't remember hearing until today is that in Smart mode there is a continuous sort of slightly high pitched ticking or beeping sound kind of like a woodpecker pattern!
This morning my controller was at about 1/2 power and the in Drone battery is at12.2 Volts.
It is pretty bad weather here today, very overcast and raining, so I am indoors and it did not acquire any satellites for a few minutes, so I turned it off.
I will let you know how the GUI goes IF I can get it to work.
Thanks again,
Dennis
 
......
One thing it is now doing, that I don't remember hearing until today is that in Smart mode there is a continuous sort of slightly high pitched ticking or beeping sound kind of like a woodpecker pattern!
If the sound is coming from the controller, it means the right-hand control stick is not centered. And yes, that will prevent motor start. Please listen carefully. It has proven very common for people to believe the sound is coming from the drone. Moving the two away from each other some distance can avoid that minor bit of confusion.
If it's the stick, the problem can often be resolved by rapidly stirring the stick to break up the corrosion on the Pot.
 
Hi-
I was just about to attempt the GUI download when I got your message. I put the drone battery back in and started things up again. This time there was no ticking/beeping sound. I gave the right-hand stick a few wiggles just for good measure and still no siund, so I shut down and went back to the computer to do the GUI download. It appears Yuneec no longer has it! Can you suggest another source for the GUI download of a Q500 4K or will any model Typhoon GUI download work?
Thanks
 
One of the Forum Sponsors, @Yuneec Skins, maintains a repository of Yuneec information. This link will take you to the zip files for the various drones:
So, mission accomplished on the GUI! I don't see any glaring problems, but I probably wouldn'r recognize any if I saw them. I clicked on all for motors and they all spun nicely and sounded smooth. I did notice that I have firmware 1.01 and that ther is a newer one, 1.04 available. Is there any reason to install that id the drone was working fine when I last flew it?
Attached are some photos of my results.
Thanks so much for your help!!!!!!!!!!!
Dennis
 

Attachments

  • NIK_4923 Q500 Sensor Information.jpg
    NIK_4923 Q500 Sensor Information.jpg
    2.7 MB · Views: 6
  • NIK_4925 Q500 Device Information(1).jpg
    NIK_4925 Q500 Device Information(1).jpg
    2.2 MB · Views: 6

Members online

Forum statistics

Threads
20,929
Messages
241,366
Members
27,190
Latest member
Gsw1179