Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

HELP BEEPS OF DEATH!!!!!!!!!

Joined
May 6, 2016
Messages
217
Reaction score
52
Location
Glendale, CA
Hi Guys

I turned my H on just now for the first time in a bout 3 days and i haven't had this happen before.

I turn on the ST16 wait a few seconds then turn on the H...once the H is booted up it makes rapid beeps and won't stop...I tried to re-bind the controller and camera and nothing...this is frustrating since I need to use my H on Sunday

PLEASE ANY ADVICE BEFORE WILL BE GREATLY APPRECIATED...OTHERWISE I AM DOWN FOR THE WHOLE WEEKEND
I have attached a link containing the video of what happens
View My Video
 
Joined
Mar 2, 2016
Messages
1
Reaction score
13
Location
Texas
Your purple light is not flashing purple/white stating you have good GPS/Satellite lock, Do you have metal/interference around your location? Do the compass dance again? All I can suggest !
 
Joined
May 22, 2016
Messages
444
Reaction score
157
Location
Pittsburgh
May sound stupid but is the toggle on the ST16 that switches it from S to A to R set okay? Have you tried switching that? Maybe stuck in A mode since the light is purple?
What happens if you switch it to S, should be green? Or red for RTH...
 
Joined
May 6, 2016
Messages
217
Reaction score
52
Location
Glendale, CA
IT WORKS!

I got reminded why I went with YUNEEC years ago, not only do they have a great product but the best customer service! Baffled when I got home last night I wrote YUNEEC tech support an email along with trying my own trying to figure out what was going on, but by the time I was home EVERYTHING was fine, I hooked it up to the GUI and had no problem everything was green checked and ready to go.

Moises from YUNEEC asked when he replied that very next morning if the sticks were zerod out and thats funny because apart of my tests last night were holding the right stick down and it would beep continuously as it did yesterday and when I let go it stopped...so his and my only idea that maybe the controller was stuck somehow either system wise or physical but the problem is gone! and now that I want to fly again its drizzling in California LOL.

So in closing there is no "known" explanation as to what happened but we are ready to go once the weather clears!
 
Joined
May 6, 2016
Messages
217
Reaction score
52
Location
Glendale, CA
May sound stupid but is the toggle on the ST16 that switches it from S to A to R set okay? Have you tried switching that? Maybe stuck in A mode since the light is purple?
What happens if you switch it to S, should be green? Or red for RTH...
Thank you for your input, but it wasn't that either, still a mystery since its working now
 
Joined
May 22, 2016
Messages
444
Reaction score
157
Location
Pittsburgh
As long as it is working man, that is all that counts. If it does it again work out something to get it replaced for sue though.
 
Joined
Mar 2, 2016
Messages
1
Reaction score
13
Location
Texas
As long as it is working man, that is all that counts. If it does it again work out something to get it replaced for sue though.
Is Sue his wife? LOL ! just had to throw that in ! No pun intended! LOL !:rolleyes:
 
Joined
May 22, 2016
Messages
444
Reaction score
157
Location
Pittsburgh
Joined
May 22, 2016
Messages
444
Reaction score
157
Location
Pittsburgh
  • Like
Reactions: DroneClone
Joined
May 6, 2016
Messages
217
Reaction score
52
Location
Glendale, CA
HAHAHAHAHA that requires a joke drum crash is that what they call it? bum bum chish?
 

PatR

Premium Pilot
Joined
May 1, 2016
Messages
10,154
Reaction score
5,514
Location
N. California
I'm experiencing the rapid beeping issue now myself. Normal green/white light code. Moving the speed slider to slow stops the beeping. On the phone with Yuneec customer service now to establish the cause.

Turns out there was a fault within the ST-16 that required the controller be re-calibrated. There's a secret menu inside System Settings that will take you to controller calibration after hitting "About Controller" quickly a number of times. There are two pages to the calibration process. The first page is the stick controls and sliders, the second page covers every switch, button, and slider on the ST-16 aside from the on/off switch. If doing a re-cal, start with the sliders in a mid/center position. Same with the pan knob.

Ideally you should call Yuneec and get walked through the process. The call also allows them to track issues such as this for product improvement purposes. My call to Yuneec was absolutely painless, obtaining human contact within seconds of the call being answered by the system. The tech was polite, attentive, and thorough. Thanks Mitch!

Edit
Forgot to mention, performing the transmitter calibration resolved the problem. Took about 3 minutes to perform the fix once learning what and where it was.
 
Last edited:
Joined
May 6, 2016
Messages
217
Reaction score
52
Location
Glendale, CA
ya mine seemed i was holding down one of the sticks and causing it to beep so it defiantly was the ST 16
 
Joined
Aug 8, 2016
Messages
38
Reaction score
43
Age
37
Got the same problem last friday. Checked the web to find an answer and probably didn't look well because i only found this thread this morning.

On my side, i did a ST-16 factory Reset. Had to rebind the H and the camera, but once i've done the reset, everything was back to normal !

I will look into the secret menu you are talking about tonight !

CHEERS !
 
Joined
Aug 8, 2016
Messages
38
Reaction score
43
Age
37
Got the same problem again yesterday. This time, i notice it happened right after i did a battery change. I went into the secret menu and it was all ok. ( everything turned green ( passed ))

I think i will go and ask for my money back today.

This problem, the HDMI output port not working properly.... it's just unreliable too much for me.
 
Joined
Aug 15, 2016
Messages
1
Reaction score
0
Location
Denver, Colorado
Performing a calibration of my ST16 controller was the solution to the super beeps problem for me also. Thank you for posting up what Yuneec gave you.

The calibration process itself is not difficult to perform but it's not an intuitive user interface and I relied on two of my favorite software debugging and troubleshooting tools to figure out the calibration procedure; trial and error.

I have a Q500 4K, a Typhoon H, and a Typhoon H w/ Real Sense.
Since I'm very new and learning the drone art, I'm always looking for a good source for replacement parts.
 
Joined
Oct 6, 2016
Messages
5
Reaction score
0
Age
56
My H was doing the same beeping fits as well. a quick move from A to S resolved the problem. This is the second time this has happened. So Ill will be looking into the calibration option next.
 

New Threads

Forum statistics

Threads
17,112
Messages
199,948
Members
19,802
Latest member
Bandit