Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Intermittent twitch and drift to the right 4-8ft...

Joined
Apr 2, 2017
Messages
70
Reaction score
31
Location
WA
Hey people, been working out an issue with a used H I bought (1st one is flawless). You can see the behavior in the video below. When she does this, the only way to make it stop is land it and reboot (one time, I landed and restarted motors for a reset). All you have to do is move the right stick in any direction and it will spaz with a twitch to the right and drift that way 4-8' and then she'll look like the GPS relocks and holds well enough until you touch that right stick again. In the video, I just tap the right stick and let go, if I were to hold the right stick forward, it would twitch then continue to go forward, but will drift to the right like a drunk trying to walk. So far this has been infinitely repeatable when it kicks in (until rebooting copter), but doesn't always kick in, I've gone an entire battery without it acting up. I've also rebooted and it happens again after a few minutes on same battery. I have seen a single flash of orange light on the status behind copter when this happens, just a single blip and seems to come when I tap the right stick, it does not show well in this video.

I've eliminated the usual so far:
1) Environmental factors (3 different places and my other H or XSP doesn't exhibit issue in these places)
2) Latest firmware
3) Multiple calibrations done
4) Even eliminated the st16 (just because I could)

So I am now focusing on the birds hardware. Leaning towards the GPS module and/or flight controller. I was wondering if any of you H experienced have seen this or have any thoughts on how to proceed? Starting to get into reading the telemetry files, but haven't completely wrapped my head around diagnosing that info yet.

Thank you for your thoughts and feedback.

 
Joined
May 10, 2016
Messages
1,645
Reaction score
685
Age
66
Location
Melvin Michigan, In the thumb
Your low to the ground with many trees around. Does she do the same thing if you are above the tree line?
They can interfere with the GPS signal. Looks like she holds pretty steady, but I do see a drift to the right.
1) Calibrate the ST-16
2) try at an altitude above any ground obstacles.
If none of that works, call Yuneec.
Let us know what you figure out.
 
Joined
Apr 2, 2017
Messages
70
Reaction score
31
Location
WA
Thanks fellas, but am past all that 1, 3 & 4 and I know exactly what Yuneec is going to say. Cal'd st16, reset, cleared, checked, even swapped out for another.

Moving ahead, I decided to swap the lids on my 2 H's, effectively replacing the GPS module with one known to be issue free. Painless procedure and I find it comforting that the bird is screaming for a compass cal now, considering. Everything connects, but it will be a long 11 hours before I can put her in the air to see if I still have the glitch.

Out of 6 full charges (4 different batts) only the 2nd batt did not have the glitch somewhere in the flight, if not the entire charge. So pretty sure that doing 6 more charged runs without the glitch would def indicate the GPS module as the culprit.

To be continued...
 
Last edited:

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,195
Reaction score
4,675
Location
Bessemer, MI
I think by changing the top shell you are only changing the GPS antenna. The GPS module is located on the main board I believe.
 
Joined
Apr 2, 2017
Messages
70
Reaction score
31
Location
WA
The module was between the adhesive shielding and top, connecting to mainboard by plug.

Funny, now I get a GPS lock even when I turn off GPS. I have it videoed and need to look into this as I haven't flown atti on either H until today, should drift with the wind, yet she resists.
 
Last edited:

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,195
Reaction score
4,675
Location
Bessemer, MI
The module was between the adhesive shielding and top, connecting to mainboard by plug.

Funny, now I get a GPS lock even when I turn off GPS. I have it videoed and need to look into this as I haven't flown atti on either H until today, should drift with the wind, yet she resists.
Ah, okay. I have not seen any pics of the actual location of the module.

When you turn off the GPS, it really does not turn off. The flight controller simply ignores the GPS for navigation.
 
Joined
Apr 2, 2017
Messages
70
Reaction score
31
Location
WA
ahh, that's interesting Steve, thanks. The kind of thing I was hoping to find out tonight when I start looking. I've only read a few comments about running in atti, but could have swore I seen it done on youtube simply by the settings and turning off the gps slide switch, unfortunately been losing too much time fooling with this one when it was just an opportunity to get a Peau installed and focused lens and some extra batts, turning out to be a cumbersome decision. I like flying my quad in atti, just letting the wind take it where they go and I'll pan the cam for some shots.

EDIT: I remember the video, it was a guy doing H speed tests. Was running 29-30mph up and down wind in gps mode, switched to atti (thought he just turned off gps in software, but have to rewatch later) and he was doing like 48 upwind and 57 downwind.
 
Last edited:
Joined
Apr 2, 2017
Messages
70
Reaction score
31
Location
WA
Nope, didn't take long to confirm a new issue with GPS not disabling. When I slide it off, there aren't any warnings that gps is disabled, she holds a gps lock (doesn't drift) and doesn't get above 29mph. No shortage of videos showing sliding that button and what's expected happens, it does not on this one. I will try disabling gps on my other one and see what happens.


 

New Threads

Members online

Forum statistics

Threads
20,120
Messages
232,698
Members
24,615
Latest member
iwin68bizz