Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Q500 Flying Erradic - flight log and video

Joined
Jun 5, 2016
Messages
8
Reaction score
2
Age
55
I have had my Q500 for about 12 days and it always acts a little strange.

Basically, flying around in Angle mode, Rabbit rate. The Q500 suddenly spins, wobbles, climbs for 3-5 seconds and is unresponsive to controller. Occurs in Home mode as well.

The flight log column labeled error_flags1 is mostly 0, but there are groups of value 32. Any idea what that means?

The flight telemetry file is linked here.
The low res video of the fpv is here. Trouble occurs at about :55, 1:05, and 1:33

Thank you in advance,
Dan (dmsmoke261)
 
Joined
Jun 5, 2016
Messages
8
Reaction score
2
Age
55
Thanks for the response. I forgot to mention that I did a compass and accelerometer calibration after this flight and it made little difference. The drone didn't spin around, but it wobbled like crazy, and didn't respond to the controller. Actually, I was up at 150 feet and put it in Home mode, it wobbled like crazy, descended too quickly. At 30 feet I went back to Angle mode and full throttle to try and keep it from hitting the ground.... No response from drone and it hit at same descent rate, pitched over and broke a prop.

The telemetry data showed the same error_flags1 value of 32 at that moment in flight as it does in the telemetry of the other flights. What does this error value mean?
 
Last edited:
Joined
Jun 5, 2016
Messages
8
Reaction score
2
Age
55
Another thing...
The main LED light flashes purple (3 sec) and white (1 sec) (sometimes white and green). I called tech support and was told this is normal for the new firmware. I have firmware v1.07 high altitude.

Who else has a flashing purple and white light when they have GPS lock, or is the support info wrong?

Support also told me to fly in Turtle rate at high altitude. I was flying in Rabbit rate, but I don't know if that would have made a difference.
Dan (dmsmoke261)
 
Last edited:
Joined
Mar 2, 2016
Messages
1
Reaction score
13
Location
Texas
Another thing...
The main LED light flashes purple (3 sec) and white (1 sec) (sometimes white and green). I called tech support and was told this is normal for the new firmware. I have firmware v1.07 high altitude.

Who else has a flashing purple and white light when they have GPS lock, or is the support info wrong?

Support also told me to fly in Turtle rate at high altitude. I was flying in Rabbit rate, but I don't know if that would have made a difference.
Dan (dmsmoke261)
I do, it's normal!
 
Joined
Mar 15, 2016
Messages
1
Reaction score
1
Age
97
Here are error codes:
Error Flags (set bitwise):
ERROR_FLAG_AIRPORT_WARNING = 128
ERROR_FLAG_FLYAWAY_CHECKER_WARNING = 64
ERROR_FLAG_COMPASS_CALIBRATION_WARNING = 32
ERROR_FLAG_HIGH_TEMPERATURE_WARNING = 16
ERROR_FLAG_COMPLETE_MOTOR_ESC_FAILURE = 8
ERROR_FLAG_MOTOR_FAILSAFE_MODE = 4
ERROR_FLAG_VOLTAGE_WARNING2 = 2
ERROR_FLAG_VOLTAGE_WARNING1 = 1

Here are f_mode codes:
Flight Modes:
f_mode class FModeData Q500 / Typhoon H String
0
FMODE_BLUE_SOLID
Stability mode (Blue solid)
THR
1
FMODE_BLUE_FLASHING
Blue flashing
THR
2
FMODE_BLUE_WOULD_BE_SOLID_NO_GPS
Blue, no GPS
THR
3
FMODE_PURPLE_SOLID
Angle mode (Purple solid)
Angle
4
FMODE_PURPLE_FLASHING
Purple flashing
Angle
5
FMODE_PURPLE_WOULD_BE_SOLID_NO_GPS
Angle mode (Purple solid) - no GPS
Angle
6
FMODE_SMART
Smart mode
Smart
7
FMODE_SMART_BUT_NO_GPS
Smart mode - no GPS
Angle
8
FMODE_MOTORS_STARTING
Motor starting
Start
9
FMODE_TEMP_CALIB
Temperature calibration
Temp
10
FMODE_PRESS_CALIB
Pressure calibration
Pre Cali
11
FMODE_ACCELBIAS_CALI
Accelerator calibration
Acc Cali
12
FMODE_EMERGENCY_KILLED
Emergency/Killed
EMER
13
FMODE_GO_HOME
RTH coming
Home
14
FMODE_LANDING
RTH landing
Land
15
FMODE_BINDING
Binding
Bind
16
FMODE_READY_TO_START
Initializing, Ready to start
Ready
17
FMODE_WAITING_FOR_RC
Waiting for RC
No RC
18
FMODE_MAG_CALIB
Magnetometer calibration
Mag Cali
19
FMODE_UNKNOWN
Unknown mode
20
FMODE_RATE
Agility mode (Rate)
Rate
21
FMODE_FOLLOW
Smart mode - Follow me
Follow
22
FMODE_FOLLOW_NO_GPS
Smart mode - Follow me - no GPS
THR
23
FMODE_CAMERA_TRACKING
Smart mode - Camera tracking
Watch
24
FMODE_CAMERA_TRACKING_NO_GPS
Camera tracking - no GPS
THR
 
  • Like
Reactions: dmsmoke261
Joined
Jun 5, 2016
Messages
8
Reaction score
2
Age
55
Mr. Bennett,
That is a wealth of information. Thank you for posting it.

After calibrating the compass, and calibrating the compass, etc., I still receive the error_flags1 = 32, and strange behavior. The altitude would not hold steady; it would drop for 5-8 seconds or rise for 5-8 seconds. The former scenario proved to be disastrous on 3 occasions. I'm getting it looked at.
Dan
 
  • Like
Reactions: Keith Bennett
Joined
Mar 20, 2017
Messages
19
Reaction score
0
Age
28
Hey did you ever figure out what was a matter I'm getting the same error code and exactly what your describing is happening to my typhoon H an I cannot figure out the problem contacted yuneec for a warranty after it smashed into my neighbors roof then the ground :-/ hoping it's covered. First time any problems have occurred I was a very satisfied customer.
 

New Threads

Members online

Forum statistics

Threads
16,819
Messages
196,344
Members
19,518
Latest member
Sana