Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Quick (mostly useless?) fact: The CGO3 works on the YTH

Joined
May 28, 2016
Messages
107
Reaction score
26
Age
40
Because of the current issue with the CGO3+ on my YTH:
The lens in my CGO3+ is misaligned (pics)

And I still have my Q500 4k, I decided today out of boredom to throw the CGO3 from the Q500, onto the YTH.

Quick summery, it functions just fine. Exactly as it does on the Q500 4k. On the ST16 I just had to connect to the CGO3 wifi, and I was off and running. The only two (one is odd) issues are pretty extreme lag, and some hilarious 80's style video glitching. (see the pics) Otherwise, perfectly functional.

I know this isn't exciting news, just throwing it out there in case anyone else was curious.

Here are a couple shots OF it on the YTH, and WITH it on the YTH.
 

Attachments

  • IMG_20160611_172109.jpg
    IMG_20160611_172109.jpg
    3.7 MB · Views: 42
  • IMG_20160611_173336.jpg
    IMG_20160611_173336.jpg
    5.7 MB · Views: 35
  • IMG_20160611_174823.jpg
    IMG_20160611_174823.jpg
    3.4 MB · Views: 37
  • YUN00006.jpg
    YUN00006.jpg
    1.9 MB · Views: 36
  • YUN00013.jpg
    YUN00013.jpg
    5 MB · Views: 37
  • YUN00023.jpg
    YUN00023.jpg
    5.5 MB · Views: 34

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,146
Reaction score
4,612
Location
Bessemer, MI
Interesting. Neither of my CGO3 cameras have the contacts on the slide mount so I'm out of luck trying it.
 

New Threads

Members online

Forum statistics

Threads
19,955
Messages
230,832
Members
24,212
Latest member
Dino-86