Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Servo melted after internal humming and detectable heat.

Joined
Aug 23, 2016
Messages
2
Reaction score
0
Age
50
Anyones Breeze suffered the same? I had noticed a humming sound from day one.(used drone purchase) and the camera angle never worked. Someone had 3 B and 1 A props. So awaited the props to arrive. Got em and it flys perfectly but the humming went away with no camera angle function. Opened it up to discover the camera servo melted a bit. I replaced it with what seems like an identical servo but now beeps 1,2 4,5 times after powering on with still no camera servo op.

Any ideas out there?
 
Joined
Jun 12, 2018
Messages
129
Reaction score
28
Age
44
Location
Ontario, CANADA
Hey Philip can you take a picture of the melted servo? Also even though the servo may look identical did you check to see the voltage requirements... Some servos are 12, 7.2, 6, 4.8volts. Does your replacement match the stock (albeit melted) servo?
 
Joined
Aug 23, 2016
Messages
2
Reaction score
0
Age
50
Hey Philip can you take a picture of the melted servo? Also even though the servo may look identical did you check to see the voltage requirements... Some servos are 12, 7.2, 6, 4.8volts. Does your replacement match the stock (albeit melted) servo?
Good question. No i did not. The servo in the Breeze has no markings so difficult to tell. Maybe some internet research would have provided something. I'll see about a pic.
 

New Threads

Forum statistics

Threads
19,326
Messages
224,505
Members
22,773
Latest member
Andre Hurter