Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

Trouble with camera connecting to ST16

Discussion in 'Typhoon H Help' started by coolcooch, Nov 24, 2017.

  1. coolcooch

    Joined:
    Sep 22, 2017
    Messages:
    16
    Likes Received:
    1
    Last time I had my Typhoon H out the first battery I had no trouble with the connection between camera and the ST16, the second battery on the same day the camera did not connect with the ST16 until I had landed. Since I am not a techie I have no idea what to do, I did the only thing I could, and that was to take the camera off the drone thinking it might be a bad connection, that is about the extent of my knowledge. Anyone that might give me a idea what might be the problem would be much appreciated. Thanks
     
  2. BobW55

    BobW55 Moderator
    Staff Member

    Joined:
    May 10, 2016
    Messages:
    1,465
    Likes Received:
    597
    Location:
    Melvin Michigan, In the thumb
    Remove the camera.
    Check the contacts on both the camera and the aircraft.
    Sometimes the contacts get pushed down and do not connect.
    Use a hobby knife and gently pry up on the ones that look pressed down.
     
  3. FlushVision

    Joined:
    Jun 19, 2016
    Messages:
    1,063
    Likes Received:
    335
    Location:
    Shaw, Gtr Manchester, U.K.
    I experienced a failure of my camera to connect on power up last Sunday. This rarely happens (usually when the aircraft is cold) but when it does, a power cycle usually puts things right.

    More of a problem (to EU firmware H480s) is the loss of the camera feed which sometimes happens when the landing gear is raised after take-off. The camera re-connects after a minute but by that time all the settings you've done to get good video prior to take-off have gone. This is an issue because unless you land again to set the balances with a card in front of the camera, etc, you have to do it in the air which sometimes leads to a less than perfect camera set up.
     
  4. coolcooch

    Joined:
    Sep 22, 2017
    Messages:
    16
    Likes Received:
    1
    Thanks...much appreciated
     
  5. coolcooch

    Joined:
    Sep 22, 2017
    Messages:
    16
    Likes Received:
    1
    Thanks...I'll give it a try, I did remove the camera,but never looked to see if any of the contacts were out of place...
     
  6. coolcooch

    Joined:
    Sep 22, 2017
    Messages:
    16
    Likes Received:
    1
    Thanks for your reply's...needing all the help I can get since I'm technological challenged