Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Convert Typhoon H to PixHawk 6C Flight Controller

What to explain? Here in the forum was a TH's schematic diagram. Find it, connect any UART - USB, and find a suitable hex terminal. Start listening, analyzing, and so on.

Nothing to say more. As I think, there are almost no people, who can write at least a small software part, so sharing facts will cause more trouble than happiness for everyone here.

I tried to explain in a private conversation with some gurus here how the camera works, how the gimbal works, and so on, without any further success.

So, show some real progress and we can discuss further.
I thought you were referring to the sonar sensor, since that was the only part of my msg that was quoted.

Yes, I've read 📚 many of msgs concerning the CGO3+... Even those that turned it into a GoPro-like camera...
Delays, delays, delays... Still waiting on parts to finally assemble this project... some tests need an assembled drone...

In the meantime, I had to purchase a different FC in order to update the firmware on the 4in1 ESC's. Simply couldn't perform the ESC update using PX4 on PixHawk 6C. Supposedly, it will work with ArduPilot configured for DSHOT. I figured a workable FC would better than flipping the PixHawk back and forth between PX4 and ArduPilot...
I wouldn't have believed but, both the CGO3+ and Landing Gear module require battery voltage. I measured both... Now according to a different post the LG uses PWM...
She ain't pretty, yet... I need to clean up the wiring, connect and test the landing gear module, sort out the camera and figure out the sonar module.

I am able to arm the motors (no blades) but, I had to put throttle slide in jack rabbit mode and depress the start/stop button otherwise it would not arm because of high throttle warning. Depressing and holding the start/stop button will turn off the motors. Cycling through various stick positions (roll, pitch, yaw, throttle) changes the speed of the motors... More testing before its ready to fly.

The compass appears to off by a few degrees.


  • 20240618_085004.jpg
    2.6 MB · Views: 8
Connected the TH GPS as a secondary GPS but, no joy. There is an amber LED blinking on the module but, when I unplug the primary GPS nothing, nada, no GPS at all. The transmitter, ST16, sees sufficient satellites. It has been a long while since my last flight. Maybe I need to replace the battery.
There maybe hope for the TH GPS module. It would appear that the compass portion is working as hmc5883. Not sure as to why the gps portion is not working. I'm using the u-blox protocol for it. I've double and triple checked the cabling. So, I'm at a loss as to why the TH GPS is not being detected.

BTW, the red LED on the TH GPS module is blinking once per second.
Try with NMEA.
I did... I've tried all of the protocols available, u-blox, MTK, Ashtech, Emlid Reach and NMEA and nada. I've also tried stepping through the baud rates. I've also tried reversing the TX/RX leads, in case the documentation had it backwards. I'll try bench testing it with the TH mainboard.
Attached is a parameter file from Thunderbird (PX4 customized FW for Typhhon H). It shows GPS (and other) settings that work with Typhoon H hardware.
Maybe this helps.

Edit: A better set of information gives nuttshell gps status:
NuttShell (NSH)
nsh> gps status
INFO [gps] Main GPS
INFO [gps] protocol: UBX
INFO [gps] status: OK, port: /dev/ttyS0, baudrate: 115200
INFO [gps] sat info: disabled
INFO [gps] rate position: 5.00 Hz
INFO [gps] rate velocity: 5.00 Hz
INFO [gps] rate publication: 5.00 Hz
INFO [gps] rate RTCM injection: 0.00 Hz
timestamp: 233036704 (0.190379 seconds ago)
time_utc_usec: 1718982004599540
lat: ..2261961
lon: ..0963275
alt: 507986
alt_ellipsoid: 555547
s_variance_m_s: 2.5310
c_variance_rad: 1.9988
eph: 8.3150
epv: 38.1940
hdop: 1.6900
vdop: 8.8700
noise_per_ms: 91
jamming_indicator: 28
vel_m_s: 0.1620
vel_n_m_s: -0.0180
vel_e_m_s: -0.1600
vel_d_m_s: -0.5670
cog_rad: 0.0000
timestamp_time_relative: 0
heading: nan
heading_offset: 0.0000
fix_type: 3
vel_ned_valid: True
satellites_used: 5

The LED on the GPS module is a PPS LED (puls per second). It starts blinking if data from sats are received (not necessarily a fix, but I don't know exactly).


  • h-elsner_settings_2020-05-17.params.zip
    4.5 KB · Views: 2
Last edited:
  • Like
Reactions: 1midniterider
More tuning needs to be performed. When I'm testing the motors under vehicle setup, the motors idle, accelerate and decelerate smoothly. When I test the motors (no props) with the radio the motors vibrate a lot, acceleration and deceleration are rough. At throttle in neutral (mid-stick) it's rough... Miles to go...
Wires trimmed, and tucked away... The lower plate is secured to main body using the same holes to secure the upper and lower shells together. I've even made allowances for the upper shell. The power connectors for the landing gear and CGO3+ are also installed...


  • 20240621_212401.jpg
    3.5 MB · Views: 7
  • 20240621_225627.jpg
    3 MB · Views: 7
  • 20240622_071201.jpg
    2.4 MB · Views: 7
  • 20240622_071128.jpg
    1.9 MB · Views: 7
Why must Yuneec be so unique? Connected the landing gear module to power and it didn't fry so that is a plus. Moved on to connect power to the camera shoepad. Hold up! Wait a minute! Five wires come off the shoepad to connect to the TH mainboard but, wait... The connect to the mainboard is only a 4-wire connector. What? No biggie! I'll just reach into my box of connectors, nope! Yet another style of connector. There 1mm, 1.25mm and some other size and style. I'll sort it out, after all I did sign up for this challenge.

Bonus! I connected the TH micro usb port to the PixHawk FC. No more popping the hood to plug in. I also hardwired the MavLink wifi connectors. I needed to lower the profile in order to get the clearance to fit under the hood.
Drone in action, a tabletop exercise. The first segment is testing the motors without blades through the setup facility, followed by with blades... Notice how smooth everything is. So this should rule out a balance issue. The next two segments are flight mode using the ST16, both with and without blades. Notice the shakes... Watch the video.

If you are interested in the "flight logs", go here. Look for "Modified Typhoon H480 with PixHawk 6C".
Last edited:
I think I've figured out the issue. I'm not sure how to fix it, yet. The way I setup the dual 4in1 esc to avoid having too many crissed-crossed wires and balance power is to allow the left ESC control the left motors and the right one the right side. In a perfect world and all things being equal, that should have worked. What I'm seeing is a split-brained situation. The two ESCs are not matching power. I noticed that in the flight logs and verified by moving the yaw to the left initially and everything smoothed out. I could also slide the it to right to achieve balance. Now, how to I fix that? I could allow one ESC to control motors 3, 4, 5 & 6 and the other motors 1 & 2. Or????
  • Like
Reactions: Steve Carr
Maybe try 1, 3, and 5 (LF, RM, LR) on one ESC and 2, 4, and 6 (RF, LM, RR) on the other.
  • Like
Reactions: 1midniterider
Just wondering if the issue with motor output more of an issue with ST16 transmitter calibration? I've calibrated it few times and the settings always end up in the same place. On the sliding scale, the roll, pitch, yaw and throttle are not centered. I wonder should I try to correct this first...

Screenshot from 2024-06-23 14-20-26.png
I fiddled around with rc yaw parameters and was able to eliminate the vibration. However, I'm not sure if that is the right approach.

So, while I'm looking into that issue I disassembled my drone to wrap a shield around the receiver cable and reroute it. The right size paracord should be here in a few days. While I'm at it may as well shield other stuff.

New Posts

Members online

Forum statistics

Latest member