Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

H520E don't connect DataPilot Planner (Win Desktop)

Joined
Nov 3, 2022
Messages
9
Reaction score
1
Age
53
I tried to download the ULOG files via USB from the drone to my laptop as one the video tutorial I found in a thread here suggested - but with no success. I tried several USB cables...without the battery in the drone, then with battery inside and then with the drone turned off and also turned on... to no avail. The program and the drone did not connect at all.
Any idea how I can download the ULOG files from the drone? hen I could upload it to PX4 Flight Review and share it here for inspection?
or...Is it possible to download the ULOG files from the drone to the ST16S controller? I did not find such an option in the DataPilot menu of the controller.

Video - ULG file downloading
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
7,632
Reaction score
4,469
Location
Genesee, MI USA
We’re you using QGroundControl to download the ulog files or DataPlanner?
 
Joined
Nov 3, 2022
Messages
9
Reaction score
1
Age
53
We’re you using QGroundControl to download the ulog files or DataPlanner?
I tried both. First the QGroundControl as this was used in the video. Then I installed DataPilot Planner. No success with any of them
DataPilot Planner Version: v2.1.22
:(
 
Joined
Nov 3, 2022
Messages
9
Reaction score
1
Age
53
Try to start QGC or DataPilot (whatever you use) as Adminstrator. What Windows version do you use?
br HE
I run the DataPilot (QGC was uninstalled after I installed DataPilot) as an admin - still no connection. I uninstalled then installed it again as an admin - still no connection to the drone. :(

Few mentioned here in other threads that the USB port on the drone sometimes faulty. But earlier I was able to connect the drone to te ST16S controller and update the camera/gimbal/drone OFDM...
I can't try the USB in this way as there is no updates available for the drone.
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
7,632
Reaction score
4,469
Location
Genesee, MI USA
You can reinstall QGC and use it only to download the ulg files. Never try to use it to control or calibrate the H520E.

Since you are not seeing communication with DataPilot, it is lending credence to the USB port being defective.

Is the USB port a MicroUSB or a USB-C? Although USB-C is supposed to be able to be inserted in either direction, many in other forums have reported that it only works when inserted in one direction and not the other.
 
Joined
Nov 3, 2022
Messages
9
Reaction score
1
Age
53
You can reinstall QGC and use it only to download the ulg files. Never try to use it to control or calibrate the H520E.

Since you are not seeing communication with DataPilot, it is lending credence to the USB port being defective.

Is the USB port a MicroUSB or a USB-C? Although USB-C is supposed to be able to be inserted in either direction, many in other forums have reported that it only works when inserted in one direction and not the other.
I reinstalled QGC and started as admin...still no connection.
H520e has a MicroUSB on the back of the drone in he OFDM module. So it migh be a faulty USB connector? I wonder what Yuneec would would do about it if I ask them for the repair. It i practically new with 11 min. HOBBS time
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
7,632
Reaction score
4,469
Location
Genesee, MI USA
Hard to say what they would do. Since you are in Europe you may have different rules about warranty issues.

The defective USB connector manifested itself with several members while trying to do updates. The same may have happens with yours. The main Yuneec repair center is in Germany, but it seems to me there is a member of the forum that knows of a repair facility in Sweden or Netherlands. Maybe they will respond to the thread.
 
  • Like
Reactions: drn-yf

h-elsner

Premium Pilot
Joined
Mar 23, 2016
Messages
1,684
Reaction score
1,312
Location
Bavaria / Germany
I have only an old H Plus mainboard (ESC defect) to test connection. Did it yesterday - no problem with QGC and LINUX PC. At Windows 10 PC you need to wait some time (a minute or so) until it connects but it works too. Connected it without battery, power only over USB to CPU STM32.

To test the USB connection you can check if in device manager a new device appears when you connect USB. H Plus looks like that:
Device_Manager_HPlus.png
Maybe for H520E there is another device but something must happen when you connect or disconnect the USB connection at least an update of the devices listing. If not either device driver is missing or USB connection is defect or it is the wrong USB connector (is there only one on the drone?).

As device driver I would try STSW-STM32102 - STMicroelectronics

br HE
 
  • Like
Reactions: DoomMeister

New Threads

Members online

Forum statistics

Threads
20,612
Messages
237,860
Members
26,053
Latest member
shv2sail