Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

No connection possible with USB from drone to remote control. (For updates) - Defective USB socket, support exchanged drone

Joined
Nov 12, 2020
Messages
57
Solutions
2
Reaction score
23
Age
24
Location
Bavaria / Germany
EDIT: The drone is sent in, according to the technician probably defective USB socket. - Drone got replaced by a new one, everything works now.

Short: Is there a way to reset everything (RC and Drone) ? or install manually the Firmware to the Drone (ST16E does not recognize the drone via USB)? (My PC recognizes the connected drone but I can then still do nothing).


Long:
Today I saw the new version of the DataPilot app in the Appstore (2.0) and downloaded it and could have used it. I was shown several updates there:
1622560621304.png
I had put off the updates until after my upcoming appointments and had hopes that these updates would finally fix my problems with the software.

So I have everything connected and started as it says in the instructions. Only problem is, the RC is updated. But since RC OFDM link is up to date, the drone no longer connects permanently, or not at all with the RC. Constantly for 1 second the connection is there and immediately breaks off again, GPS etc is all transferred. (Manual control lost)
-EDIT: After I unscrewed the antennas as a test, the connection no longer breaks. If I wrap the outer antennas in aluminum foil, the connection is maintained. But still no Connection via USB.-

The problem is that I can not connect the drone via USB as the instructions say. I have tried 2 cables, in different orders and restarted several times. had no success in the last 3 hours.
EDIT: I have also reinstalled the app several times (old and new Versions), directly from the appstore, as well as from the website.

What can I do now? I am dependent on the drone professionally and am now in a bit of a pickle.
 

Attachments

  • H520E+OTA+Update+EN.pdf
    366.6 KB · Views: 12
Last edited:
Solution
So I brought the drone to the post office on 4.6.21 and got it back today 9.6.21 , so after the weekend.

The drone was not repaired but directly replaced completely by a new one. The remote control etc are the old.
Also on mine are larger antennas on it, which is why I cut out the styrofoam.
(Unfortunately they forgot to include the USB cable again ... )

With me, everything was updated and is therefore up to date.
@terrence davidson I think if the USB connection works, the update should also work. With me it was probably a defective USB socket.

Also my other problem with the incorrect EXIF information is now fixed.

The only thing that remains is that I am still "afraid" when landing because it has already tipped over...

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,595
Reaction score
3,804
Location
Genesee, MI USA
Well, when it tipped over, it was a large flat parking lot and full speed.
The drone was completely on the ground, all 4 "feet", even already felt 2-3 seconds or longer but had not switched off and then all at once quickly tipped over (probably have 2 motors revved up).

Either it had frozen after that or already before, because after that it didn't react to any of the inputs anymore, not even to emergency stop.
I then had to pull the battery from the still running drone.

maybe it has to do with the reason why I landed at all is.
In mid-air it has switched from angled to manual (Probably GPS loss). But I have directly set the lever once from angled to manual and back to angled, which has solved the problem immediately. Nevertheless, I landed promptly out of caution. (and at the exact same place also 10 minutes before to exchange the battery). And that's when it happened.

And now I'm scared every time it stands on 2 of the 4 feet for a short moment, that it will happen again. ¯\_(ツ)_/¯
That’s was definitely strange behavior, so I understand why you are scared of it reoccurring.
 
  • Like
Reactions: Hypano

New Threads

Members online

Forum statistics

Threads
19,900
Messages
230,057
Members
24,057
Latest member
Marc E