Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Help Typhoon H Won't Power Up

Joined
May 5, 2016
Messages
146
Reaction score
40
Age
59
Hi All, Need some help this morning I went to go flying and the Typhoon H powered up fine I got connected to the transmitter and all looked well. I did not start the props yet as I noticed that I had forgotten to insert the SD Card (the one from yuneec). So I powered down the unit (it powered off fine) kept the transmitter on then after inserting the SD card I went to power the Typhoon back up and nothing, nada no sound no lights. I checked the battery with a volt meter and 16.72 volts. When I got to work, I plugged the battery into the charger and it went solid green so it doesn't look like a battery problem. I hope its something easy as I'm going on vacation on the 25th of this month and I bought the Typhoon H to bring with me to Hawaii this is only my 6th flight as I have been travelling for work and when the H arrived so I was a late started the other 5 flights went off fine. I searched the form but really didn't see anything. I tried to reinsert the battery multiple times no luck. I did smell anything strange either. Let me know if you guys seen this before. The SD card looks to be fine as I can access the files on a computer. Oh and I didn't even pick up the drone just rotated the camera so I could get at the SD card slot.
 
Last edited:
Joined
Apr 20, 2016
Messages
266
Reaction score
76
Location
Gateway to Cape Cod
I know the props will not turn on if in RTH mode but I'm pretty sure the H itself will energize.
Be sure the battery is seated completely in the socket.
Did you try to energize the H without the SD card in the camera again to see (taking a wild shot here) if that had anything to do with it?
 
Joined
May 5, 2016
Messages
146
Reaction score
40
Age
59
Thanks for the reply, Yes I removed the card and re-seated the battery about 6 times so far. I let it sit for about a half hour re-insentered the battery and tried again no luck. I'm in angle mode when I fly. I also wanted to add no hard landings prior to this flight.
 
Last edited:
Joined
Apr 20, 2016
Messages
266
Reaction score
76
Location
Gateway to Cape Cod
Thanks for the reply, Yes I removed the card and re-seated the battery about 6 times so far. I let it sit for about a half hour re-insentered the battery and tried again no luck. I'm in angle mode when I fly. I also wanted to add no hard landings prior to this flight.
Call Yuneec Customer Service. They are pretty good.
 
Joined
May 5, 2016
Messages
146
Reaction score
40
Age
59
The bird is going back today Yuneec CSR said they have not seen this issue. Andrew was extremely helpful and said they'll push to have it back to me before my trip on the 25th to Hawaii. Hopefully they can follow through and it's something simple. Sending back the Bird, Transmitter and Battery. Off to my house then UPS. Thanks for the reply's appreciate it. Just really strange initial power-up fine no issues link to transmitter 20 SATS and I believe battery on the bird was reading 16.8V via transmitter. Just forget to insert the SD card, that's when it happened. Powered down insert card and that's when the crickets start chirping. I guess I'm lucky it didn't loose power while it was aloft that would have sucked. I'm in the semiconductor and strange things happen with electronics. I have to deal with testers that are powered on 24/7/365 and they don't like to be powered down, if there's a power glitch then sh#t most always hits the fan.
 
Joined
May 3, 2016
Messages
145
Reaction score
37
Mine did the very same.
She would only give one short beep when the switch was held down.
No rising tone and no nav lights. She was comatose :-(
Camera would level a few seconds later as if it was initialising.
I could see some blue LED's inside her brain but she was veggied.
She had to go to H clinic.
I had four weeks sans H while they tried to diagnose.
I eventually got a replacement. Probably someones ex but she looks
and feels good and boots up great again and is fun to have around.
The On switch works now and the Off switch works great too when your done.
 
Joined
May 5, 2016
Messages
146
Reaction score
40
Age
59
Hey, at least you got a beep, mine acts like as there no battery/power available. Anyway we'll see what they find.
 
Joined
May 3, 2016
Messages
145
Reaction score
37
I was trying to update the firmware through the GUI because it had failed to update through the camera. The buggy old GUI crashed during the update attempt and left the H bricked.
The tech guy at H-Q, told me that there was a switch issue. I operated on H but the switch seemed fine. That could be your trouble..
 
  • Like
Reactions: Malibu_Rod
Joined
May 5, 2016
Messages
146
Reaction score
40
Age
59
Ok, Hey thanks for the heads-up hope its that easy. I wonder if they go through the entire bird digs or just look at the issue it came in for. Would make sense to go through the whole bird diagnostics to be on the same side should take that long.
 
Joined
May 3, 2016
Messages
145
Reaction score
37
Dealer said they like to get them back to stick the diagnostics on them, especially if its a new issue.
Pity I had to wait so long after waiting so long...
 
Joined
Apr 4, 2016
Messages
1,358
Reaction score
959
Age
56
Location
Ottawa, Canada
Hi All, Need some help this morning I went to go flying and the Typhoon H powered up fine I got connected to the transmitter and all looked well. I did not start the props yet as I noticed that I had forgotten to insert the SD Card (the one from yuneec). So I powered down the unit (it powered off fine) kept the transmitter on then after inserting the SD card I went to power the Typhoon back up and nothing, nada no sound no lights. I checked the battery with a volt meter and 16.72 volts. When I got to work, I plugged the battery into the charger and it went solid green so it doesn't look like a battery problem. I hope its something easy as I'm going on vacation on the 25th of this month and I bought the Typhoon H to bring with me to Hawaii this is only my 6th flight as I have been travelling for work and when the H arrived so I was a late started the other 5 flights went off fine. I searched the form but really didn't see anything. I tried to reinsert the battery multiple times no luck. I did smell anything strange either. Let me know if you guys seen this before. The SD card looks to be fine as I can access the files on a computer. Oh and I didn't even pick up the drone just rotated the camera so I could get at the SD card slot.
So it's a power issue. When you inserted the card something glitched. My first fault finding step would be to remove the camera and try powering it up without it.
 
Joined
May 7, 2016
Messages
1,140
Reaction score
358
Age
72
Location
Gurdon, Ar
My sentiments exactly.
 
Joined
May 5, 2016
Messages
146
Reaction score
40
Age
59
Yea its defiantly a power issue. My first step was to work back wards from when it did work. I removed the card didn't touch the bird tried to power up - Nothing, picked up the drone and re-insert the battery - nothing, re-insert again for Sh*[email protected] and giggles, - nothing. Remove the battery, remove the camera assembly. re- insert the battery - nothing. So I packed up and went to work. I checked the battery voltage 16.72v plugged it into the charger. Charger lit Green let it sit for 10 minutes, still Green. Tried to plug it into the bird nothing, Tried installing the camera assembly - nothing. I tried the SD Card into computer and its fine, no Issues I thought maybe the card as one member mentioned yesterday that the card melted the adapter. Anyway it act's like there is no power at all so it sounds like the switch issue. I troubleshoot stuff for a living. I just don't want to take this apart as I don't have the parts I could scope it but I need a schematic. I'm sure I could figure it out but if Yuneec is going to fix it why bother. I was just looking to see if others had this issue before and it was just something stupid I missed (Done that before too) its just weird but I have seen it in million dollar testers before. But thanks for your reply's guys I do appreciate your input.
 
Last edited:
Joined
May 5, 2016
Messages
146
Reaction score
40
Age
59
I was all happy this morning because I was going to a new spot to fly and a park close to the Bay 2 minutes from work on the way I got a delivery notification that my second battery was arriving in the afternoon from Captain Crunch. I though "hey gonna be good day" I'll get some more flights in when I get home as I'll have two batteries now. Then it happened, oh well, got to chalk it up to "[email protected]* Happens !" I guess :)
 
Joined
Sep 14, 2015
Messages
272
Reaction score
73
Location
Oklahoma
That really sucks. Frustrating. Hopefully they do a quick turnaround for you!
 
Joined
May 5, 2016
Messages
146
Reaction score
40
Age
59
That really sucks. Frustrating. Hopefully they do a quick turnaround for you!
Yeah not too bummed I just hope they can turn it before my trip, the rep said he would try to push it on his end. So for now gotta keep my fingers crossed and hope for the best if not then I'll really be bummed out as I'll be gone for two and half weeks in Hawaii for a family reunion, which was one of the reasons I pre-ordered the drone (not way ahead like most of the folks on here just a few months before). I went straight home to get the box then right to the UPS station as soon as I got off the phone with the rep as he did everything while we were talking (RMA & Shipping label) so far the service has been outstanding. I didn't have to wait on the phone that long either this morning, of course I called at 8:30 AM.
 

Murray Martz

Moderator
Staff member
Premium Pilot
Joined
Jan 29, 2017
Messages
957
Reaction score
398
Location
Saskatchewan, Canada
Yeah not too bummed I just hope they can turn it before my trip, the rep said he would try to push it on his end. So for now gotta keep my fingers crossed and hope for the best if not then I'll really be bummed out as I'll be gone for two and half weeks in Hawaii for a family reunion, which was one of the reasons I pre-ordered the drone (not way ahead like most of the folks on here just a few months before). I went straight home to get the box then right to the UPS station as soon as I got off the phone with the rep as he did everything while we were talking (RMA & Shipping label) so far the service has been outstanding. I didn't have to wait on the phone that long either this morning, of course I called at 8:30 AM.
Was the final result a faulty power button?
 

New Threads

Members online

Forum statistics

Threads
16,800
Messages
196,035
Members
19,489
Latest member
tmhicks