Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

How do I reset the clock to the correct local time??

Joined
Jun 7, 2016
Messages
232
Reaction score
38
Age
84
Location
Near Seattle, WA
I noticed the time in my ST16 is an hour slow. I went into the Pad/Settings and tried resetting the time, but once I had it corrected, I switched back to the main screen and the time was still an hour slow. I checked to make sure I had Pacific Daylight Time set, but every time I attempt to correct the time, it still doesn't save the new setting. And of course the manuals don't say a darn thing about this!

Mojoe35
 
Joined
Apr 24, 2016
Messages
495
Reaction score
201
I noticed the time in my ST16 is an hour slow. I went into the Pad/Settings and tried resetting the time, but once I had it corrected, I switched back to the main screen and the time was still an hour slow. I checked to make sure I had Pacific Daylight Time set, but every time I attempt to correct the time, it still doesn't save the new setting. And of course the manuals don't say a darn thing about this!

Mojoe35
This is a known bug, some people thought they had the fix but it does not last to keep the correct time.
We will have to wait for a firmware fix on this one.
 
Joined
Mar 2, 2016
Messages
1
Reaction score
13
Location
Texas
Did you select "Save" after setting new time? I am sure you did! Because mine saved the time just fine!
 
Joined
May 28, 2016
Messages
62
Reaction score
16
Age
70
Did you select "Save" after setting new time? I am sure you did! Because mine saved the time just fine!
Where is the "Save" button? I don't see that anywhere when setting time or date.
 
Joined
Mar 2, 2016
Messages
1
Reaction score
13
Location
Texas
Where is the "Save" button? I don't see that anywhere when setting time or date.
I meant the "Done" botton, sorry!, One thing I did select and keeps the time correct is at the top of the time settings is a box to check/uncheck, I chose check. It says "Automatic Date and Time" "use network date and time" I check that box? Hope it helps!
 
  • Like
Reactions: jwjohnson
Joined
May 28, 2016
Messages
62
Reaction score
16
Age
70
I meant the "Done" botton, sorry!, One thing I did select and keeps the time correct is at the top of the time settings is a box to check/uncheck, I chose check. It says "Automatic Date and Time" "use network date and time" I check that box? Hope it helps!
Thanks. I'll try it again.
 
Joined
Jun 7, 2016
Messages
232
Reaction score
38
Age
84
Location
Near Seattle, WA
Did you select "Save" after setting new time? I am sure you did! Because mine saved the time just fine!
I thought I did save, but I just tried again with the same result of incorrect time. However, I didn't see a "save" button. I just tapped the 'Done' button and when I went back to the main screen, the time was wrong again.

I did hear from someone else saying it's a known problem and perhaps the next update will fix it.

Mojoe35
 
Joined
Apr 6, 2016
Messages
56
Reaction score
15
Age
54
I unchecked the "Use Network Time", set the correct time. DON'T click anything else. Turn OFF the controller. wait a minute or two and see if that works. Worked for me.
 
Joined
May 11, 2016
Messages
100
Reaction score
84
Age
71
Location
Monrovia, MD
What worked for me to over ride the bug is to go into the pads settings, go down to date/time, uncheck Automatic date & time, select a time zone that's 1 hr less negative. I'm on EDT and so I chose Atlantic Time (Canada) with is GMT-3:00 vs using Baltimore which is GMT-4:00. That fix seems to have held and is what I'll use until the bug is fixed.
 
Joined
Jun 7, 2016
Messages
232
Reaction score
38
Age
84
Location
Near Seattle, WA
Ok, thanks for the tips on resetting the clock. I've just done it again and also show GPS Locked and the time is still correct.
I'll shut it down and check again later this afternoon.

I sure appreciate all the help found here on the Forum.

Mojoe35
 
Joined
May 24, 2016
Messages
281
Reaction score
76
Same here as soon as you leave the pad screen and go back to flight screen it goes back to one hour, I also tried as suggested set the time and just switch the controller off and leave a minute and switch back on directly the flight screen boots up you actually see the clock roll back one hour, so I guess there is a bug in some off the controllers.
 
Joined
Apr 4, 2016
Messages
1,358
Reaction score
959
Age
56
Location
Ottawa, Canada
Same here as soon as you leave the pad screen and go back to flight screen it goes back to one hour, I also tried as suggested set the time and just switch the controller off and leave a minute and switch back on directly the flight screen boots up you actually see the clock roll back one hour, so I guess there is a bug in some off the controllers.
Time is controlled via GPS signal. Does not matter what you set it as, GPS will override. I think it's a daylight savings bug.
 

Hal

Joined
Apr 12, 2016
Messages
204
Reaction score
58
Age
53
Yes... I agree, time is set by GPS and GPS knows nothing about daylight savings time. That's where the tablet needs to know to adjust for the American daylight savings time based off of the GPS time. I think the work around is, as mentioned, choose another time zone.
 
Joined
Jun 7, 2016
Messages
232
Reaction score
38
Age
84
Location
Near Seattle, WA
Well, I did reset the clock again and turn it off after tapping the 'done' button. I waited a few minutes and restarted the ST16 and it had the correct time showing. Great, I thought! But, a while ago I turned on the ST16 and it was an hour slow again! I guess we'll just have to wait until the next firmware version comes out and hope it's fixed by then. It really doesn't hurt having the wrong time, but I do like my pictures to show when they are taken. Sigh....

Mojoe35
 

New Threads

Forum statistics

Threads
17,103
Messages
199,821
Members
19,794
Latest member
zajter