Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

How To: Tell if my phone, tablet, or pad is compatible with the Breeze?

Status
Not open for further replies.

DoomMeister

Moderator
Staff member
Joined
Dec 25, 2017
Messages
2,313
Likes
820
#1
As a general rule your device must support 802.11ac WiFi to work with the Breeze. Some devices will work that only support 802.11a, but if your device only supports 802.11b/g/n it will not work with the Breeze directly.

The best place I have found to check the specifications of your device is GSMArena.com. They list most devices and are consistent with the information provided.

For those that have the Bluetooth controller for the Breeze, your device needs to support Bluetooth v4.1 or better. Some devices with B/T v4.0 work, but many crash the Breeze Cam app.

Hoping this will help resolve the mystery of what WiFi is needed to successfully work with the Breeze.
 
Status
Not open for further replies.

New Threads

Forum statistics

Threads
14,250
Messages
162,420
Members
17,023
Latest member
Dronelee