Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Loss of RC at only 236m out with Raptor XR- Why?

Joined
Nov 10, 2016
Messages
423
Reaction score
220
Location
London, ON Canada
I was flying at a gravel pit pond and attempted an Orbit around a small island in the pond. The orbit started OK but at about half of the first circle, I got a "lost RC warning" and the H520 stopped. at this point, I selected RTL and the copter executed the return normally, and then I switched to angle mode when it was closer and control was back to normal. There were no obstructions between me and the copter at all. I am using a Raptor XR range extender on the ST16s. The furthest distance of the flight was only about 236m from the controller.

I examined the ulog file on "logs.px4.io" and will attach the file here. It showed some strange (to me) results. For instance in the "RSSI to Jamming" graph. (I assume high jamming is bad). I welcome analysis by our experts here to try to understand what happened and if it might be a problem with my ST16s with the Raptor XR. Also attaching a screen dump of the flight path - purple is Orbit and RTL.
 

Attachments

  • Hunt road pond.JPG
    Hunt road pond.JPG
    64.5 KB · Views: 13
  • 0e3a304a-87db-46e3-bc0e-16157cb0e750.zip
    16.9 MB · Views: 18

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,824
Reaction score
3,942
Location
The Villages, FL USA
My first guess would be to check the cables for proper continuity that are used to connect the XR.

Do you have such a limited range using the stock antennas?

Are you keeping the XR pointed right at the aircraft?
 
Joined
Nov 10, 2016
Messages
423
Reaction score
220
Location
London, ON Canada
1 The connections from the antenna to the ST16s are tight, I haven't tested the continuity of each cable - can do that...
2 No, the stock antennas never had a range issue- had previously gone out approx 700-800m without loss.
3 The controller was always pointing laterally at the aircraft, but Its possible that the flat surface of the XR antenna was aimed slightly too high for the altitude of the aircraft.

If anyone has time I would like an analysis of the ulog file. Some of the data I am not familiar with to say if its "spooky" or "normal" For instance the "GPS noise and Jamming" graph.....
 

Attachments

  • GPS noise and jamming.JPG
    GPS noise and jamming.JPG
    57.3 KB · Views: 7

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,824
Reaction score
3,942
Location
The Villages, FL USA
I use a range extender by another company that is of the same construction and design as the XR that you use. I don’t think the aim in elevation would have that much effect unless it was aimed well above the aircraft (like 45 degrees or more) especially since you say it was aimed at the aircraft in the azimuth. I would definitely check the continuity in the two outside cables that carry the 2.4GHz Zigbee RC signals.

Since there was no range issue with the stock antennas this lends credence to an issue with the cables or terminations in the antenna itself.

I will look at the ulog data, but like you there is a lot of it that find quite cryptic like the GPS noise and jamming.
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,824
Reaction score
3,942
Location
The Villages, FL USA
I loaded your ulog file into the PX4 Flight Review Flight Review

Your Rssi values appear to be quite low and did trigger a loss of RC that initiated the autoRTL. The help file for PX4 Flight Review states that the GPS jamming indicator should be at or below a value of 40 and the plot for this flight is showing values well above that. The help file suggests checking for things that operate in the frequency range of the GPS signal (like USB3.0).

I would like to see a ulog file from a flight that was using the stock antennas for comparing to this flight.
 
Joined
Nov 10, 2016
Messages
423
Reaction score
220
Location
London, ON Canada
Here is a ulog file from a structure scan with the 520 I did in May. The ST16s had the standard antennas at that time. There is a dranatic difference in the "GPS noise and Jamming" file compared to the RC loss file.
BTW, I tested both 2.4 antenna cables for continuity and they are fine.
 

Attachments

  • 9f485374-62cc-44ed-bf92-2d117c07bafc-stock.zip
    11.3 MB · Views: 1

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,824
Reaction score
3,942
Location
The Villages, FL USA
The first thing I checked in the ulog with the stock antennas was the GPS Noise and Jamming Indicator. That was a much better looking graph. You may want to compare several other flights with the two different antenna systems to see if there is a correlation with them and the GPS quality.

Looking at the Rssi plot I see relatively weak RC signal for a max distance of at most 80 meters and there were indicators of RC signal loss, but not enough to trigger an autoRTL. I am not totally sure if the control during a mission is conducted over the 2.4GHz Zigbee RC or through the 5.8GHz WiFi via the camera link. If it via the camera link it may explain the drops in signal level as the aircraft and camera rotate to different positions during the mission. The 5.8GHz WiFi signal is less robust and is more easily blocked by vegetation and buildings.

When you tested the cables did you check center to center, shield to shield, and center to shield? C to C and S to S should be near 0 ohms, C to S should be open or very high resistance >1MOhm.
 
Joined
Nov 10, 2016
Messages
423
Reaction score
220
Location
London, ON Canada
Thanks for looking into the files. A lot of the data in the ulogs is difficult (for me) to process in terms of how it affects flight of the copter.
Re the continuity of the cables - I only checked the centre to centres, will follow up with a full test as you suggest.
I also have a Raptor SR and Itelite antenna on a H480 and H920+
Getting heavy weather here (London, ON) for a few days, but when it clears, my plan is to do a comprehensive 4 flight test with the 520 using, the same site, flight plan and stock vs Raptor XR, vs Raptor SR, vs Itelite antennas.
I think there is also a (remote) possibility that the XR antenna itself is defective and wondering if there is a way of testing it other than risking a long distance flight test?
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,824
Reaction score
3,942
Location
The Villages, FL USA
We are getting the same ugly wet weather you are right now. London is almost straight east of Genesee, MI.

The Rssi is a bit harder to read in the plots on the PX4 Flight Review, but I equate the plot with what I see for the TH or TH+ using @h-elsner Q500log2kml program. The green in the Rssi usually equates to low 2.4GHz RC signal and the 5.8GHz WiFi redundancy taking over. When this is happening you will sometimes experience lag in the controls. When you see the light blue RC loss there will be an autoRTL activated.

I use an Itelite antenna with my Typhoon H. I have had it out about 1300 meters with good control and video feed. I didn’t go further as I had just lost VLOS and was approaching a busy highway. I did a 180 and headed back.

I would try doing distance flights as loss of control should result in an autoRTL and compare the signal levels from the flightlogs. Since you have the other antennas they should be interchangeable so you can find if the XR may be faulty. There is actually little difference in the SR and XR as far as design. The XR does provide more amplification and has a narrower beam width.
 

h-elsner

Premium Pilot
Joined
Mar 23, 2016
Messages
1,407
Reaction score
1,030
Location
Bavaria / Germany
  • Like
Reactions: DoomMeister
Joined
Nov 10, 2016
Messages
423
Reaction score
220
Location
London, ON Canada
Today I did a comparison test of three types of antennas that I have for the ST16S, 1) Standard antennas, 2) Raptor SR antenna, and 3) Raptor XR antenna. The flights were in the same location, approximately similar flight paths, and all within 1 hour. I uploaded the ulogs to Flight Review, and took screen shots of the GPS and Jamming files, the RC Quality files, and images of the flight paths.

I am attachiing a PPT file that shows the images side by side and the "Standard" antennas and "Raptor SR" antenna had better RC quality than the "Raptor XR" which showed high RC loss "indicated" as well as very high jamming compared to the Raptor SR, but similar to the Standard antennas.

This suggests to me that the Raptor XR antenna which I bought new in June 21, may be defective.
 

Attachments

  • AA ST16 Antena Test.zip
    375.1 KB · Views: 4
  • Stock RC qual.JPG
    Stock RC qual.JPG
    40.9 KB · Views: 4
  • SR RC qual.JPG
    SR RC qual.JPG
    40.3 KB · Views: 4
  • XR RC qual.JPG
    XR RC qual.JPG
    52.9 KB · Views: 4
Joined
Nov 10, 2016
Messages
423
Reaction score
220
Location
London, ON Canada
Let me know if the previous zipped powerpoint file is available for download. I will attach it again.....
 

Attachments

  • AA ST16 Antena Test.zip
    375.1 KB · Views: 0

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,824
Reaction score
3,942
Location
The Villages, FL USA
I will try to get caught up with you tomorrow. I’ve been busy the last couple of days.
 
Joined
Nov 10, 2016
Messages
423
Reaction score
220
Location
London, ON Canada
Update: I contacted 4Hawks and they were also puzzled by my issue with the XR antenna. After some back and forth they agreed to replace the antenna with a new unit, which I have since received, tested and seems to be working fine.
 
Last edited:

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,824
Reaction score
3,942
Location
The Villages, FL USA
Update: I contacted 4Hawks and they were also puzzled by my issue with the XT antenna. After some back and forth they agreed to replace the antenna with a new unit, which I have since received, tested and seems to be working fine.
Glad to hear they replaced it with a good unit. All it takes is a weak solder joint to turn these antennas into useless weight. I’m thinking of switching to the 4Hawks as it is a more compact unit than the Itelite I am using.
 

New Threads

Members online

Forum statistics

Threads
20,048
Messages
231,821
Members
24,392
Latest member
TomF