Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Please help: chroma st10+ yuneec blade transmitter version number st10_rc_app_v00.00b29_repair

Joined
May 29, 2016
Messages
5
Reaction score
1
Age
38
Under step 1: Reading version number of transmitter states:
transmitter version: st10_rc_app_v00.00b29_repair

I can fly the drone but some controls are extremely slow with response. The radio version had the normal set of numbers but didnt have the repair at the end as mentioned above. I attached a photo as well. Can anyone please help? Thank you in advance.
 

Attachments

  • ST10+YuneecBlade.jpg
    ST10+YuneecBlade.jpg
    1.1 MB · Views: 8
Joined
May 29, 2016
Messages
5
Reaction score
1
Age
38
I would also like to note I am the original owner and got it when it first came out or within a year or so. I have never done any type of firmware update or similar.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
2,865
Reaction score
2,205
Location
North Carolina Piedmont, USA
Has the controller always had a slow response?
If the slow response is something new, then we should talk about things like cleaning the rate slider potentiometer.
If the controls have always been slow, then maybe an update will help. V29 was not the last update. And I don't recall seeing the "Repair" caveat at all.

If you choose to update, I would recommend using the guidance in Attachment 37 (ST10+ Firmware Update) of the PDF document attached to Way To Fix Drones project. The wording in the version provided by Yuneec is ambiguous in a couple of places and has led a few folks into major headaches.
 
Joined
May 29, 2016
Messages
5
Reaction score
1
Age
38
No the controls have always worked great. I moved from Michigan to Florida 3-4 years ago. I flew it all the time and took areial pictures of friends houses properties, etc... for fun. Then I boxed it up for the move and made sure there was plenty of padding in the box. The one thing I did not do was remove the camera or the legs when I packaged it up. I've been so busy that it wasn't until yesterday I finally got around to getting my drone out and thats when I noticed a crack in the leg and the camera was broke right off the drone with 2 of the wires stripped. The box was completely undamaged. After I seen the issues with the drone I inspected every inch of that box thinking it got dropped hard but it was in great shape. I also had 3 other drone (separately wrapped) in the same box. Nothing was damaged but those 2 things. The ST10+ had no other signs of damage and I also took the casing apart to check for internal damage, corrosion, anything but it all looked brand new.

So I recalibrated the compass and accelerometer. When I go to lift off I have to raise the stick on controller a bit more then im used to but very slowly cause it will just kick right in and lift like no other. When coming down it is right on the money with no issues. Flying forward and also back is also right on the money. When I have the drone flying off the ground and not touching anything it stays flying accurately and doesnt pull in any direction. I let it sit there about 5 feet off the ground for roughly 5-10 minutes waiting to see if it would malfunction and it held up perfectly. Towards the end it started getting windy so I brought i back down.

Now here is where everything takes a turn for the worse. If the drone is off the ground just sitting there flying or if i am in movement. When I try to use the controls to simply turn it. It turns so slow. To give you and idea and I didn't time it so its just an estimate. I am guessing it would take 45-60 seconds to do 1 full rotation in either direction which is crazy. So I thought that was the worst issue and wanted to drain the full battery so i was just flying it up/down my driveway. But as soon as I would try to turn it like i previously stated is when the controls on the drone would act up. It did many different things but to give you an idea. Once I tried turning it and sat around watching paint dry...;) until it turned to where I wanted it. Up/Down didnt seem effected, but if I needed to go left it would go right instead. if i needed it to go forward it would go backwards. So to avoid collision damage I would land it, and somtimes hard landings. I could take back off without shutting it off and controls would be fine again.

I searched like a madman on that code i showed in the photo with repair at the end of it with no luck. So was hoping someone here may know how to help. Thank you for replying to my post, its greatly appreciated.
 
Joined
May 29, 2016
Messages
5
Reaction score
1
Age
38
Has the controller always had a slow response?
If the slow response is something new, then we should talk about things like cleaning the rate slider potentiometer.
If the controls have always been slow, then maybe an update will help. V29 was not the last update. And I don't recall seeing the "Repair" caveat at all.

If you choose to update, I would recommend using the guidance in Attachment 37 (ST10+ Firmware Update) of the PDF document attached to Way To Fix Drones project. The wording in the version provided by Yuneec is ambiguous in a couple of places and has led a few folks into major headaches.
I also wanted to put out there that I am no expert with drones. But growing up building RC cars & building RC helicopters from scratch for friends who couldnt afford buying a whole kit. I am very confident in my electrical work and overall knowledge of how things work I guess is the way to put it. With this being said I dont know all the correct terminology with flight direction and everything else and with the firmware update. I'm worried I would mess somthing up doing the firmware update as I've never done it. If its an easy task then thats great, if not and you recommend that and I can follow clear instructions or your advice. I will tackle it no problem. I just wanted to let you know my knowledge in these areas. I forgot to mention I did not tear down the Yuneec Blade to check electrical inside. Also I read in another forum post and I believe it was use stating to clean the terminals and so on. I have not done that either. I figured laying out the details the best as possible first before proceeding would be best as i'm sure most if not all the people on here are a lot more knowledgeable then I am. Again, thank you for your time.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
2,865
Reaction score
2,205
Location
North Carolina Piedmont, USA
I also wanted to put out there that I am no expert with drones. But growing up building RC cars & building RC helicopters from scratch for friends who couldnt afford buying a whole kit. I am very confident in my electrical work and overall knowledge of how things work I guess is the way to put it. With this being said I dont know all the correct terminology with flight direction and everything else and with the firmware update. I'm worried I would mess somthing up doing the firmware update as I've never done it. If its an easy task then thats great, if not and you recommend that and I can follow clear instructions or your advice. I will tackle it no problem. I just wanted to let you know my knowledge in these areas. I forgot to mention I did not tear down the Yuneec Blade to check electrical inside. Also I read in another forum post and I believe it was use stating to clean the terminals and so on. I have not done that either. I figured laying out the details the best as possible first before proceeding would be best as i'm sure most if not all the people on here are a lot more knowledgeable then I am. Again, thank you for your time.

"When I try to use the controls to simply turn it. It turns so slow."
This sounds like corrosion of the Pot associated with the J2 (Yaw) stick. Tap "Flight Settings" at the bottom of the screen, then "Hardware Monitor". Move all the sticks/switches around to ensure they do full travel, return to center, move smoothly, etc. If you see problems you will need to vigorously exercise the sticks to restore normal function. If that doesn't work, use plastic safe contact cleaner on the pots.

"if I needed to go left it would go right instead. if i needed it to go forward it would go backwards"
This sounds like you are in "Safe Mode" on the controller. Ensure the "S1" switch (above the right hand control stick) is in the center. This problem could also be a failure of the switch, so watch for that also when you check the Hardware Monitor.
 
  • Like
Reactions: Demario
Joined
May 29, 2016
Messages
5
Reaction score
1
Age
38
"When I try to use the controls to simply turn it. It turns so slow."
This sounds like corrosion of the Pot associated with the J2 (Yaw) stick. Tap "Flight Settings" at the bottom of the screen, then "Hardware Monitor". Move all the sticks/switches around to ensure they do full travel, return to center, move smoothly, etc. If you see problems you will need to vigorously exercise the sticks to restore normal function. If that doesn't work, use plastic safe contact cleaner on the pots.

"if I needed to go left it would go right instead. if i needed it to go forward it would go backwards"
This sounds like you are in "Safe Mode" on the controller. Ensure the "S1" switch (above the right hand control stick) is in the center. This problem could also be a failure of the switch, so watch for that also when you check the Hardware Monitor.
Thank you, I will try these options when i get home in a bit and report my findings back on here soon.
 
  • Like
Reactions: WTFDproject

New Threads

Members online

Forum statistics

Threads
19,921
Messages
230,284
Members
24,106
Latest member
Griggsrj