Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Problems with Q500 not able to bind with ST 10+

Joined
Feb 15, 2023
Messages
1
Reaction score
1
Age
52
Hi All. I am a new member from South Africa.
I got a second hand Q500 from a friend but is not able to get the copter to bind with my ST 10+ radio.
I have done all the binding steps according to the manual and threads. The copter goes into binding mode with the flashing orange LED.
When going into the bind setting on ST 10+ clicked on the white model name and it stated binding successful. at this stage nothing else happens and the orange LED just keeps flashing. I cannot find any Yuneec service AGENTS in South Africa. Please help.
 
  • Like
Reactions: Murray Martz
.......and it stated binding successful. at this stage nothing else happens and the orange LED just keeps flashing. I cannot find any Yuneec service AGENTS in South Africa. Please help.
I'm not sure from your description if you went back to the Main Screen.
It does not actually bind while you are still on the Bind Screen. You have to go back to the Main screen for it to actually bind.

Did you run the diagnostics provided in Q500 Binding Verification.pdf ?
The verification is not just "binding instructions". It is a verification of the MANY hidden clues in the binding process. The purpose is to identify abnormal conditions that are preventing a successful bind and to identify the exact point the binding process is failing. That information can assist in determining the best course to remedy the problem.
You will need to perform every step up to the point the verification does not match what you see. Do not skip any steps. Every step must be performed. Even the steps you have no doubt are already in the correct condition. After some preparation steps, the verification falls into a routine of directing an action, then verifying the correct response to the action. When you reach a verification step that does not match what you see, or if you are unsure if it matches, STOP. Report the step number back to the forum, and what you actually saw at that step. We can then go from there.
 
Last edited:
  • Like
Reactions: h-elsner
Hi All. I am a new member from South Africa.
I got a second hand Q500 from a friend but is not able to get the copter to bind with my ST 10+ radio.
I have done all the binding steps according to the manual and threads. The copter goes into binding mode with the flashing orange LED.
When going into the bind setting on ST 10+ clicked on the white model name and it stated binding successful. at this stage nothing else happens and the orange LED just keeps flashing. I cannot find any Yuneec service AGENTS in South Africa. Please help.
Very warm welcome to the Yuneec forum, also make sure the you have a GPS lock on on your (radio) controller
 

New Posts

Members online

No members online now.

Forum statistics

Threads
20,977
Messages
241,818
Members
27,362
Latest member
Jesster0430