Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Retracts

Joined
Jun 9, 2016
Messages
5
Reaction score
0
Age
49
The retracts won't go up. When I hit the switch the left one tries to move up but seems stuck....the right one dosent move.
 
Joined
Mar 2, 2016
Messages
1
Reaction score
13
Location
Texas
The retracts won't go up. When I hit the switch the left one tries to move up but seems stuck....the right one dosent move.
Mine did the same thing out of the box, and when I landed and did a slightly elevated bump on landing, they have worked flawless since ! I would maybe fire it all up without props on and hold it up in the air, while having someone hit the raise landing gear switch and give it a little help/bump. I believe the gear that raises it may just be stuck from a shipping bump around! It might save you a send back, like mine?;)
 
Joined
May 27, 2016
Messages
202
Reaction score
53
Age
39
i had the same thing happen, i posted a video on it actually, you can just see 1 leg barely moves-


all i done was take battery out, hold power button in to completely drain residual power. battery back in and started working again no problem.
 
  • Like
Reactions: DroneClone

PatR

Premium Pilot
Joined
May 1, 2016
Messages
9,857
Reaction score
5,219
Location
N. California
Another option might be to remove the gear legs and clean the electrical contacts with contact cleaner and re-seat them. Do the same for the camera gimbal while you're at it.
 
Joined
Jun 4, 2016
Messages
9
Reaction score
2
Age
55
Had an issue with mine turned it upside down retract the gear turn it rightside up gear down now it works.
 
Joined
Jan 23, 2016
Messages
127
Reaction score
49
Age
66
Just got my H back from Ontario for a gimbal issue. Did the whole bind process and full calibration. First flight up, my gear won't go up! Looking at the video from raptorheli2, that's exactly my problem.
I've removed the gimbal, turned upside down, pulled, pushed, and banged the gear...nothing is moving. So, I've already called Yuneec CS and they are sending new gear modules.

However, I NEVER had any gear issues in over 15 hours of flight time so I just can't believe the issue is actually the gear. I've heard it discussed on this thread and another to try rebinding the H. Exactly how should I go about this? Everything has been rebound, calibrated, etc. Thoughts and suggestions, please???
 
Joined
Jan 23, 2016
Messages
127
Reaction score
49
Age
66
just learned an interesting lesson...per my last message, gear would not go up. So, I did rebind the H, multiple times. Still would not work. New firmware update 11/16 successfully updated. Gear now works perfectly!

As said previously, I've never had any gear issue in over 20 hours logged until I got my bird back from Ontario. Have no idea what was done during the camera calibration issues, but it definitely screwed things up. So, just a word should you have this issue: if nothing else works, try a full firmware reinstall.
 
Joined
May 28, 2016
Messages
280
Reaction score
95
Location
Fairhope, Alabama
I had my first landing gear issue on this latest upgrade from yesturday. Flip the switch and one moved slightly and the other didnt. Turned upside down and retried no good. Turned completely off and back on nothing. Turned H off then turned ST16 off and turned all back on and now it works. Weird....
 

New Threads

Members online

Forum statistics

Threads
16,662
Messages
194,227
Members
19,332
Latest member
cbs1970