Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Update Confusion

Joined
May 23, 2016
Messages
82
Reaction score
14
Age
63
Location
Perth Western Australia
I got my Typhoon H at long last and decided to update to the latest firmware. I downloaded the file as per instructions then transferred it to the SD Card and inserted it into the CG03+ camera. Went to the update section on the ST16 when everything loaded up and pressed update. Every time I tried I got the message "update file cannot be found". I thought ok maybe I need to unzip it first so I did that and transferred it to the sd card and tried again.
No cigar, still could not find the file. Out of frustration and a little bit of experience with file formats on windows I changed the file from a ".zip" to a ".bin" file and voila it found it and updated.

My question is why is it downloading as a zip file not a bin file and how would someone with little knowledge of windows and file structures ever manage to to the update. I am using windows 10 so not sure if that was the culprit but it should have downloaded as a BIN file !!! Sorry for the long post.
 
  • Like
Reactions: GunnyE9
Joined
Dec 5, 2015
Messages
208
Reaction score
63
Age
53
Location
West Midlands, UK
Which browser? I use vivaldi and it downloaded it as an stl file which I knew was wrong, tried again in chrome and it was correct.
 
Joined
Mar 2, 2016
Messages
1
Reaction score
13
Location
Texas
Or just click on the the zip file and then select "Extract" and it will change it to a bin file, but your finding will work also !
 
  • Like
Reactions: GunnyE9
Joined
Jan 19, 2016
Messages
384
Reaction score
122
Age
58
Location
USA
I agree, if someone doesn't know it needs to be a .bin but it downloads as a .zip they may not know what to do. Fortunately, mine downloads as a bin file...
 
  • Like
Reactions: DroneClone
Joined
Mar 2, 2016
Messages
1
Reaction score
13
Location
Texas
Do yo
Unfortunately DC unzipping it did not work .. when I tried that and extracted it it became a ".zzz" file .. go figure.
U have a Zip reader installed on your PC ? it won't without one ! Try 7Zip Reader if you don't!
 
Joined
Mar 2, 2016
Messages
1
Reaction score
13
Location
Texas
Oh Well! can't explain, I have Windows 8.1 and 10 and it extracts just fine, always has from my P2,3 and H?
 
Joined
Apr 24, 2016
Messages
495
Reaction score
201
I had the same problem, it downloads with a ZIP extension.

Just rename the file, change ZIP to BIN and put on sd card and away you go.
 
Joined
May 13, 2018
Messages
35
Reaction score
1
Age
53
I have been trying to update my H and this is my exact problem. I get a BIN file on download, place it on the SD card and load it into the ST16. I get a file not found error. ST16 says to try wireless download. When I do it says files are up to date, but the file build numbers clearly show this not to be the case. My ST16 shows v03.01.b30 the download file is a v3.04.A.bin

I have not had any issues with this version, just wanted to get any possible advantage gained from the latest updates.

How do I get the ST16 to recognize the downloaded file?
 

rdonson

Premium Pilot
Joined
Jul 24, 2017
Messages
2,029
Reaction score
857
Location
Davidson, NC USA
Format the SD card in the camera using the ST16 first.

Next take the SD card to your computer and load the .bin to it.

Finally take the SD card with the .bin to the ST16
 
Joined
May 13, 2018
Messages
35
Reaction score
1
Age
53
Format the SD card in the camera using the ST16 first.

Next take the SD card to your computer and load the .bin to it.

Finally take the SD card with the .bin to the ST16
I do not seem to be able to locate where to format the card on the ST16. . .I see where to format the card in the H but not in the controller
 

PatR

Premium Pilot
Joined
May 1, 2016
Messages
10,106
Reaction score
5,457
Location
N. California
Do you have a computer? If so just format the card there and save yourself any confusion. There really is no reason to install updates or format cards in the field so do that at home where you have a computer present.

When updating, start with a clear card, have only the specific file for the camera, or aircraft, or controller being updated. Delete all card files after updating an item before adding the update file for the next item. Do not open any of the update files. The system will extract the files without your help.
 
Joined
May 13, 2018
Messages
35
Reaction score
1
Age
53
Thank you all very much. . .Update has been successful. Quick flight seemed flawless. . .
 

rdonson

Premium Pilot
Joined
Jul 24, 2017
Messages
2,029
Reaction score
857
Location
Davidson, NC USA
For the record if you go into "Photo/Video settings" on the ST16 you will see the option to "Format SD Card". Its not difficult to find.

The reason I recommended this is that you didn't mention what operating system you had on your computer or if/how you'd formatted the SD card prior to putting the .bin on it. Some people have been known to format SD cards in strange ways that won't work. Formatting in camera removes a LOT of questions and insures the SD card works.

The whole world doesn't run Windows or format everything to MBR/FAT 32.
 

New Threads

Members online

Forum statistics

Threads
17,031
Messages
198,914
Members
19,701
Latest member
mkrassovski