Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Australian support

Joined
Jan 1, 2019
Messages
1
Likes
0
Age
70
#5
Hi folks, my first post here.
Flew my Chroma on a Saturday (a few weeks ago), Sunday , turn on ST10+ controller and all the screen said was NA everything! *&$#%! and #$@%%^&.
Video is good and think I tried every thing that my pea brain could think off.....I am not very clued up with all this electronic jiggery pokey stuff.
Being an old hand at RC planes and stuff, all I can fly now are Drones coz I'm in a wheelchair.
Can land beside me see.
Re calibrated controller, connected the GUI- all seems well with the bird, still got the NA messages.

What to do now?
Thanks in advance.
I'm in Kellyville NSW.
 
Joined
May 19, 2016
Messages
532
Likes
198
Age
47
Location
Brisbane Australia
Website
www.mountainview.enterprises
#6
Hi folks, my first post here.
Flew my Chroma on a Saturday (a few weeks ago), Sunday , turn on ST10+ controller and all the screen said was NA everything! *&$#%! and #$@%%^&.
Video is good and think I tried every thing that my pea brain could think off.....I am not very clued up with all this electronic jiggery pokey stuff.
Being an old hand at RC planes and stuff, all I can fly now are Drones coz I'm in a wheelchair.
Can land beside me see.
Re calibrated controller, connected the GUI- all seems well with the bird, still got the NA messages.

What to do now?
Thanks in advance.
I'm in Kellyville NSW.
You can call me on 0410584575 and I can see if I can help
 
Joined
Oct 27, 2018
Messages
221
Likes
77
Location
North Carolina Piedmont, USA
#8
Your issue sounds like there is no 2.4 GHz communication with the Chroma. One real possibility is a bad Chroma receiver or just a corroded/bad receiver connector.

Some symptoms to look for:
NOTE: None of these wires are related to video. If no video is present, it is likely the problem is elsewhere.
Bad Gray Wire: No telemetry available on ST10+. May be able to control the drone.
Bad Yellow Wire: No flight control of drone (big problem if it fails during flight.). May have telemetry.
Bad Black OR White wire: No flight control, no telemetry. (Again, big problem if failure occurs during flight)

The first thing to try is to pull the connector apart a few times to see if it will restore the connection. This may or may not help, but it is not very difficult. The first two pictures show how to access the connector, and which connector to work with.
The drawing at the end is a little hard to follow, and isn't real important. It is included in case you need to troubleshoot.

2-Chroma Wire Guard.jpg

3-Chroma Reciever Connector.jpg

This drawing is a little hard to read, but it can show you what color wire is associated with which function, and which overall “paths” should have continuity. The wires change color at the connector, so the functions are NUMBERED at each measurable point.
1- Chroma Receiver Connections.jpg
 
Last edited:
Likes: PatR

New Threads

Forum statistics

Threads
14,264
Messages
162,566
Members
17,038
Latest member
donmcnabb2