Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Breeze keeps dropping wifi

Joined
Jan 2, 2017
Messages
4
Reaction score
0
Age
57
I've owned the breeze for about 3 weeks now and have horrible problems with it dropping wifi connection. It flies just fine inside even with my home wifi system nearby. When I take it outside, it drops the signal within a couple of minutes, even if I keep it within 30 feet of me. This happens every single time. I have tried everything I can think of. I'm using an iPhone 7plus, I removed it from its case, calibrate the drone every time, have removed watches and bracelets to prevent any kind of interference, also tried using a Samsung galaxy tablet...all to no avail. I took it down to the beach, 150+ yards away from any buildings and it still happened. Any suggestions on what might be causing this and how to fix it? I'm beyond frustrated at this point!
 
Joined
Dec 29, 2016
Messages
32
Reaction score
9
Age
40
Have you upgrade the firmware or calibrate? Try using a different device.

Sent from my LGLS675 using Tapatalk
 
Joined
Nov 16, 2016
Messages
65
Reaction score
31
Age
71
Hello dwalker22,

Same thing happens with my Moto G4 , I shipped mine back to Yuneec about 10 days ago and they acknowledged receiving it but nothing further. I had my Breeze since September and was thrilled with it, never one problem, then Yuneec came out with the FPV update and from then on my Breeze did the same exact thing as yours. Since the first FPV update there have been four additional updates. I think in their attempt to emulate the DJI Mavic they screwed up a great little camera platform. Call them and complain and let them know that you know other people are having the same problem. My next step is to make a formal complaint to Amazon where I bought the Breeze.

Old Man Photographer
 
Joined
Jan 2, 2017
Messages
4
Reaction score
0
Age
57
Hello dwalker22,

Same thing happens with my Moto G4 , I shipped mine back to Yuneec about 10 days ago and they acknowledged receiving it but nothing further. I had my Breeze since September and was thrilled with it, never one problem, then Yuneec came out with the FPV update and from then on my Breeze did the same exact thing as yours. Since the first FPV update there have been four additional updates. I think in their attempt to emulate the DJI Mavic they screwed up a great little camera platform. Call them and complain and let them know that you know other people are having the same problem. My next step is to make a formal complaint to Amazon where I bought the Breeze.

Old Man Photographer

Thanks for the input! That wasn't what I was hoping to hear but I was pretty sure I'd tried everything possible. It's odd how many seem to be working fine, but a few random ones are almost nothing more than paperweights. I'll contact Yuneec directly and see what they have to say. But I'm about ready to return the thing!
 
Joined
Dec 13, 2016
Messages
22
Reaction score
9
Age
62
Try taking the "case" off the phone.... I had a magnet in my case hampering wifi.... without the case it worked much better
 
Joined
Nov 16, 2016
Messages
65
Reaction score
31
Age
71
Hello Markfore,

If Yuneec ever decides to send it back to me I will give it a try. I don't think it will have much effect on things though since I flew the Breeze more than twenty times with that phone and case without so much as a hiccup before they added the FPV update. But thanks for responding and I will give it a try if and when I get it back. I am calling this afternoon to see if anyone can give me a status report. Will post something if I hear anything.

Old Man Photograper
 
Joined
Dec 29, 2016
Messages
32
Reaction score
9
Age
40
Hello Markfore,

If Yuneec ever decides to send it back to me I will give it a try. I don't think it will have much effect on things though since I flew the Breeze more than twenty times with that phone and case without so much as a hiccup before they added the FPV update. But thanks for responding and I will give it a try if and when I get it back. I am calling this afternoon to see if anyone can give me a status report. Will post something if I hear anything.

Old Man Photograper
What device are you using?

Sent from my LGLS675 using Tapatalk
 
Joined
Nov 16, 2016
Messages
65
Reaction score
31
Age
71
Hello jcarloacsay,
I am using a nearly brand new Motorola Moto G4 that flew my breeze flawlessly about 30 times before Yuneec added the FPV update to the APP. I just got off the phone with Yuneec and the rep told me that he was sorry for the delay but that the Christmas, New Years holidays set them back and that they also had to do inventory so they were running behind. Answers like that to a customer who sent a product back on the 16th of December and had to call to ask what is going is unacceptable. He did tell me though that the new update has caused some problems for customers so I guess I just sit here and wait to see what happens.
 
Joined
Dec 27, 2016
Messages
24
Reaction score
7
Location
Central NJ
Hello Markfore,

If Yuneec ever decides to send it back to me I will give it a try. I don't think it will have much effect on things though since I flew the Breeze more than twenty times with that phone and case without so much as a hiccup before they added the FPV update. But thanks for responding and I will give it a try if and when I get it back. I am calling this afternoon to see if anyone can give me a status report. Will post something if I hear anything.

Old Man Photograper

So I got the Breeze, did the firmware update before my first flight.
Calibrated everything, connected the wifi to my phone and tried my first flight. Didn't go as planned. Took off to the predetermined height and hovered. Made a few turns and increased the altitude to maybe 20 feet. Wifi disconnected and it flew right into a window, breaking 2 prop guards. Sent an email to them to see about getting a replacement set of guards. Have not heard back.
Fast forward to today. We are having a roof replaced and decided it would be a great time to fly again. Connected to wifi and normal and did a great flight outside for about 10 minutes. Responded as it should through the entire flight.
Brought it back down to swap the battery, reconnected wifi and did a takeoff. Within 10 seconds, it lost wifi and crashed into the house, this time breaking the props and popping off the cover on the belly and losing one of the lenses that covers the sensor.
So now I have a broken drone. Wrote again to Yuneec to see what the deal is. This wifi issue is not good.
I will update once I get a reply. Also plan to call today as well.
 

New Threads

Members online

Forum statistics

Threads
18,954
Messages
220,436
Members
22,111
Latest member
lili11