Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

CGO3+ 4K lens trim

Joined
Mar 4, 2019
Messages
295
Reaction score
124
Age
52
I have a question for someone who may own both CGO3 model cameras.
I am putting back together a CGO3+ that I purchased from a guy that had taken it apart to replace the lens. In the process of putting everything back together, I noticed that my trim around the lens is not lining up with the front cover. The opening is not lining up with the lens but does fit the front cover. I am thinking the lens opening on the trim piece is different on the two.

My question is, are the CGO3 and CGO3+ trim pieces around the lens the same on both cameras?
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
2,759
Reaction score
2,107
Location
North Carolina Piedmont, USA
The problem you describe can be caused by the WiFi antenna not in the right place. Be sure one arm is secured in the deep notch in the crossbar just below the lens. There is also a notch in the antenna opening near the lower right of the front camera cover opening that is there to provide a little extra clearance for the antenna arm that lays near it.
There were a couple different size WiFi antennas used on the CGo3 and CGo3+. The larger size can be a bear to get everything lined up and in place.
Also note; While the nose pieces were pretty much the same, the front half of the camera covers were not. Some had the notches, some did not.
 
  • Like
Reactions: Yuneec Skins

Yuneec Skins

The Yuneec Parts Guy
Approved Vendor
Premium Pilot
Joined
Jan 4, 2019
Messages
330
Reaction score
448
Location
Citrus Heights, CA
Website
yuneecskins.com
I have run into this Problem before it was due to the Camera being crashed and damage to the white mounting plastic plate, and yes as stated above they are the same Part for both CGO3 & CGO3+ Cameras, if you find out it is the White Plastic Mount, I will give you that piece NC and ship it to you for free if your in the lower 48...;)
 
Joined
Mar 4, 2019
Messages
295
Reaction score
124
Age
52
The problem you describe can be caused by the WiFi antenna not in the right place. Be sure one arm is secured in the deep notch in the crossbar just below the lens. There is also a notch in the antenna opening near the lower right of the front camera cover opening that is there to provide a little extra clearance for the antenna arm that lays near it.
There were a couple different size WiFi antennas used on the CGo3 and CGo3+. The larger size can be a bear to get everything lined up and in place.
Also note; While the nose pieces were pretty much the same, the front half of the camera covers were not. Some had the notches, some did not.
I actually removed the stock antenna and am using an external.
 
Joined
Mar 4, 2019
Messages
295
Reaction score
124
Age
52
Thanks everyone for the quick replies. I guess its time to taker her back apart and find the problem.
 

New Threads

Forum statistics

Threads
19,770
Messages
228,866
Members
23,731
Latest member
chelsea144