Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Failure to take-off

Joined
Jul 5, 2021
Messages
5
Reaction score
0
Age
37
Good morning all, my last post I could not get my ST16 (3 antenna) Screen to come on. Must be something internal, battery is 100% charged. However now after binding to new to me ST16 (2 antenna) I have a failure to take-off. I have calibrated everything twice, made new profile on the ST16, and all it will do is trun the props on, acting like the throttle is disconnected and constantly beeps, green and purple light flashing. However the left stick registers when in the hardware monitor menu. Any help would be greatly appreciated
Thanks
Matt
 

Attachments

  • 20220609_081048.jpg
    20220609_081048.jpg
    1.1 MB · Views: 14

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,291
Reaction score
4,771
Location
Bessemer, MI
If it's beeping constantly it's most likely the right stick. If it doesn't return to exactly zero then it won't launch. Check the right stick in Hardware Monitor. Make certain it doesn't look sluggish or erratic. If it does then it will need cleaned.

One of your preflight steps should include rapidly stirring the sticks to help keep them clean.

 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,336
Reaction score
2,594
Location
North Carolina Piedmont, USA
,,, all it will do is trun the props on, acting like the throttle is disconnected..
The Hardware Monitor does not always tell the full story. Please turn on the "Final Output Display" and verify the first channel (CH01) moves when you move the left stick up and down.

The Display is turned on by doing a rapid double tap of the volts Icon:
Final Output Display.jpg
 
Joined
Jul 5, 2021
Messages
5
Reaction score
0
Age
37
Here are the pictures
 

Attachments

  • 16556757242763994343686519662379.jpg
    16556757242763994343686519662379.jpg
    1 MB · Views: 6
  • 16556758275391441696874341387570.jpg
    16556758275391441696874341387570.jpg
    2.3 MB · Views: 6

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
3,336
Reaction score
2,594
Location
North Carolina Piedmont, USA
First, try to exercise the stick and spray contact cleaner on the pot. Calibration is a risky thing if the pot has corrosion built up on it.

When the stick is as clean as you can get it, the best two calibration videos are on this page:
 
Joined
Jul 12, 2021
Messages
10
Reaction score
7
Age
46
Location
Poznan / Poland
Small hint from me: sometimes you need to improve solder joints of the steering stick. Yuneec had some problems with oxidizable solder joints (I hope yopu understand - English is not my native language :) ) - and in about 70% cases this operation helps. If not - you need to clean or replace steering stick.
 

New Threads

Members online

No members online now.

Forum statistics

Threads
20,431
Messages
236,440
Members
25,615
Latest member
quynh2306