Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Had my first flight!!! I have questions.

Joined
May 13, 2016
Messages
187
Reaction score
33
Age
46
I probably broke a thousand rules but I tried to remember as much as I could from here. I ran the battery down to 14.7 just because I couldn't remember the right number and didn't want to go too far.

Should I charge up the battery fully if I'm not going to fly until tomorrow?

I couldnt get the photo option to work during video. Also, does the Take Off button not work in Angle mode? It was red the whole time.

She handled beautifully. I got some stuttering in the video where it looked like the gimbal was jiggling but that could have been me fiddling with the knobs. Adjusting the tilt and rotation will take getting some used to.

Sorry if this is rambling but I'm just pumped up from the flight! I now totally get why you guys do this!!
 
  • Like
Reactions: Old Jar Head
Joined
Jun 3, 2016
Messages
35
Reaction score
13
Age
66
You'll get different answers, but here's mine:

1. I go down to 14.3 when I get the first warning, and then land. If I'm any distance away, I'll start returning around 14.4-14.5

2. I leave my batteries fully charged for over a few weeks and never had a problem.

3. The Take Off button does not change color; it's always red. If it doesn't work, you don't have enough satellites.

Have fun flying!
 
  • Like
Reactions: NoCoOutdoorGuys
Joined
May 13, 2016
Messages
187
Reaction score
33
Age
46
You'll get different answers, but here's mine:

1. I go down to 14.3 when I get the first warning, and then land. If I'm any distance away, I'll start returning around 14.4-14.5

2. I leave my batteries fully charged for over a few weeks and never had a problem.

3. The Take Off button does not change color; it's always red. If it doesn't work, you don't have enough satellites.

Have fun flying!
Thanks Allan!

When I tried the take off mode the first time it said I was too close. Then I tried it after I had landed and it said something to the effect of the aircraft was not in a ready state. I had not used the red button to shut of the props. I land by holding the left stick down until the props slowed.

Any idea on the camera not taking stills?
 
Joined
Mar 2, 2016
Messages
1
Reaction score
13
Location
Texas
Thanks Allan!

When I tried the take off mode the first time it said I was too close. Then I tried it after I had landed and it said something to the effect of the aircraft was not in a ready state. I had not used the red button to shut of the props. I land by holding the left stick down until the props slowed.

Any idea on the camera not taking stills?
It is a known issue with many H owners ! I can get mine to work 50% of the time, but haven't really played with her to see if I am doing it right, since Yuneec has such a wonderful manual that explains everything so well ! LOL ! Sorry for the last line of Bull S+*T ;)
 
  • Like
Reactions: NoCoOutdoorGuys
Joined
Jun 3, 2016
Messages
35
Reaction score
13
Age
66
Thanks Allan!

When I tried the take off mode the first time it said I was too close. Then I tried it after I had landed and it said something to the effect of the aircraft was not in a ready state. I had not used the red button to shut of the props. I land by holding the left stick down until the props slowed.

Any idea on the camera not taking stills?
If it said you were too close you were in Smart Mode. I land by holding the left stick down until the motors "idle", about 3 seconds after landing. Then you can safely let the throttle go back to the center position and press the red Start/Stop button.

There have been reported problems of the still and video buttons being tricky to the touch. I know I have to tap mine quickly; if I end up holding it down nothing happens. Try a few different touches to see if that helps. I also heard a firmware update may help. Keep in mind the photo resolution while in video mode will be the same resolution as the setting for the video. So if you are filming 1920x1080, your photo will be 1920x1080.
 
  • Like
Reactions: NoCoOutdoorGuys
Joined
May 13, 2016
Messages
187
Reaction score
33
Age
46
Definitely not in Smart Mode. I avoided that like the plague. I checked my mode every time I moved my right hand and twice if I flipped a nearby switch!

Ok, so I'll play with photos a bit more. It worked with a normal push when in just photo mode when I had it sitting on the table.
 
Joined
Apr 10, 2016
Messages
43
Reaction score
7
Location
Victoria, Texas
I am going to commit heresy on this forum and say there is a place for smart mode. If at a distance you have totally lost your orientation and you don't understand the green arrow on screen in angle mode then switch into smart mode and pull the right stick back. Also, if trying to start a video or take a photo tap the buttons don't hold them down. This is different from the Q500 where the you could push the buttons down and they would then do there thing.
 
  • Like
Reactions: NoCoOutdoorGuys
Joined
May 1, 2016
Messages
96
Reaction score
35
Age
53
Had my first flight today, too. I brought her home in Safe mode till she got about 100 feet out the switched to Angle. As strange as it may sound I felt more comfortable bringing her home myself. Will have to try RTH sometime soon.
 
Joined
May 25, 2016
Messages
157
Reaction score
41
I just had a flight and she was a beauty. It was hovering aprox 15 meters above me literally with no movement and it's was windy. I've done compass calibration prior the flight and 17 satellites probably helped. The only thing scared sh*** of me was RHM. She took off from maybe 100m away from me at my direction very aggressively:) and was almost above me when I switched it back to angle (didn't want to find out her true intentions).

I am having Camera Failed initialise message very often. I tried to remove/reconnect gimbal and then bind. What is the correct procedure for unbind/bind?
It never asked me for the password when I was binding the camera, must be doing something wrong. However, event after 'failed initialise' message camera works.
 
Joined
Mar 18, 2016
Messages
430
Reaction score
104
Age
66
Location
london UK
I am going to commit heresy on this forum and say there is a place for smart mode. If at a distance you have totally lost your orientation and you don't understand the green arrow on screen in angle mode then switch into smart mode and pull the right stick back. Also, if trying to start a video or take a photo tap the buttons don't hold them down. This is different from the Q500 where the you could push the buttons down and they would then do there thing.
When I first got my H I could not get it to record at all. Took it back to Yuneec UK they tried it and it worked perfectly. Took it back home tried it there and no go. Experimented with different lengths of pushes and go it to go in to record in the end. Now after some 8 flights the video button for record works all the time. I do not take stills but I suppose that would work as well. Perhaps it is no more than a sticky hardware switch?
 
Joined
Apr 20, 2016
Messages
266
Reaction score
76
Location
Gateway to Cape Cod
Picked up my 'H' last night from my local hobby shop. Yay!
After the crowd in the shop watched me unbox it and the shop owner and I tried to get the bird to synch with the transmitter in his shop with little luck I decided to take it outside and do the dance.
Compass calibration complete, battery at 3 out of 4 bars and 14.7v I started the motors. Took her up to some where around 8 - 9 feet and hovered for a few minutes. Landed her then took off again for another hover, received the low battery buzz and landed her and shut her down.

I could not seem to get the camera to swivel around. Does the landing gear need to be in the up position for the camera to swivel?

Everything went well for the maiden flight.
 
Joined
Mar 18, 2016
Messages
430
Reaction score
104
Age
66
Location
london UK
Picked up my 'H' last night from my local hobby shop. Yay!
After the crowd in the shop watched me unbox it and the shop owner and I tried to get the bird to synch with the transmitter in his shop with little luck I decided to take it outside and do the dance.
Compass calibration complete, battery at 3 out of 4 bars and 14.7v I started the motors. Took her up to some where around 8 - 9 feet and hovered for a few minutes. Landed her then took off again for another hover, received the low battery buzz and landed her and shut her down.

I could not seem to get the camera to swivel around. Does the landing gear need to be in the up position for the camera to swivel?

Everything went well for the maiden flight.
Pan Mode switch right down to bottom position .Knob to the right will turn the camera
No.
 
Joined
May 7, 2016
Messages
1,140
Reaction score
358
Age
72
Location
Gurdon, Ar
It is soooo Good to hear you guys are getting yor TH's. Life can be great.
 

New Threads

Forum statistics

Threads
16,833
Messages
196,543
Members
19,529
Latest member
[email protected]