Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

J2 and J3 mixture

Joined
Nov 5, 2016
Messages
6
Likes
0
Age
47
#3
Hello, i have the same problem :Transmitter in mode 2, when I try to turn left moves forward, when I try to turn right moves backward, not stable need help !!!!!I reset the station and J3 don´t calibrate
 
Joined
Nov 5, 2016
Messages
6
Likes
0
Age
47
#9
I've done the reset does not work, writing from Spain and is very difficult to call and get along with them because my English is very bad.
I have written an email
 
Joined
Jun 15, 2016
Messages
72
Likes
10
Age
56
Location
Belgium
#10
Are you quite sure you don't move the stick on the other axe?
To be sure, don't hold the stick with your finger; just puch it gently with a pencil or something.
 
Joined
Jun 15, 2016
Messages
72
Likes
10
Age
56
Location
Belgium
#12
Yes, the left stick only. But it is quite easy to move it up and down and (if you don't care) in the same time to move it left and/or right just a little bit.
And doing that you get the problem you show.
 
Joined
Nov 5, 2016
Messages
6
Likes
0
Age
47
#13
Yes, the left stick only. But it is quite easy to move it up and down and (if you don't care) in the same time to move it left and/or right just a little bit.
And doing that you get the problem you show.
I only move the left stick (mode 2) when I try to turn left moves forward, when I try to turn right moves backward, without touching anything right stick, seems that both are mixed ......
When i touch right stick it does not happen
 
Joined
Aug 25, 2017
Messages
29
Likes
7
Age
52
#14
Did anybody ever come up with a fix to this, aside from calling Yuneek customer support?

I am having the exact same issue.




I am NOT moving the right stick...not even touching it. Push J2 over, and J3 will slowly start to move on it's own.

 
Last edited:
Joined
Apr 15, 2017
Messages
39
Likes
3
Age
55
Location
Lake Lure, NC
#15
Have you checked Channel Settings to make sure that they did not become linked?
 
Joined
Apr 15, 2017
Messages
39
Likes
3
Age
55
Location
Lake Lure, NC
#17
Have you done a recent software update? Some have reported an issue after update. In flight failure

I had a problem after missing a step while testing "Broken Line Rate Curve" sittings.
 
Joined
Aug 25, 2017
Messages
29
Likes
7
Age
52
#18
Well.......I founda fix on the forum that worked.....it might not be the #1 way to do things as it may have the side effect of washing dirt into other places.....but I was able to clean the gimbals out from the front with CRC QD Electrical Cleaner. Sprayed a bit around each stick, worked them around real well for a couple of minutes, and then did a ST16 calibration. Everything appears to be working fine.
 
Likes: Bob520
Joined
Oct 12, 2017
Messages
4
Likes
0
Age
69
#20
I am having a problem on my typhoon h. When i want to yaw to the left it moves forward instead. If i yaw to the right, it works ok. The only way i can yaw to the left is hold the stick to the left and it turns as you fly forward. I need help with this problem.It has been completed updated and calibrated.
 

New Threads

Forum statistics

Threads
12,479
Messages
141,893
Members
15,071
Latest member
dmoorewv