Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

New DataPilot update 1/17/2020

Joined
Sep 5, 2018
Messages
41
Reaction score
18
Age
68
Location
Matthews, North Carolina
I flew a 2 battery survey yesterday afternoon on the new software/firmware with an E90. No interruption or freezes of DataPilot. I did have a "loss of remote control" warning, but I had all telemetry and control when landing. The screen showed the survey pattern and picture dots throughout. I did an RTL at 27% and resumed after the battery change without difficulty. I will try another survey in the next 1-2 days if the weather cooperates. Thus far seems to be a much needed improvement.
 

Hurricane1402

HURRICANE1402
Joined
Apr 7, 2019
Messages
6
Reaction score
7
Age
34
Location
HOUSTON, TX
I updated and no problems. flew manually then did 2 surveys. in total 3 battery swaps alot of video and too many still shots but everything flew smoothly
 
  • Like
Reactions: Steve Carr and MrEd
Joined
May 19, 2017
Messages
577
Reaction score
339
Age
67
Location
France
Je pense qu'il parle du couple Firmware 1.6.53 et Datapilot 1.5.12.25 du 22/08/2020.
Corrigez sinon.
 
Last edited:
Joined
Nov 28, 2019
Messages
209
Reaction score
107
Age
45
Location
Austin, Texas
Joined
Nov 28, 2019
Messages
209
Reaction score
107
Age
45
Location
Austin, Texas
Good and bad on 1.6.57 DP firmware.
  • Noticed a new message while everything was starting up notifying that the drone did not have a GPS lock.
  • Pre-existing condition still exists. Settings are set to miles per hour and reported speed on flight UI is feet per second.
  • Prior condition of battery percentage not being reported correctly seems to be resolved. I was having an issue where the reporting at the beginning of the flight was a very low percentage and after a couple of runs I noticed that the percentage was counting up as I continue to fly. Missions were completing normally and about halfway through the flight the battery was reporting correctly and then counting back down.
  • Abnormally slow flight speed after the Mission completed. I was limited to 6 ft./s even though I had the speed control all the way up and verified that my calibration was correct. Initiating return to home went to full speed.
  • Abnormally slow flight speed during a video capture. Limited to 14 ft./s.
  • Pre-existing condition of less distance from home before video lags.
  • Prior condition of reported “no RC” seems to have been fixed.

All this will be reported to the beta team as well.
 
Joined
Oct 30, 2016
Messages
624
Reaction score
162
Age
43
also noted that the controller just got the update not the h520 craft itself. when the newer hi res thermal camera came out both aircraft and controller got updated for it. h520 airframe is due for a update
 
  • Like
Reactions: chascoadmin
Joined
Nov 28, 2019
Messages
209
Reaction score
107
Age
45
Location
Austin, Texas
also noted that the controller just got the update not the h520 craft itself. when the newer hi res thermal camera came out both aircraft and controller got updated for it. h520 airframe is due for a update
What do you think needs to be updated? As far as I can tell nothing hardware-wise has changed in about a year, but I do have my list of "I wish it flew this way or that worked that way(s)".
 
Joined
Oct 30, 2016
Messages
624
Reaction score
162
Age
43
about each time a new payload comes out both controller software and uav software is updated. so far need to be tested the new zoom cam need to be tried to be used without the controller on a preset mission.
 
Joined
Sep 5, 2018
Messages
41
Reaction score
18
Age
68
Location
Matthews, North Carolina
I did the January 30 Datapilot update (1.6.57). The e90 camera and gimbal remained the same. The zoom video/photo on the ST16s controller works fine. I don't have any of the other cameras. Nor have I flown a survey mission yet (although it worked well on 1.6.53 except for the "loss of RC" which did not have any apparent effect.,
 
  • Like
Reactions: Paw

Paw

Joined
Jul 11, 2018
Messages
119
Reaction score
27
Location
Poland
I did the January 30 Datapilot update (1.6.57). The e90 camera and gimbal remained the same. The zoom video/photo on the ST16s controller works fine. I don't have any of the other cameras. Nor have I flown a survey mission yet (although it worked well on 1.6.53 except for the "loss of RC" which did not have any apparent effect.,
Ihad installed all updates yesterday and flew this morning. Everything seemed to work well. Yet I did not fly any surveys, ROI and waypoint missions. Pure manual flights only.
 
  • Like
Reactions: chascoadmin

Paw

Joined
Jul 11, 2018
Messages
119
Reaction score
27
Location
Poland
Flew my 1st survey mission today after the update to 1.6.57.0 earlier today. The mission required 2 batteries what I did on purpose in order to check DataPilot and battery swap procedure at once.

Both things did well. There was no DataPilot crash, screen freezing or nothing. Good job Yuneec! Hope this persists.
Battery swap went well yet strange thing was that the camera (e90) started to take pictures on the second fly right after h520 took off and continued through the end of the mission. I mean that it was taking them while taxing to the first waypoint being the last from the first battery part of the mission. Other thing was that it actually started the "second" mission from the start of the leg on which there was the point where the "first" mission had been terminated rather than from the point the "first" mission ended.

regards,
Pawel
 
Joined
Nov 28, 2019
Messages
209
Reaction score
107
Age
45
Location
Austin, Texas
Flew my 1st survey mission today after the update to 1.6.57.0 earlier today. The mission required 2 batteries what I did on purpose in order to check DataPilot and battery swap procedure at once.

Both things did well. There was no DataPilot crash, screen freezing or nothing. Good job Yuneec! Hope this persists.
Battery swap went well yet strange thing was that the camera (e90) started to take pictures on the second fly right after h520 took off and continued through the end of the mission. I mean that it was taking them while taxing to the first waypoint being the last from the first battery part of the mission. Other thing was that it actually started the "second" mission from the start of the leg on which there was the point where the "first" mission had been terminated rather than from the point the "first" mission ended.

regards,
Pawel
This is all behaviour that has existed for at least a year so if it is just now showing up then the firmwares we were testing is starting to show up.

Did the aircraft climb to full altitude before commencing to the 2nd battery start point?
 

Paw

Joined
Jul 11, 2018
Messages
119
Reaction score
27
Location
Poland
This is all behaviour that has existed for at least a year so if it is just now showing up then the firmwares we were testing is starting to show up.

Did the aircraft climb to full altitude before commencing to the 2nd battery start point?
Yes it did fly to the set alt. before starting to the first waypoint of the second battery.

Cannot tell it now for sure but have a feeling that it wast starting to take pictures only after reaching first waypoint of the 2. battery before last update. Not sure though.
 
  • Like
Reactions: chascoadmin
Joined
Nov 28, 2019
Messages
209
Reaction score
107
Age
45
Location
Austin, Texas
In a previous beta firmware there was a condition where the drone tried to go directly from home to the restart waypoint meaning from zero to 200ft or whatever your setting was and took pictures the whole way. I wanted to make sure this hadn't crept into public release!
 
Joined
Nov 28, 2019
Messages
209
Reaction score
107
Age
45
Location
Austin, Texas
Good evening from Texas! How's everyone doing with UpdatePilot 1.6.7 and DataPilot 1.6.57?

We've having good success and I will correct my last report that the odd speed inconsistencies seem to be due to the common pitch stick problem. I moved to my backup RC and haven't had that issue recently.
 
Last edited:
  • Like
Reactions: NorWiscPilot

New Threads

Members online

No members online now.

Forum statistics

Threads
18,142
Messages
212,574
Members
21,039
Latest member
rconiv