Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Post Crash Update - Question

Joined
Jan 22, 2017
Messages
3
Reaction score
1
Age
53
Had a crash in February, sent to Yuneec's repair center in NY. Received it back after several components were fixed. Fantastic customer service. However, upon flying it again for the first time this week, the landing gear did not retract. Repair included motherboard, 1 or 2 rotor motors. They said they tested and confirmed all systems working - I expect they did not try to retract landing gear. It seems one of the landing gear attempts to move - then stops after several mils, the other does not move. Is this potentially just a configuration setting that needs to be reset? Anyone else had a similar issue?
 
  • Like
Reactions: spongella

Steve Carr

Missed Approach
Staff member
Premium Pilot
Joined
Dec 15, 2015
Messages
8,146
Reaction score
4,612
Location
Bessemer, MI
Had a crash in February, sent to Yuneec's repair center in NY. Received it back after several components were fixed. Fantastic customer service. However, upon flying it again for the first time this week, the landing gear did not retract. Repair included motherboard, 1 or 2 rotor motors. They said they tested and confirmed all systems working - I expect they did not try to retract landing gear. It seems one of the landing gear attempts to move - then stops after several mils, the other does not move. Is this potentially just a configuration setting that needs to be reset? Anyone else had a similar issue?
Remove the props, turn it up-side-down and try it again. You can do this in the house. Cycle it a few times to see the the gear is stuck or if one of the motors isn't working.
 
Joined
Jun 9, 2016
Messages
215
Reaction score
102
Age
59
Had a crash in February, sent to Yuneec's repair center in NY. Received it back after several components were fixed. Fantastic customer service. However, upon flying it again for the first time this week, the landing gear did not retract. Repair included motherboard, 1 or 2 rotor motors. They said they tested and confirmed all systems working - I expect they did not try to retract landing gear. It seems one of the landing gear attempts to move - then stops after several mils, the other does not move. Is this potentially just a configuration setting that needs to be reset? Anyone else had a similar issue?

Several of us have had a similar issue after updating, I believe there was a firmware bug. I just received my H back from Yuneec and I was having the same retract issue, they tested it and said all is good.

No big deal for me I just had to cycle the retract switch multiple times to get the gear down, more of an annoyance.
 
Joined
Aug 1, 2016
Messages
1,033
Reaction score
386
Location
Auburn, WA, USA
I had the same issue after update. As others have noted, after attempting to cycle the gear several times, it finally worked properly. No problems since. Hope this helps.
 

New Threads

Members online

Forum statistics

Threads
19,951
Messages
230,783
Members
24,206
Latest member
SLD2387