Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Rubber bushings on CGO3+ camera mount

Joined
Mar 2, 2019
Messages
17
Reaction score
1
Age
45
I noticed the other day that it looked like one of the rubber bushings on my camera had pipped out of socket. So I took the camera off of my H and saw there are 2 plastic retainers on 2 of them. Thought I was missing 2 until I looked the parts up. Am I missing something here?? Or is this the normal mount on this camera?? It seems like 2 of them are just kinda floating.1557867669204.jpeg1557867707125.jpeg
 
Joined
Oct 2, 2018
Messages
886
Reaction score
243
Age
53
Location
Uk
Only two per mount. That's normal. Some use dental floss etc to give it a bit more security.
 
Joined
Mar 2, 2019
Messages
17
Reaction score
1
Age
45
Only two per mount. That's normal. Some use dental floss etc to give it a bit more security.
Ok thanks. I am pulling the bushing up through the holes on the ones without the retainers. Seems like they would have put 4 on instead of 2.
 
Joined
Oct 2, 2018
Messages
886
Reaction score
243
Age
53
Location
Uk
Ok thanks. I am pulling the bushing up through the holes on the ones without the retainers. Seems like they would have put 4 on instead of 2.
It can't be too fixed, needs to be able to absorb vibration etc.
 
Joined
Mar 2, 2019
Messages
17
Reaction score
1
Age
45
In the pictures, two of the dampers are pulled out of the mount holes. Is that what you are asking about? If so, then, no, that is not normal. Stuff them back in. Lots of ways to do it, read some posts, but if you pinch them and get them started, you can use your fingernail to finish pushing them in.
Yeah I stuffed them back through. It was pretty easy, used a toothpick. I was really kinda wondering why they only used 2 of the plastic retainers and not 4 of them. But my question was answered. Thank you
 
Joined
Nov 30, 2018
Messages
24
Reaction score
3
Age
57
I noticed the other day that it looked like one of the rubber bushings on my camera had pipped out of socket. So I took the camera off of my H and saw there are 2 plastic retainers on 2 of them. Thought I was missing 2 until I looked the parts up. Am I missing something here?? Or is this the normal mount on this camera?? It seems like 2 of them are just kinda floating.View attachment 16572View attachment 16573
I thought exactly the same too, until I did a bit of research. It's an odd looking set up, but understandable when you think about it.
 
  • Like
Reactions: deforestdiamond

New Threads

Members online

Forum statistics

Threads
15,660
Messages
182,402
Members
18,290
Latest member
i7wjrng4