Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Typhoon H Altimeter incorrect

Joined
Jun 20, 2021
Messages
1
Reaction score
0
Age
25
After I turn on my ST16 and my Typhoon H, the altimeter goes into the negative numbers. The longer it sits, the more into the negatives it goes. The most I've seen is -60. I think this is posing a problem for landing because after I take off, I have to hold the joystick down for an extended period of time just to get a very minimal descent rate. I've already done all the recalibrations and rebinded the camera and drone.

Any help is appreciated.
 
Joined
Mar 31, 2020
Messages
71
Reaction score
91
Location
Etex
Unsettling, huh. The device is basically a barometer, so if the atmospheric pressure happens to be changing, the device is simply tracking the change. It should reset to zero at each drone startup.
 

WTFDproject

Moderator
Staff member
Premium Pilot
Joined
Oct 27, 2018
Messages
2,753
Reaction score
2,102
Location
North Carolina Piedmont, USA
I think this is posing a problem for landing because after I take off, I have to hold the joystick down for an extended period of time just to get a very minimal descent rate. I've already done all the recalibrations....
The altimeter would not be my first thought for the landing issue. Have you checked "Hardware Monitor" to see if the throttle stick (J1) is responding normally? More importantly, did you check the Final Output display (double tap the ST16 battery "Volts" icon) to ensure the actual signal going out (CH01) matches the stick position?

Kind of a "biggie". Which recalibrations did you perform?

Some related threads:
 
  • Like
Reactions: Steve Carr

h-elsner

Premium Pilot
Joined
Mar 23, 2016
Messages
1,320
Reaction score
962
Location
Bavaria / Germany
Please check with GUI what value the baro sends and what is the outcome on altitude value from telemetry on the RC.
If the pressure sensor remains at ~0m (Height Estimate) and the altitude on ST16 is starting with 0 and goes down to a negative value then this is probably a problem with the IMU (which is not good).
Try an accelerometer calibration and compare values after that.

br HE
 

DoomMeister

Moderator/Tech Junkie
Staff member
Premium Pilot
Joined
Dec 25, 2017
Messages
6,412
Reaction score
3,694
Location
Genesee, MI USA
Joined
Oct 28, 2017
Messages
88
Reaction score
66
Age
61
My altimeter is all over the place also.
This should not be a problem when landing. Make sure to have the right slider in rabbit mode. (All the way up) That is what my landing problem was. In gusty winds I am hand catching with my finger on the red button. Yesterday was very windy and I hand caught all three landings.
 

New Threads

Members online

Forum statistics

Threads
19,760
Messages
228,775
Members
23,705
Latest member
Percevil