Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Typhoon H flipping over at take-off

Joined
Feb 24, 2017
Messages
36
Reaction score
8
Age
41
I will attach the Remote files shortly too..

Also, thanks to Haydn for listening to my ranting and raving on the phone.. I have a few things to try also.
 
Joined
Feb 24, 2017
Messages
36
Reaction score
8
Age
41
Here they are. Thanks for taking the time to have a look..

Now that you mention it, in the last 'flight' there was a very noticeable delay between WiFi commands, and it was also causing 'Flight Control' to crash a few times.. a bit scary when the drone is sitting in the air..
 

Attachments

  • Archive.zip
    13.1 KB · Views: 4
Joined
Jan 13, 2018
Messages
42
Reaction score
5
Age
64
First, the current issue.. then, a little backstory.

My current Typhoon H is 'refurbished' unit from an authorised repair centre as my original Typhoon H had issues, and they refused to repair it under warranty. Since getting this refurbished unit, I've had nothing but issues.. the first few flights went ok, but since then, more often than not, the H has been flipping over on take-off, using tearing the camera/gimbal off its mount or (on the last flight) breaking props.

Since this had happened a few times, I was very suspect of this particular H and started recording take-offs using my mobile phone. The other day, it happened again, and I got it on video! I will upload that video when possible.. its on my friends phone.

I've seen posts on here of people having issues with the H flipping on landing, but my case is on take-off. What happens is, I power on the drone, check for any messages/warnings, then 'prime' the motors and let it idle for around 30 seconds, checking for any odd noises or vibration/movements. Then, when everything is ok, I hold UP on the left stick to take off. More often than not, it simply rolls over (usually to the front) instead of launching into the air. When this happens, the front part of the landing gear never even gets off the ground. It simply rolls over.

So, here is a little backstory of my history with Yuneec and their products.

1) Purchased a Q500 4K - enjoyed it immensely. Kept up to date with firmware updates etc.
2) One day, while setting up to take some video for a job, I went to launch the Q500 4K.. it got a couple of meters in the air, then came crashing to the ground with "Motor error - Enter five-rotor mode!" on the ST10 display.. a bit odd, since the Q500 is a quad rotor..
3) Tried to call the place I purchased the drone from (around 8 moths earlier) to find they were out of business.
4) Tried to contact Yuneec to find what my options were in regards to warranty - no response from any emails I sent.
5) The Q500 sat in its box, broken, for several months.
6) Eventually, I went out and purchased a Typhoon H as a replacement, vowing that I never wanted to have my drone fall from the sky again due to a single motor issue.
7) All was well for around 10 months, then the ST16 kept going flat.. I'd charge the controller overnight (sometimes taking up to 6-8hrs to charge) put it in my flight case in the morning, drive to a job to find its down to 30% or so.
8) After a while, the ST16 started to take 12+ hours to charge, then eventually wouldn't charge at all.
9) I purchased a new battery for the ST16 assuming this was the issue.. new battery arrived, same problem.
10) I decided to look for any authorised repair centre in Australia again.. FOUND ONE! I was so happy that I'd be able to get my Typhoon H repaired under warranty!
11) Took my Typhoon H and Q500 4K into the service centre. They said the Typhoon H would be no issue - it was a known fault, and after I explained my Q500 4K issues (and lack of service centre) they said they can probably get that pushed through under warranty too -- HAPPY DAYS!
12) Months passed. No updates from the repairer. Each time I called, I told it was 'in process' or 'waiting on parts' or some other excuse.
13) Eventually, after pushing, and informing them that my drone is a tool for work, they basically admitted that neither will be repaired under warranty.
14) They did offer to fix my H at a 'reduced price' and I agreed.
15) Each time I called about it, it wasn't ready. I stressed that I needed it for work, and I was losing money by not having it. I was told it would be done by Friday afternoon.
16) I catch a 1hr vehicle barge (I live on an island) and drive another 50 minutes to the service centre, to find out its not repaired. I am them told it will certainly be done by Monday.
17) I call Monday morning to confirm, and they assure me it will be ready. I get there. Guess what? Not ready.
18) I lose my cool, and have a bit of a go at them.. each barge trip is costing me $100, plus 50 minute drive, for nothing..
19) They offer me a refurbished unit in replacement of my H. I accepted. Still no update, quote, or anything on my Q500 4K.
20) I use this refurbished drone on its first job.. on the 4th take-off, it flips over and tears the camera off
21) I contact the service centre (by email, it was out of business hours) and explain what has happened.
22) I get no response, and I call up a few days later. They ask me to pay $1200 for the refurbished unit. I stressed I am NOT paying $1200 for a refurbished unit that was given to me because they had not fixed either of my other drones in around 3-4 months they have had them. Especially not a refurbished drone that flips/crashes randomly on take-off.
23) I have emailed on multiple occasions for updates etc, and had no response. I did get a voicemail message on my phone once that they are reporting me to the police for 'stealing' a drone. THEY STILL HAVE 2 OF MINE THEY HAVENT FIXED!
24) Current result. Repairer has 2 broken Yuneec drones of mine. I have 1 broken refurbished unit that randomly flips/crashes on take-off. Repairer does not answer emails, and I would refuse to work with them at all, due to them not fixing my first 2 drones, and claiming I 'stole' this refurbished unit.


Anyone know how I can stop this refurbished one flipping over? Anyone know of any decent Yuneec service centres in Australia? Or how about some sort of contact email/phone for a decent Yuneec customer service line in another country?
Hi Wishie
Where abouts are you in Aus, if in Brisbane there is a great repair centre at Yatla
 
Joined
May 19, 2016
Messages
578
Reaction score
234
Age
50
Location
Brisbane Australia
Hi Wishie
Where abouts are you in Aus, if in Brisbane there is a great repair centre at Yatla
Haha. That's the repair centre he is having the issues with.

I'm near Brisbane also.
 
Joined
Jan 13, 2018
Messages
42
Reaction score
5
Age
64
Haha. That's the repair centre he is having the issues with.

I'm near Brisbane also.

Wow, surprised at that, these guys have been looking after my craft and several referrals for a couple of years with great pricing and service, not sure of any other service centres locall.y
 
Joined
Feb 24, 2017
Messages
36
Reaction score
8
Age
41
I used to have a good relationship with that repair centre. But they've now had my Q500 4k and H for 5+ months.. and the "refurbished" unit I was given has been plagued with issues, and now they have accused me of stealing it.

Meanwhile, I am without a working drone, and am losing income because of it.

It is simply not good enough. Warranty was basically refused on every unit, also.
 

h-elsner

Premium Pilot
Joined
Mar 23, 2016
Messages
1,355
Reaction score
988
Location
Bavaria / Germany
This is really scary. I have never seen such a hughe delay between WLAN commands and RC-connection. And I have seen a lot of flight logs from all over the world.
Delay is usually between 100 and 200ms. And this is also hard to handle. I have had log from a guy whor forgot the bind to 2.4GHz RC after using the wizard. You can control the bird and fly around, but landing may hard in this case. He lost some props by that.

Here some pictures how it looks like in telemetry:
ScreenshotSchnellanalyse_1.png
ScreenshotDatei_sichten_1.png ScreenshotDatei_sichten_2.png

br HE
 
  • Like
Reactions: Dr Delta
Joined
Feb 24, 2017
Messages
36
Reaction score
8
Age
41
This is really scary. I have never seen such a hughe delay between WLAN commands and RC-connection. And I have seen a lot of flight logs from all over the world.
Delay is usually between 100 and 200ms. And this is also hard to handle. I have had log from a guy whor forgot the bind to 2.4GHz RC after using the wizard. You can control the bird and fly around, but landing may hard in this case. He lost some props by that.

Here some pictures how it looks like in telemetry:
View attachment 13453
View attachment 13454 View attachment 13455

br HE
Any idea of what the cause might be? And more importantly.. how I can attempt to fix it?
 
  • Like
Reactions: mastertek

h-elsner

Premium Pilot
Joined
Mar 23, 2016
Messages
1,355
Reaction score
988
Location
Bavaria / Germany
I have no idea. But there are two strange things:
- I cannot see in Ch0 at Remote_00033.csv the action of button B1 (mixed to J1) to arm the copter.
- There is no information about FW at your ST16. That means the serial connection beween cam and copter is not working or cam was not attached.

If this is not an warranty case, what else? The service has to fix it. I gueaa it needs a new CGO3+.

br HE
 

h-elsner

Premium Pilot
Joined
Mar 23, 2016
Messages
1,355
Reaction score
988
Location
Bavaria / Germany
Another idea is to create a new model from scratch and bind this one. Test it with/withou camera and let me see the flight logs.
Channel settings and all the stuff should be clean then with new model.

br HE
 
Joined
Feb 24, 2017
Messages
36
Reaction score
8
Age
41
Another idea is to create a new model from scratch and bind this one. Test it with/withou camera and let me see the flight logs.
Channel settings and all the stuff should be clean then with new model.

br HE
I'll charge it up and go for a test flights tomorrow after factory resetting everything and making a new model/bind
 
  • Like
Reactions: Dr Delta
Joined
Feb 24, 2017
Messages
36
Reaction score
8
Age
41
This is the video of the latest crash (from late December that broke my props etc..)

I still need to get the camera back in once piece, also.

 
Last edited:

New Threads

Members online

Forum statistics

Threads
19,900
Messages
230,054
Members
24,055
Latest member
chemiczny27