Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Typhoon H motor loose...WTF! Is it normal???

Joined
Mar 2, 2016
Messages
1
Reaction score
13
Location
Texas
I, too, get the 5 motor warning when accelerating without props on. However, it flies well with props on.
It is normal, I get it too, Just tried it out! It is showing you that there are 'NO" props on, or that one is missing , that's all. Good thing, not a bad thing! I am sure that the ESC, accelerometer can sense that there is a unbalance, but just ain't that smart to tell if it's one or all six. I tried with four props on like a quad and it does the same thing, even before it tries to lift!
 
Joined
Aug 2, 2016
Messages
5
Reaction score
3
Age
29
Hey Guys,

I've received my Typhoon H and I absolutely love it. I have since noticed that the motors don't quite seem to line up with one another. eg. they are not sitting level or square to the motor beside them and they seem to be slightly crooked compared to the level ground. Do you think that this will affect my flight? Should I straighten/level them out? Or should I just leave them the way that they are?
 
Joined
Feb 8, 2016
Messages
22
Reaction score
12
Age
61
Hey Guys,

I've received my Typhoon H and I absolutely love it. I have since noticed that the motors don't quite seem to line up with one another. eg. they are not sitting level or square to the motor beside them and they seem to be slightly crooked compared to the level ground. Do you think that this will affect my flight? Should I straighten/level them out? Or should I just leave them the way that they are?

I worried about that too but after a lot of googling it seems that not only is it normal, it is by design.
 

New Threads

Forum statistics

Threads
17,025
Messages
198,831
Members
19,693
Latest member
HJLally