Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Crash at start up?! Didn't even touch control?

Joined
May 21, 2016
Messages
3
Reaction score
1
Age
31
On the boat yesterday, I went to launch off the bow as I have always done. All satellite connected. Everything ready. Led purple in angle mode. I press the red button to start the motors. At that moment the motors start. I'm not touching any of the controls. The motors seemed to throttle up on their own flipping it on its side and almost off the boat into the lake. Broke 3 propellers luckily getting caught up on the rails around the bow. Lost all confidence as of now to fly over water. Why would it take off and flip at startup? Only crash I've had and it's drone error. Not pilot error. Please help
 
Joined
Mar 2, 2016
Messages
1
Reaction score
13
Location
Texas
On the boat yesterday, I went to launch off the bow as I have always done. All satellite connected. Everything ready. Led purple in angle mode. I press the red button to start the motors. At that moment the motors start. I'm not touching any of the controls. The motors seemed to throttle up on their own flipping it on its side and almost off the boat into the lake. Broke 3 propellers luckily getting caught up on the rails around the bow. Lost all confidence as of now to fly over water. Why would it take off and flip at startup? Only crash I've had and it's drone error. Not pilot error. Please help
Where you in Smart Mode by chance? That would answer all!:rolleyes:
 
Joined
May 21, 2016
Messages
3
Reaction score
1
Age
31
Local RC shop said it could have been the accelerometer reading The Rock of the boat and trying to adjust
 

New Threads

Forum statistics

Threads
16,814
Messages
196,235
Members
19,509
Latest member
Bud Nubby