Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

Is IPS an inside joke?

In this case, I have no idea where is the problem. Probably the firmware version of the drone or the ST is not the last or something other. Sorry, I can't help more.
Yep, I've checked. Running latest firmware everywhere. Thanks for the assist.
 
This is a procedure to use IPS without an RS or for what?
It is just a way to force IPS mode. IPS mode requires the RealSense module for the bottom Sonar sensors and the Flow Camera sensor.

Forcing IPS allows it to be used even when GPS has enough satellites. A use case would be when flying under a canopy of trees where GPS alone can result in positional drift.
 
  • Like
Reactions: Vaklin
I get to the point of the H chirping back after the joystick+switch4 toggle process but never get gps ready.
Are you disabling GPS before you try to enter IPS mode? It is not necessary to do so and may be the reason GPS stays in Acquiring.
 
Smitty,
Just a note to let you know we are still looking at the issue. I now have a RealSense module installed on a TH that is/was giving symptoms very similar to yours. I got it to work. Once. Haven't tried a second time. I am working to determine if the last thing I changed was actually the solution or if it was just a fluke that the thing suddenly started to work properly.
 
Smitty,
Just a note to let you know we are still looking at the issue. I now have a RealSense module installed on a TH that is/was giving symptoms very similar to yours. I got it to work. Once. Haven't tried a second time. I am working to determine if the last thing I changed was actually the solution or if it was just a fluke that the thing suddenly started to work properly.
Awesome, thanks! I can get the GPS to go ready but only for a few sec and the motors still won't start. Beep chirp and whatnot. I appreciate the assist!
 
Smitty,
Just a note to let you know we are still looking at the issue. I now have a RealSense module installed on a TH that is/was giving symptoms very similar to yours. I got it to work. Once. Haven't tried a second time. I am working to determine if the last thing I changed was actually the solution or if it was just a fluke that the thing suddenly started to work properly.
@h-elsner and @Enrico Jorysch..
I installed a RealSense Module from an H Plus on a Typhoon H in an attempt to troubleshoot the issue of this thread.
Can either of you comment on whether the H Plus RealSense should be compatible with the Typhoon H?

It seems to be compatible from the visible indications. But it does not work. It mostly shows the symptoms as described by @SmittyInTheSky. There was a period of 5 consecutive boots with successful IPS initiation. The 5 successful starts followed removing and replacing the FC board. It then quit working again and is showing the same symptoms as before. Removing the FC board, cleaning the pins and reinstalling did not work a second time, hence the question of actual compatibility.
 
Last edited:
@WTFDproject try with the camera detached.
I just moved the RealSense to a different Typhoon H. In this TH, the FC board is so bad it will not even acquire GPS itself. My last hope of having a good FC board is to remove the last one I have not tried from another working drone. It is 1:00 AM here now. I will change the FC board in the morning, remove the camera and give it a good try.
 
@h-elsner and @Enrico Jorysch..
I installed a RealSense Module from an H Plus on a Typhoon H in an attempt to troubleshoot the issue of this thread.
Can either of you comment on whether the H Plus RealSense should be compatible with the Typhoon H?

It seems to be compatible from the visible indications. But it does not work. It mostly shows the symptoms as described by @SmittyInTheSky. There was a period of 5 consecutive boots with successful IPS initiation. The 5 successful starts followed removing and replacing the FC board. It then quit working again and is showing the same symptoms as before. Removing the FC board, cleaning the pins and reinstalling did not work a second time, hence the question of actual compatibility.
So I'm pretty sure I have the right model of everything. My antennas have the little plastic tubes attached and the ST16 has the three antennas. I'm pretty sure I have the "professional" series since it also came with the CGO3+ and not the 1" sensor camera that the "plus" comes with. It also came with the backpack that doesn't require the use of the foam block that comes in the regular box.

I see no indications that the kit was pieced together. Should be a "Typhoon H Pro with Intel RealSense". It's 28.5" blade tip to blade tip.
 
I just moved the RealSense to a different Typhoon H. In this TH, the FC board is so bad it will not even acquire GPS itself. My last hope of having a good FC board is to remove the last one I have not tried from another working drone. It is 1:00 AM here now. I will change the FC board in the morning, remove the camera and give it a good try.
Some encouraging progress. With the FC board from the working drone, both RealSense and IPS are apparently working as they should. IPS was manually engaged from the GPS fully acquired state, from the GPS fully acquired then disabled state, and the GPS disabled prior to fully acquired state. No flight test was done.
This apparent success would suggest the problem (at least on this TH setup) was marginal and defective FC boards. Most of the boards tested are clearly defective (immediate, relatively fast rotation on the Yaw axis). Two are capable of normal flight but show symptoms of some degradation when viewed on the GUI (slow rotation on the Yaw axis). This board looked better on the GUI than the others but was itself not really perfect (some drift on the YAW axis, but not a continuous rotation in either direction).
Too early to declare success. A known bad FC board will be reinstalled to see if the problem returns.
 
So I'm pretty sure I have the right model of everything. My antennas have the little plastic tubes attached and the ST16 has the three antennas. I'm pretty sure I have the "professional" series since it also came with the CGO3+ and not the 1" sensor camera that the "plus" comes with. It also came with the backpack that doesn't require the use of the foam block that comes in the regular box.

I see no indications that the kit was pieced together. Should be a "Typhoon H Pro with Intel RealSense". It's 28.5" blade tip to blade tip.
It's good to know your kit is probably an original unit. But my post was to question the validity of my known Frankenstein as a troubleshooting tool. The apparent success described in my last post suggests it may at least be close enough to provide us with some clues.
 
It's good to know your kit is probably an original unit. But my post was to question the validity of my known Frankenstein as a troubleshooting tool. The apparent success described in my last post suggests it may at least be close enough to provide us with some clues.
Hey, I really appreciate how far you're digging into this. Many thanks.
 
It's good to know your kit is probably an original unit. But my post was to question the validity of my known Frankenstein as a troubleshooting tool. The apparent success described in my last post suggests it may at least be close enough to provide us with some clues.
One thing I find is that my altitude estimate on the ST16 is wildly inaccurate over time (+/- 10 ft while stationary on the ground) but it looks OK in the GUI. Compass and accelerometer calibrations complete without issue.
 
One thing I find is that my altitude estimate on the ST16 is wildly inaccurate over time (+/- 10 ft while stationary on the ground) but it looks OK in the GUI. Compass and accelerometer calibrations complete without issue.
That's pretty normal for a TH. Actually, pretty normal for all the models.
 
I've connected both of my units to the gui and i think the one with the RS may have a bad gyro sensor? I see non-0 values for gyro deg/sec while idle.
 
  • Like
Reactions: Vaklin

Members online

Forum statistics

Threads
21,009
Messages
242,227
Members
27,577
Latest member
fantacmet