Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up
Joined
May 31, 2017
Messages
4
Reaction score
1
Hello all,
I have been flying my Q500 4K for over a year now but I took her out last night for a flight and I noticed that the fore and aft lights under the motors flashed. I guess more of a flicker, they turned off then on really quick stayed on for a few minutes then did it again, stayed on for a few more minutes and then did it again. I brought her down for the night as I have never noticed that before. The main LED was purple and I believe stayed that way as I was in GPS locked Angle mode. I cannot find anywhere that the "pylon" leds are supposed to do anything other than be steady on. Thoughts? Thank you
 
Joined
Apr 30, 2016
Messages
625
Reaction score
110
Location
Southwest United States
The only time I know for sure they flash different is when the battery is critically low but you would have known that I'm sure,
Seems I recall mine doing something similar but it's been a while since I've done a night flight.
 
  • Like
Reactions: RogueWolff
Joined
May 31, 2017
Messages
4
Reaction score
1
The only time I know for sure they flash different is when the battery is critically low but you would have known that I'm sure,
Seems I recall mine doing something similar but it's been a while since I've done a night flight.
Thanks for the reply Jafo. Yeah, this started shortly after take-off the battery had not reached a low voltage state as far as I know. The battery was freshly charged and the controller was not warning me. I will keep an eye on it and post more info/resolutions if I come across any. Thanks again!
 
  • Like
Reactions: Jafo

New Threads

Members online

Forum statistics

Threads
19,784
Messages
228,973
Members
23,750
Latest member
Nbet10z