Welcome to YuneecPilots.com!

Sign up and join the fastest growing Yuneec drone community.

Slow YAW response

Discussion in 'Typhoon H Discussion' started by Ken448, Aug 13, 2016.

  1. Ken448

    Joined:
    Nov 30, 2015
    Messages:
    27
    Likes Received:
    6
    Having an issue with YAW. Itll go left OK, but VERY SLOW right. If Im in turtle mode, it will barley yaw right at all, and in rabbit, its just kind of meh
    Travel on the yaw movement is low (73% left and 52% Right) when looking at the hardware menu.
    Is there a way to calibrate the sticks on the ST16???
     
  2. Bobjazz

    Joined:
    May 26, 2016
    Messages:
    221
    Likes Received:
    51
    Location:
    SF Bay Area, California
    Sounds to me like an offset in the channel settings since the travel is not the same on both sides of the stick. First you should check the hardware monitor (system settings>hardware monitor) to make sure the travel on the stick is ok (both directions should be equal). Make sure the graph at the bottom (J2) travels to ±100 when you move the left stick to the right and left. If that's OK, then it's probably an offset in the channel settings. This gets a little trickier and you should make a backup copy of your model in the model select section before doing anything else.
     
  3. Ken448

    Joined:
    Nov 30, 2015
    Messages:
    27
    Likes Received:
    6
    Still no luck. Sent Yuneec an email and shall report back. Hopefully I wont have to send the controller in..
     
  4. Gary Cyras

    Joined:
    Oct 8, 2016
    Messages:
    1
    Likes Received:
    0
    Hello, Did you ever get an solution to your issue. I am having the exact same problem on my Yuneec 4K.
    Please let me know.
    Thanks,
    Gary
     
  5. Ken448

    Joined:
    Nov 30, 2015
    Messages:
    27
    Likes Received:
    6
    After dealing with CS and tech support doing calibrations etc, it had to be sent to Yuneec to have the left stick replaced. Sucked to have to ship it in, and it took almost 2.5 weeks to get it back.
     
  6. Brian Mackey

    Joined:
    Aug 3, 2016
    Messages:
    1,024
    Likes Received:
    293
    Location:
    Eagle Idaho
    I had this issue and I had to re-calibrate with the rabbit and the turtle dead center for some reason -- Now it still goes faster left yaw if I am in turtle mode, but move just a tad out of turtle and everything is equal Odd! Oh and they should have crossed shipped you a new one!
     
  7. Ken448

    Joined:
    Nov 30, 2015
    Messages:
    27
    Likes Received:
    6
    shipping me a new one would have been great... But they simply wont. All good, while the H was down, I bought and got to know my p4 pretty well.
     
  8. Brian Mackey

    Joined:
    Aug 3, 2016
    Messages:
    1,024
    Likes Received:
    293
    Location:
    Eagle Idaho

    LOL
     
  9. Droneworld34

    Joined:
    Jun 5, 2017
    Messages:
    16
    Likes Received:
    3
    I know this post is old, but I'm having the same issue with my remote as well (ST16). I had the remote and the H in the case for a few weeks and now that I pulled it out attempting to fly my Typhoon H, The minute I hit the throttle, the H didn't want to come down or land. I had to grab it mid air and pull the battery out to kill the motors. When I got home to check the channels and the response, it showed the throttle was not moving to 100 % and the right side joystick for left, right, up and down was responding the same way. This can't be the joy sticks that are bad all of a sudden. Can anyone provide an idea of how to fix this?

    Thanks.
     
  10. Eagle's Eye Video

    Joined:
    Oct 16, 2016
    Messages:
    638
    Likes Received:
    210
    Location:
    Albuquerque NM
    ST-16 Calibration ( secret menu )

    couple of things... you need to make sure the the pan control is centered, as well
    as both the controls for tilt and turtle/rabbit or the calibration will not be successful.
    After getting all controls completed and showing green on both calibration screens,
    back out to the the main screen and reboot the ST-16.
     
    Landmanjeep likes this.
  11. Droneworld34

    Joined:
    Jun 5, 2017
    Messages:
    16
    Likes Received:
    3
    I did everything it said and all the boxes turn green except J1 and J3. They seem to stay red. I did this last night as well and nothing works to get them to go green. Is there something wrong here?
     
  12. Forrestt

    Joined:
    May 30, 2016
    Messages:
    392
    Likes Received:
    156
    Location:
    North Carolina
    Most likely you have the same problem as I just had with J1....dirty potentiometer. Electronic/contact cleaner will do the trick but be careful which kind you use as a lot of these cleaners will soften and mar plastic.
     
    #12 Forrestt, Aug 24, 2017
    Last edited: Aug 24, 2017
  13. Droneworld34

    Joined:
    Jun 5, 2017
    Messages:
    16
    Likes Received:
    3
    Thanks for the advice. Can you recommend a good cleaner that's safe?
     
  14. Forrestt

    Joined:
    May 30, 2016
    Messages:
    392
    Likes Received:
    156
    Location:
    North Carolina
    CRC makes a great cleaner just be sure to get the one marked "safe for plastic".