Hello Fellow Yuneec Pilot!
Join our free Yuneec community and remove this annoying banner!
Sign up

ST16 Problems

Joined
Oct 31, 2016
Messages
52
Reaction score
9
Age
54
Hello Everybody,

Even I think this is also related to the recent V3 update, I am opening a new discussion.

Since the V3 update
  1. I cannot calibrate the J2 channel anymore. The corresponding gauge remains red independent what I am doing.
  2. The Hardware Monitor is not showing any reaction to any of my commands
    Edit Funny, but it is working again after writing this post
Has somebody made the same observations?
J2 never properly worked but until now I could fix the issue by calibrating the ST16.
Edit I did some more checks on the J2 and found out that it is not going to zero when totally released. This is explaining my drifts I experienced. Because I switched to Mode 3 the Elevator Channel moved to the left stick. So I cannot blame V3 for the drifts, it's seems to me a hardware problem on the left stick. I also noted that the left and right amplitude is slow and never going to -100 / +100

What do you think, sending in/back the ST16?

Thank you and cheers

Beat
 
Last edited:
Joined
May 10, 2016
Messages
1,646
Reaction score
681
Age
64
Location
Melvin Michigan, In the thumb
Yes, Time to send in your ST-16. I know it is a pain to be without, but if your J2 is going out, what else is going out along with it but just has not shown up yet. Yuneec is very good about honoring their warranties. Give them a call, here in the USA they are even open on Saturday.
 
Joined
Oct 31, 2016
Messages
52
Reaction score
9
Age
54
Thank you for your reply Bob,

Well I am living in Switzerland hence US Yuneec CS is not an option. :(

I've investigated furhter and found out that when I am pushing the left stick quickly to the right and left, I am at least able to calibrate it in a way that it gets a green status. Still it will not move completely to the zero position. And I also don't get the full amplitude out of it. It remains in a range withing -80% and +80%. But hey, this I can program in the channel settings.



Here you can see as well that J2 is not moving into the neutral position. I've tried several times to calibrate the ST16 without any success.

At least this should work until we'll get a bad weather period so I can send in the ST16 ;)

Cheers

Beat
 

Attachments

Last edited:
Joined
May 7, 2016
Messages
1,140
Reaction score
358
Age
72
Location
Gurdon, Ar
Like Bob said send it in.
 
Joined
May 25, 2016
Messages
157
Reaction score
41
I had the same issue but with J1, able to calibrate had one flight then it came back again. It's with Yuneec now.
 
Joined
Sep 10, 2016
Messages
11
Reaction score
0
Age
61
I too have this issue with J2 and sometimes with J4. I also noticed it after Version 3 update, but it could have been there before. Got my RMA today. The H is already sent in due to crash that I now suspect was, at least partially, because of the S16 issues.
My J2 is very erratic and will jump from midpoint to 0 (full left) and very slowly return to midpoint. Similar seen on J4, but since calibration I have only seen minor lag or jump on J4.
Got my RMA today so it will go join it's flight partner to be fixed.
 
Last edited:
Joined
May 25, 2016
Messages
157
Reaction score
41
My issue with J1 was nothing to do with v3 update because it manifest itself on b22 firmware. I believe it's a physical issue rather software. Just got a new controller, not tested yet.
 
Joined
Aug 2, 2016
Messages
126
Reaction score
52
Daft question, but did you try this with the mode set to rabbit, not turtle?
 
Joined
Sep 10, 2016
Messages
11
Reaction score
0
Age
61
The erratic behavior was the same either way, just the endpoint, when it actually reached it, was less in turtle mode. It was in rabbit mode when I did this.
 
Joined
Dec 12, 2016
Messages
27
Reaction score
4
Location
Montreal, QC
Have experienced the same problem on YAW on my new ST16+ and have changed the yaw from left stick to the right joystick and it was perfect but then the left stick stayed erratic, so i feel that it is a hardware issue, luckily i have not tried to fly the H pro with that faulty controller.So I will be sending the unit back!
 

CraigCam

Premium Pilot
Joined
Oct 1, 2016
Messages
1,517
Reaction score
649
Age
60
Have experienced the same problem on YAW on my new ST16+ and have changed the yaw from left stick to the right joystick and it was perfect but then the left stick stayed erratic, so i feel that it is a hardware issue, luckily i have not tried to fly the H pro with that faulty controller.So I will be sending the unit back!
My left stick has behaved similarly. I'm so used to mode 2 so have not tried switching. For me, I do not get full right to yaw sometimes without a little upward swing but only In full turtle. Be careful playing with those curves because we can't see how the curves change with different speed settings. I did some hardware checks and recalibrated St 16 twice and it went back to behaving. I've found a slight bit of up to rabbit from full turtle gives me the control I'm looking for.


Sent from my iPad using Tapatalk Pro
 
  • Like
Reactions: CHO
Joined
Dec 12, 2016
Messages
27
Reaction score
4
Location
Montreal, QC
well I did another calibration... and this time made sure turtle-rabbit and camera pan side dials were 100% in the middle, now it seems 85% better the yaw J2 comes back in the 0% middle, just get a little lag once in a while but nothing drastic I tested again on the UAV-Pilot simulator and the behavior was much improved than before.
 

CraigCam

Premium Pilot
Joined
Oct 1, 2016
Messages
1,517
Reaction score
649
Age
60
well I did another calibration... and this time made sure turtle-rabbit and camera pan side dials were 100% in the middle, now it seems 85% better the yaw J2 comes back in the 0% middle, just get a little lag once in a while but nothing drastic I tested again on the UAV-Pilot simulator and the behavior was much improved than before.
Try it again. You can get better at it and it does help. I got 100% back on second try. Make sure you go in circles on the sticks and even when I get the green ok finish my stick circle. It cannot hurt.


Sent from my iPad using Tapatalk Pro
 
Joined
Oct 31, 2016
Messages
52
Reaction score
9
Age
54
Yep, tried it again today and surprisingly it worked this time. I was able to calibrate J2 and don't see any deviation now in the zero position.

Stange... but ok

Cheers
 

CraigCam

Premium Pilot
Joined
Oct 1, 2016
Messages
1,517
Reaction score
649
Age
60
Yep, tried it again today and surprisingly it worked this time. I was able to calibrate J2 and don't see any deviation now in the zero position.

Stange... but ok

Cheers
It learns that's why. Remember it's got Intel inside....it can be so smart it's dumb.


Sent from my iPad using Tapatalk Pro
 

New Threads

Members online

Forum statistics

Threads
17,030
Messages
198,904
Members
19,701
Latest member
mkrassovski